在线检测未来函数

通达信资金流向统计主图指标公式

来源:Internet,编辑:股旁网,2014-09-10

{沪主1:="999999$AMOUNT"/100000000,NODRAW;}
沪主:=STRCAT(STRCAT('沪主:' ,CON2STR("999999$AMOUNT"/100000000,2)),' 亿 ');
{深主1:="399001$AMOUNT"/100000000,NODRAW;}
深主:=STRCAT(STRCAT('深主:' ,CON2STR("399001$AMOUNT"/100000000,2)),' 亿 ');
{中小1:="399005$AMOUNT"/100000000,NODRAW;}
中小:=STRCAT(STRCAT('中小:' ,CON2STR("399005$AMOUNT"/100000000,2)),' 亿 ');
{创业1:="399006$AMOUNT"/100000000,NODRAW;}
创业:=STRCAT(STRCAT('创业:' ,CON2STR("399006$AMOUNT"/100000000,2)),' 亿 ');
{总额1:沪主1+深主1+中小1+创业1;}
额:=("999999$AMOUNT"+"399001$AMOUNT"+"399005$AMOUNT"+"399006$AMOUNT")/100000000;
{Y:=("999999$AMOUNT"/100000000+"399001$AMOUNT"/100000000+"399005$AMOUNT"/100000000+"399006$AMOUNT"/100000000);}
总额:=STRCAT(STRCAT('总额:' ,CON2STR(额,2)),' 亿 ');
昨沪主:=STRCAT(STRCAT('昨沪主:' ,CON2STR(REF("999999$AMOUNT"/100000000,1),2)),' 亿 ');
{昨深主:=REF(深主,1);}
昨深主:=STRCAT(STRCAT('昨深主:' ,CON2STR(REF("399001$AMOUNT"/100000000,1),2)),' 亿 ');
{昨中小:=REF(中小,1);}
昨中小:=STRCAT(STRCAT(' 昨中小:' ,CON2STR(REF("399005$AMOUNT"/100000000,1),2)),' 亿 ');
{昨创业:=REF(创业,1);}
昨创业:=STRCAT(STRCAT(' 昨创业:' ,CON2STR(REF("399006$AMOUNT"/100000000,1),2)),' 亿 ');
{昨总额:=REF(总额,1);}
昨总额:=STRCAT(STRCAT('昨总额:' ,CON2STR(REF(("999999$AMOUNT"+"399001$AMOUNT"+"399005$AMOUNT"+"399006$AMOUNT")/100000000,1),2)),' 亿 ');
{沪主【差】:=沪主-昨沪主;}
沪主【差】:=STRCAT(STRCAT('沪主【差】:' ,CON2STR(("999999$AMOUNT"/100000000-REF("999999$AMOUNT"/100000000,1)),2)),' 亿 ');
{深主【差】:=深主-昨深主;}
深主【差】:=STRCAT(STRCAT('深主【差】:' ,CON2STR(("399001$AMOUNT"/100000000-REF("399001$AMOUNT"/100000000,1)),2)),' 亿 ');
{中小【差】:=中小-昨中小;}
中小【差】:=STRCAT(STRCAT('中小【差】:' ,CON2STR(("399005$AMOUNT"/100000000-REF("399005$AMOUNT"/100000000,1)),2)),' 亿 ');
{创业【差】:=创业-昨创业;}
创业【差】:=STRCAT(STRCAT('创业【差】:' ,CON2STR(("399006$AMOUNT"/100000000-REF("399006$AMOUNT"/100000000,1)),2)),' 亿 ');
{总额【差】:=总额-昨总额;}
总额【差】:=STRCAT(STRCAT('总额【差】:' ,CON2STR((("999999$AMOUNT"+"399001$AMOUNT"+"399005$AMOUNT"+"399006$AMOUNT")/100000000-
REF(("999999$AMOUNT"+"399001$AMOUNT"+"399005$AMOUNT"+"399006$AMOUNT")/100000000,1)),2)),' 亿 ');
{总额【差】:=STRCAT(STRCAT('总额【差】:' ,CON2STR((总额-REF(总额,1)),2)),' 亿 ');}
A:=STRCAT(昨沪主 , STRCAT( 沪主, 沪主【差】 ));
B:=STRCAT(昨深主 , STRCAT( 深主, 深主【差】 ));
D:=STRCAT(昨中小 , STRCAT( 中小, 中小【差】 ));
E:=STRCAT(昨创业 , STRCAT( 创业, 创业【差】 ));
F:=STRCAT(昨总额 , STRCAT( 总额, 总额【差】 ));
DRAWTEXT_FIX(ISLASTBAR,0.03,0.09,0,A),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.03,0.15,0,B),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.03,0.21,0,D),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.03,0.27,0,E),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.03,0.33,0,F),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,' 收盘前查看'),COLORYELLOW;

通达信资金流向统计主图指标公式

 

相关文章