在线检测未来函数

大智慧正负电图指标公式

来源:Internet,编辑:股旁网,2014-09-12

DRAWGBK(CLOSE > 0,STRIP(RGB(0,0,333),RGB(0,0,688),0));
VAR0:=EMA((HHV(HIGH,5) - CLOSE)/(HHV(HIGH,5) - LLV(LOW,5)) * 100,2);
VAR1:=EMA((CLOSE - HHV(HIGH,5))/(HHV(HIGH,5) - LLV(LOW,5)) * 100,2) + 100;
VAR2:=BARSLAST(CROSS(CLOSE,EMA(CLOSE,4)));
VAR3:=BARSLAST(CROSS(EMA(CLOSE,4),CLOSE));
VAR4:=IF(VAR2 > VAR3,VAR2,0);
VAR5:=IF(VAR2 < VAR3,VAR3,0);
VAR6:=1;
VAR7:=-1;
正电图:VAR6 + SIN(VAR5),LINETHICK2;
负电图:VAR7 + SIN(VAR4),LINETHICK2;
PARTLINE(VAR6 + SIN(VAR5),VAR0 < VAR1,RGB(255,0,0),VAR0 > VAR1,RGB(0,250,0)),LINETHICK2;
PARTLINE(VAR7 + SIN(VAR4),VAR0 < VAR1,RGB(255,0,255),VAR0 > VAR1,RGB(250,250,0)),LINETHICK2;

大智慧正负电图指标公式

 

相关文章