在线检测未来函数

通达信梧桐龙凤主图指标公式

来源:Internet,编辑:股旁网,2014-09-16

A:=EMA(C,2);
B:=EMA(SLOPE(C,20)*20+C,40);
STICKLINE(A>=B,REFDATE(HHV(H,100),DATE),H*1.01,5,0),COLOR000055;
STICKLINE(A<B,REFDATE(HHV(H,100),DATE),H*1.01,5,0),COLOR663300;
高1:=REF(HHV(H,100),3);
低1:=REF(LLV(L,100),3);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
基准:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1));
STICKLINE(A1X>=0,基准,突破,5,0),COLOR000099;
STICKLINE(A1X<0,基准,突破,5,0),COLOR00CC66;
AA:=CROSS(A1X,0),LINETHICK0;
BB:=CROSS(0,A1X),LINETHICK0;
DRAWICON(AA,基准*0.98,34);
DRAWICON(BB,基准*1.015,35);
N1:=50;
K:=BARSLAST(CURRBARSCOUNT=N1);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));
KJ:=GD-DD;
平衡:=IF(CURRBARSCOUNT<=N1,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
压力:=IF(CURRBARSCOUNT<=N1,GD-KJ*0.191,DRAWNULL),COLORFF00FF,NODRAW;
支撑:=IF(CURRBARSCOUNT<=N1,DD+KJ*0.191,DRAWNULL),COLOR00FF00,NODRAW;
高区:IF(CURRBARSCOUNT<=N1,GD,DRAWNULL),COLORRED,DOTLINE;
低区:IF(CURRBARSCOUNT<=N1,DD,DRAWNULL),COLOR00FF00,DOTLINE;
STICKLINE(CURRBARSCOUNT=N1,GD,DD,0,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=N1/2,GD,DD,0,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT<=N1,平衡,平衡,3,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT<=N1/2,压力,压力,3,-1),COLORRED;
STICKLINE(CURRBARSCOUNT<=N1/2,支撑,支撑,3,-1),COLORGREEN;
DRAWKLINE(H,O,L,C);
N:=1;
XOPEN:=(REF(O,N)+REF(C,N))/2;
XCLOSE:=CLOSE;
XHIGH:=MAX(HIGH,XOPEN);
JJ:=DATE;
TJJ:=JJ<=20991029;
XLOW:=MIN(LOW,XOPEN);
VOLALITY:=MA(XHIGH-XLOW,8);
龙线:MA(XCLOSE,5)+VOLALITY/2,COLOR0000FF;
凤线:MA(XCLOSE,5)-VOLALITY/2,COLORFF0000;
T1:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1));
CC:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST(CURRBARSCOUNT>CC+T1 AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST(CURRBARSCOUNT>CC+T2 AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3));
猎击线:DRAWLINE(CURRBARSCOUNT=T3+5, T3HIGH, ISLASTBAR, T3HIGH, 1),DOTLINE,COLORYELLOW;
DRAWTEXT(ISLASTBAR, T3HIGH, ' 猎'),COLORYELLOW;
M:=10;
T4:=CONST(HHVBARS(V,10)),COLORBLUE,LINETHICK1;
量能平台:IF(CURRBARSCOUNT<=M+15,CONST(IF(T4=0,C,REF(C,T4))),DRAWNULL)COLORWHITE,LINETHICK2;
BU:=CROSS(XCLOSE,龙线);
SEL:=CROSS(凤线,XCLOSE);
VAR1:=BARSLAST(BU);
VAR2:=BARSLAST(SEL);
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,O,C,3,0 ),COLORBB00CC;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,O,C,2,0 ),COLORCC00CC;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,O,C,1,0 ),COLORDD00CC;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,O,C,0,0 ),COLORFF00CC;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,O,C,3,0 ),COLOR00AAFF;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,O,C,2,0 ),COLOR00BBFF;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,O,C,1,0 ),COLOR00CCFF;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,O,C,0,0 ),COLOR00DDFF;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,O,C,3,0 ),COLORFFBB00;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,O,C,2,0 ),COLORFFCC00;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,O,C,1,0 ),COLORFFDD00;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,O,C,0,0 ),COLORFFFF00;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,O,C,3,0 ),COLORBB0000;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,O,C,2,0 ),COLORCC0000;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,O,C,1,0 ),COLORDD0000;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,O,C,0,0 ),COLORFF0000;
DRAWICON(REF(VAR1,1)>VAR2 AND VAR1=0,XLOW*0.98,7);
DRAWICON(REF(VAR2,1)>VAR1 AND VAR2=0,XHIGH*1.01,8);
所属地域:DRAWTEXT_FIX(ISLASTBAR ,0.05,0.01,1,DYBLOCK),COLORYELLOW;
所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.06,0.01,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.11,0.01,0,EXTERNSTR(0,6)),COLORYELLOW;
DRAWTEXT_FIX(1,0.12,0.01,0,EXTERNSTR(0,1))COLORYELLOW;
IF(CURRBARSCOUNT=T4+1,量能平台,DRAWNULL),CIRCLEDOT,COLORWHITE,LINETHICK2;
A1:=BARSLAST(MONTH!=REF(MONTH,1))+1;
月±%:(CLOSE/REF(CLOSE,A1)-1)*100,COLORWHITE,NODRAW;

通达信梧桐龙凤主图指标公式

 

相关文章