在线检测未来函数

同花顺极品CCI指标公式

来源:Internet,编辑:股旁网,2014-09-19

N:=14;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
DRAWTEXT(CROSS(200,CCI),250,'下穿200'),colorgreen;
DRAWTEXT( CROSS(CCI,-200),-150,'上穿-200'),coloryellow;
DRAWTEXT( CROSS(CCI,-100),-100,'上穿-100'),COLORFF00FF;
STICKLINE(CCI>0,0,CCI,1,0),colorred;
STICKLINE(CCI<0,0,CCI,1,0),colorligreen;
STICKLINE(CROSS(CCI,-200) AND CCI>REF(CCI,1),CCI,0,1,0),coloryellow;
STICKLINE(CROSS(200,CCI) AND CCI<REF(CCI,1),0,CCI,1,0),colorgreen;
CCI70:(TYP-MA(TYP,70))/(0.015*AVEDEV(TYP,70)),coloryellow,LINETHICK2;
差值:=CCI70-REF(CCI70,1);
IF(差值>0,CCI70,DRAWNULL),coloryellow,LINETHICK2;
IF(差值<0,CCI70,DRAWNULL),colorblue,LINETHICK2;
逃顶线:200,colorgreen;
强势线:100,colorred,LINETHICK2;
趋势线:CCI,colorgray,LINESTICK,LINETHICK1;
中轴线:0,coloryellow,LINETHICK1;
抄底线:-100,colorwhite;
弱势线:-200,colorgreen;
DRAWICON(CROSS(CCI,-100) OR (REF(CCI,1)>-100 AND REF(CCI,1)<-95 AND CCI>REF(CCI,1)),CCI-0.03,1);
DRAWICON(CROSS(100,CCI) OR (REF(CCI,1)<100 AND REF(CCI,1)>95 AND CCI<REF(CCI,1)),CCI+0.03,2);

同花顺极品CCI指标公式

 

相关文章