在线检测未来函数

通达信强度尺指标公式

来源:Internet,编辑:股旁网,2014-09-17

G6:=(C-REF(C,5))/REF(C,5);
G12:=(C-REF(C,10))/REF(C,10);
G24:=(C-REF(C,21))/REF(C,21);
G36:=(C-REF(C,42))/REF(C,42);
G72:=(C-REF(C,63))/REF(C,63);
G144:=(C-REF(C,126))/REF(C,126);
G240:=(C-REF(C,252))/REF(C,252);
DP6:=(INDEXC-REF(INDEXC,5))/REF(INDEXC,5);
DP12:=(INDEXC-REF(INDEXC,10))/REF(INDEXC,10);
DP24:=(INDEXC-REF(INDEXC,21))/REF(INDEXC,21);
DP36:=(INDEXC-REF(INDEXC,42))/REF(INDEXC,42);
DP72:=(INDEXC-REF(INDEXC,63))/REF(INDEXC,63);
DP144:=(INDEXC-REF(INDEXC,126))/REF(INDEXC,126);
DP240:=(INDEXC-REF(INDEXC,252))/REF(INDEXC,252);
S6:=G6-DP6,LINETHICK2;
S12:=G12-DP12,LINETHICK2;
S24:=G24-DP24,LINETHICK2;
S36:=G36-DP36;
S72:=G72-DP72;
S144:=G144-DP144;
S240:=G240-DP240;
强度:(ema((7*S6+6*S12+5*S24+4*S36+3*S72+2*S144+S240)/28,6)+EMA(SLOPE((7*S6+6*S12+5*S24+4*S36+3*S72+2*S144+S240)/28,6),6))*6.125,LINETHICK2,COLORRED;
动态:EMA(强度,5),COLORGREEN;
ZDS:HHV(MAX(S6,MAX(S12,MAX(S24,MAX(S36,MAX(S72,MAX(S144,S240)))))),126),COLORWHITE,DOTLINE;
ZXS:LLV(MIN(S6,MIN(S12,MIN(S24,MIN(S36,MIN(S72,MIN(S144,S240)))))),42),COLORAAAA00,DOTLINE;
DMS:EMA(((ZDS+ZXS))/2,21),COLOR00CCCC,DOTLINE;

通达信强度尺指标公式

 

相关文章