在线检测未来函数

通达信双周期CCI指标公式

来源:Internet,编辑:股旁网,2014-09-18

DRAWGBK(C>0,RGB(20,10,80),RGB(10,1,5),1,0,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI84:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),COLORLICYAN;
DRAWBAND(100,RGB(0,50,50),CCI84,RGB(100,10,0));
CCI14:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORLIRED;
主力资金线:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
VAR2LL:=HHV(主力资金线>20,10);
STICKLINE(VAR2LL AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),CCI14,100,1,0),COLORBROWN; {危险:};
VAR1T:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2T:=2*ABS(VAR1T);
VAR5T:=(HIGH+LOW+CLOSE)/3;
VAR6T:=(VAR5T-MA(VAR5T,14))/(0.015*AVEDEV(VAR5T,14));
VAR7T:=(VAR5T-MA(VAR5T,70))/(0.015*AVEDEV(VAR5T,70));
VAR8T:=IF(VAR6T>=150 AND VAR6T<200 AND VAR7T>=150 AND VAR7T<200,10,0);
VAR9T:=IF(VAR6T<=-150 AND VAR6T>-200 AND VAR7T<=-150 AND VAR7T>-200,-10,VAR8T);
VARAT:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARBT:=100-ABS(VARAT);
预警系统:=IF(VAR7T>=200 AND VAR6T>=150,100,IF(VAR7T<=-200 AND VAR6T<=-150,-100,VAR9T))+0;
DRAWBAND(预警系统,RGB(10,100,10),0,RGB(100,10,0));
天线:=IF(VARBT<90,VARBT,60);
红军:=IF(VAR1T>0,VAR1T,0),COLORRED, LINESTICK;
VAR24:=红军>48 AND 预警系统>60 AND 天线<100;
DRAWICON(COUNT(CROSS(2,预警系统),15)>=1 AND CROSS(100,CCI14),100,2);
DRAWICON(COUNT(CROSS(预警系统,-2),15)>=1 AND CROSS(CCI14,0),-100,1);
350,COLOR004400,POINTDOT;
220,COLORMAGENTA,POINTDOT;
水面:100,COLORGRAY;
0,COLORLICYAN,POINTDOT;
-100,POINTDOT,COLORYELLOW;
-220,COLORBLUE,POINTDOT;

通达信双周期CCI指标公式

 

相关文章