在线检测未来函数

通达信拉升涨停主图指标公式

来源:Internet,编辑:股旁网,2014-09-20

N:=5;
N1:=3;
H1:EMA(CLOSE,N);
H2:EMA(H1,N1);
VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,5,1);
VAR3:=SMA(VAR2,8,1);
VAR4:=CROSS(VAR2,VAR3) AND VAR3<20;
VAR5:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR4;
VAR6:=IF(CLOSE>1000,VAR4,VAR5);
DRAWICON(VAR6,H,2);
DRAWTEXT(CROSS(H1,H2),H1*0.99,'○买点'),COLORYELLOW;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
取舍线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,LINETHICK1,COLORYELLOW;
STICKLINE(C>取舍线,O,C,2,0),COLORRED;
STICKLINE(C<取舍线,O,C,2,0),COLORGREEN;
DRAWICON(CROSS(C,取舍线),L,1);
DRAWICON(CROSS(取舍线,C),H,2);
DRAWICON(CROSS(C,取舍线),L,26);
{缺口}
STICKLINE(L>REF(H,1) ,REF(H,1),L,1,-1),COLOR990099;
STICKLINE(H<REF(L,1) ,REF(L,1),H,1,-1),COLOR999900;
DRAWKLINE(H,O,L,C);
{涨停分类}
个线:=EMA(EMA(CLOSE,30),9);
大线:=EMA(EMA(INDEXC,45),9);
个股1:=CLOSE/个线*100;
大盘1:=INDEXC/大线*100;
GGQD:=(个股1-大盘1);
回光返照:=COUNT(CROSS(MA(C,15),MA(C,5)),N1)=0 AND HHV(GGQD,20)>23 AND MA(C,5)>MA(C,30) AND GGQD<HHV(GGQD,30) AND GGQD>5 AND (C-REF(C,1))/REF(C,1)*100>9.6 AND C=H,;
ZT:=(C-REF(C,1))/REF(C,1)*100>8.5,COLORWHITE;
开盘:=IF(REF(ZT,1)>0 ,(O-REF(C,1))/REF(C,1)*100,0),NODRAW;
BIAS1 :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIA:=(BIAS1-BIAS2);
BIS:=LLV(BIAS1,3);
超跌涨停:=ZT>0 AND BIS<0 AND BIA>5 AND MA(C,5)<MA(C,60);
DRAWTEXT(超跌涨停,L*0.98,'超跌涨停'),COLORGREEN;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20) ;
MA30:=MA(C,30);
MA60:=MA(C,34);
F1:=(MA5-MA10)/MA10*100;
F2:=(MA10-MA20)/MA10*100;
F3:=(MA20-MA60)/MA10*100;
拉升涨停:=F1>1 AND F2>3 AND F3>0 AND ZT>0;
A1:=REF(C,20)=HHV(C,2*20+1);B1:=FILTER(A1,20);C1:=BACKSET(B1,20+1);HD:=FILTER(C1,20);
A:=REF(H,BARSLAST(HD));
RSI1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
钝化涨停:=ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80;
钝化涨停1:=GGQD>15 AND ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80 AND REF(GGQD>15 AND ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80,1)=0;
新股首次:=COUNT(ZT>0,BARSCOUNT(C))=1 AND ZT>0 AND FINANCE(42)<100;
突破涨停:=CROSS(C,A) AND ZT>0;
DRAWTEXT(回光返照,L*0.99,'回光返照'),COLORBLUE;
DRAWTEXT(拉升涨停,L*0.98,'拉升涨停'),COLORRED;
DRAWTEXT(突破涨停,L*0.97,'突破涨停'),COLORYELLOW;
DRAWTEXT(新股首次,L*0.96,'新股首次'),COLORMAGENTA;
DRAWTEXT(钝化涨停1,L*0.95,'钝化涨停1'),COLORLIRED;
DRAWTEXT(钝化涨停,L*0.94,'钝化涨停'),COLORLIBLUE;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(涨停)),REF(HIGH,BARSLAST(涨停)),0.1,0),COLORDDDD00;
STICKLINE(CLOSE,REF(LOW,BARSLAST(涨停)),REF(LOW,BARSLAST(涨停)),0.1,0),COLOR00DDDD;

通达信拉升涨停主图指标公式

 

相关文章