在线检测未来函数

通达信玩玩主图指标公式

来源:Internet,编辑:股旁网,2014-09-22

股旁网 := EMA((C + REF(C,1)) / 2,3);
⑤日 : EMA(EMA((C + REF(C,1)) / 2,3),2),NODRAW,COLORLIGRAY;
⑩日 : IF(WMA(C,15) = DRAWNULL,EMA(⑤日,6),WMA(C,15)),NODRAW,COLORYELLOW;
多空 : (⑩日 + EMA(EMA(⑩日,9),2)) / 2,NODRAW,COLOR8050B0;
20日 : EMA(EMA(⑩日,10),2),NODRAW,COLORMAGENTA;
60日 : MA(CLOSE,60),COLOR008000;
半年 : MA(CLOSE,120),COLOR996666;
年 : MA(CLOSE,250),COLORA00000;
GJ := IF(FINANCE(19) != 0,IF(C = INDEXC,(((INDEXC + INDEXH) + INDEXL) + INDEXO) / 4,(AMOUNT / (V + 0.01)) / 100),DRAWNULL);
撑 : REF(L + (C - GJ),1),NODRAW,COLOR00B000;
GAA := REF(HIGH,1);
GBB := REF(LOW,1);
GCC := REF(OPEN,1);
GDD := REF(CLOSE,1);
GEE := (((GAA + GBB) + GCC) + (2 * GDD)) / 5;
GAAA := GEE + (GAA - GBB);
GBBB := (2 * GEE) - GBB;
GCCC := (2 * GEE) - GAA;
GDDD := GEE - (GAA - GBB);
上升突破价 := GAAA;
上升阻力价 := GBBB;
下跌支撑价 := GCCC;
下跌反转价 := GDDD;
EEE := ((((GEE + 上升突破价) + 上升阻力价) + 下跌支撑价) + 下跌反转价) / 5;
心理 : IF(FINANCE(19) != 0,EEE,DRAWNULL),NODRAW,COLOR2060A0;
阻 : REF((L + (GJ - L)) + (C - L),1),NODRAW,COLORA00099;
进 := IF(FINANCE(19) != 0,EMA(((O + H) + L) / 3,4),DRAWNULL);
卖点 := (EMA(C + ((H - L) * 0.618),3)) + (((EMA(C + ((H - L) * 0.618),3)) - 进) * 0.618);
卖 : REF(明卖点,1),NODRAW,COLORFF6600;
MID := MA(C,20);
布林VAR1 := POW(C - MID,2);
布林VAR2 := IF(MA(布林VAR1,20) = DRAWNULL,EMA(布林VAR1,20),MA(布林VAR1,20));
布林VAR3 := SQRT(布林VAR2);
UPPER := MID + (2 * 布林VAR3);
LOWER := MID - (2 * 布林VAR3);
BOLL := REF(MID,1);
UB上 := REF(UPPER,1);
BL中 := BOLL;
LB下 := REF(LOWER,1);
XCC := (ABS(((((2 * CLOSE) + HIGH) + LOW) / 4) - MA(CLOSE,20))) / MA(CLOSE,20);
XDD := DMA(CLOSE,XCC);
XS通道上 := (1 + (7 / 100)) * XDD;
XS通道下 := (1 - (7 / 100)) * XDD;
XSN := 13;
XSVAR2 := CLOSE * VOL;
XSVAR3 := EMA(((((EXPMA(XSVAR2,3) / EXPMA(VOL,3)) + (EXPMA(XSVAR2,6) / EXPMA(VOL,6))) + (EXPMA(XSVAR2,12) / EXPMA(VOL,12))) + (EXPMA(XSVAR2,24) / EXPMA(VOL,24))) / 4,XSN);
SUP := 1.06 * XSVAR3;
SDN := XSVAR3 * 0.94;
XSVAR4 := EXPMA(CLOSE,9);
LUP := EXPMA(XSVAR4 * 1.14,5);
LDN := EXPMA(XSVAR4 * 0.86,5);
XS压 : IF((LUP <= MIN(UB上,MIN(XS通道上,UB上))) OR (MIN(UB上,MIN(XS通道上,UB上)) = DRAWNULL),LUP,MIN(UB上,MIN(XS通道上,UB上))),DOTLINE,COLORCC66AA;
XS底 : IF((LDN >= MAX(LB下,MIN(XS通道下,BL中))) OR (MAX(LB下,MIN(XS通道下,BL中)) = DRAWNULL),LDN,MAX(LB下,MIN(XS通道下,BL中))),DOTLINE,COLORAA9900;
明日AA := HIGH;
明日BB := LOW;
明日CC := OPEN;
明日DD := CLOSE;
明日EE := (((明日AA + 明日BB) + 明日CC) + (2 * 明日DD)) / 5;
明日AAA := 明日EE + (明日AA - 明日BB);
明日BBB := (2 * 明日EE) - 明日BB;
明日CCC := (2 * 明日EE) - 明日AA;
明日DDD := 明日EE - (明日AA - 明日BB);
明日上升突破价 := 明日AAA;
明日上升阻力价 := 明日BBB;
明日下跌支撑价 := 明日CCC;
明日下跌反转价 := 明日DDD;
明日EEE := ((((明日EE + 明日上升突破价) + 明日上升阻力价) + 明日下跌支撑价) + 明日下跌反转价) / 5;
动态买点 : IF(FINANCE(19) != 0,(EMA(((O + H) + L) / 3,4)) + ((((H + L) / 2) - (REF(((O + H) + L) / 3,3))) / 4),DRAWNULL),NODRAW,COLOR8080FF;
明日心理 : IF(FINANCE(19) != 0,明日EEE,DRAWNULL),NODRAW,COLOR0066CC;
明撑 : L + (C - GJ),NODRAW,COLOR40CC00;
明阻 : (L + (GJ - L)) + (C - L),NODRAW,COLORFF0080;
明卖 : (EMA(C + ((H - L) * 0.618),3)) + (((EMA(C + ((H - L) * 0.618),3)) - 进) * 0.618),NODRAW;
多空上轨区 : DRAWBAND(XS压,RGB(32,16,43),20日,RGB(0,0,0));
多空下轨区 : DRAWBAND(20日,RGB(16,32,43),XS底,RGB(0,0,0));
XS压力区 : DRAWBAND(XS压,RGB(32,16,43),MA(C,20),RGB(0,0,0));
XS下轨区 : DRAWBAND(MA(C,20),RGB(16,32,43),XS底,RGB(0,0,0));
20日多空彩带 : DRAWBAND(多空,RGB(82,0,102),20日,RGB(0,51,128));
⑩日多空线彩带 : DRAWBAND(⑩日,RGB(64,64,32),多空,RGB(0,80,128));
全年线 : DRAWBAND(年,RGB(0,0,160),年,RGB(0,0,255));
半年线 : DRAWBAND(半年,RGB(102,102,153),半年,RGB(128,128,192));
60日线 : DRAWBAND(60日,RGB(0,128,0),60日,RGB(0,255,0));
⑩日线 : DRAWBAND(⑩日,RGB(0,89,108),⑩日,RGB(0,0,0));
多空线 : DRAWBAND(多空,RGB(0,102,128),多空,RGB(0,0,0));
20日线 : DRAWBAND(20日,RGB(0,113,136),20日,RGB(0,0,0));
压力显示周期 := ((((PERIOD = 3) OR (PERIOD = 4)) OR (PERIOD = 5)) OR (PERIOD = 6)) OR (PERIOD = 2);
卖画线 := IF((HOUR != 0) AND (V = 0),DRAWNULL,卖);
阻画线 := IF((HOUR != 0) AND (V = 0),DRAWNULL,阻);
心理画线 := IF((HOUR != 0) AND (V = 0),DRAWNULL,心理);
撑画线 := IF((HOUR != 0) AND (V = 0),DRAWNULL,撑);
卖点价位 : STICKLINE(1,IF(压力显示周期 AND ISLASTBAR,卖画线,DRAWNULL),卖画线,45,IF(C >= 卖画线,-1,0)),COLORFF4000;
阻力价位 : STICKLINE(1,IF(压力显示周期 AND ISLASTBAR,阻画线,DRAWNULL),阻画线,53,IF(C >= 阻画线,-1,0)),COLORA00099;
心理价位 : STICKLINE(1,IF(压力显示周期 AND ISLASTBAR,心理画线,DRAWNULL),心理画线,69,IF(C >= 心理画线,-1,0)),COLOR2060A0;
支撑价位 : STICKLINE(1,IF(压力显示周期 AND ISLASTBAR,撑画线,DRAWNULL),撑画线,87,IF(C >= 撑画线,0,-1)),COLOR408000;
VAR1 := (CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2));
VAR2 := (REF(VAR1,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR3 := (REF(VAR2,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VAR4 := (REF(VAR3,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR5 := (REF(VAR4,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VAR6 := (REF(VAR5,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR7 := (REF(VAR6,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VAR8 := (REF(VAR7,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR9 := (REF(VAR8,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VARA := (REF(VAR9,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VARB := (REF(VARA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VARC := (REF(VARB,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VARD := (CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2));
VARE := (REF(VARD,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VARF := (REF(VARE,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR10 := (REF(VARF,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VAR11 := (REF(VAR10,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR12 := (REF(VAR11,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VAR13 := (REF(VAR12,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR14 := (REF(VAR13,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VAR15 := (REF(VAR14,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR16 := (REF(VAR15,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
VAR17 := (REF(VAR16,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2));
VAR18 := (REF(VAR17,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2));
排除十字星 := (C > O) OR (C < O);
粉色 := 排除十字星 AND (((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC);
下跌 := 排除十字星 AND (((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18);
VAR19 := (REF(((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18,1)) AND VAR1;
买入 := 排除十字星 AND VAR19;
VAR1A := (REF(((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC,1)) AND VARD;
抛售 := 排除十字星 AND VAR1A;
K线银底 := ((((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) AND (C > O)) AND (C > REF(C,1));
K线金底 := VAR19;
银K或金K := K线银底 OR K线金底;
STICKLINE(粉色 AND ((C < REF(CLOSE,1)) OR (买入 = 1)),CLOSE,REF(CLOSE,1),3.1,0),COLORAA55BB;
STICKLINE(粉色 AND ((C < REF(CLOSE,1)) OR (买入 = 1)),CLOSE,REF(CLOSE,1),1.9,0),COLORCC77DD;
STICKLINE(粉色 AND ((C < REF(CLOSE,1)) OR (买入 = 1)),CLOSE,REF(CLOSE,1),0.6,0),COLOREE99FF;
STICKLINE(下跌 AND ((((O > REF(C,1)) OR ((C < REF(C,1)) AND (抛售 = 1))) OR ((C > REF(C,1)) AND (买入 = 1))) OR ((C > O) AND (C > REF(C,1)))),C,REF(C,1),3.1,0),COLOR8A8A8A;
STICKLINE(下跌 AND ((((O > REF(C,1)) OR ((C < REF(C,1)) AND (抛售 = 1))) OR ((C > REF(C,1)) AND (买入 = 1))) OR ((C > O) AND (C > REF(C,1)))),C,REF(C,1),1.9,0),COLORAAAAAA;
STICKLINE(下跌 AND ((((O > REF(C,1)) OR ((C < REF(C,1)) AND (抛售 = 1))) OR ((C > REF(C,1)) AND (买入 = 1))) OR ((C > O) AND (C > REF(C,1)))),C,REF(C,1),0.6,0),COLORBFBFBF;
买卖显示周期 := (((PERIOD = 3) OR (PERIOD = 4)) OR (PERIOD = 5)) OR (PERIOD = 6);
LC := REF((((O + H) + L) + (2 * C)) / 5,1);
RSI1 := ((SMA(MAX(CLOSE - LC,0),3,1)) / (SMA(ABS(CLOSE - LC),3,1))) * 100;
SELL2 := CROSS(88,RSI1);
A81 := EMA(C,3);
A85 := EMA(C,20);
SS8 := ((CROSS(A81,A85) AND (C > O)) AND (C > REF(C,1))) AND ((C / REF(C,1)) >= 1.018);
DRAWICON(SS8 AND 买卖显示周期,MIN(MA(L,3),L),9);
STICKLINE(买入,REF(CLOSE,1),REF(CLOSE,2),3.1,0),COLOR007777;
STICKLINE(买入,REF(CLOSE,1),REF(CLOSE,2),1.9,0),COLOR009999;
STICKLINE(买入,REF(CLOSE,1),REF(CLOSE,2),0.6,0),COLOR00B9B9;
STICKLINE(抛售,REF(CLOSE,1),REF(CLOSE,2),3.1,0),COLOR207000;
STICKLINE(抛售,REF(CLOSE,1),REF(CLOSE,2),1.9,0),COLOR309000;
STICKLINE(抛售,REF(CLOSE,1),REF(CLOSE,2),0.6,0),COLOR3AAA00;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
冲高回落变盘 := ((O > C) AND 粉色) AND (C < REF(C,1));
STICKLINE(粉色,IF(((O > REF(C,1)) AND (C < O)) AND 冲高回落变盘,REF(CLOSE,1),C),CLOSE,2.35,0),COLORAA55BB;
STICKLINE(粉色,IF(((O > REF(C,1)) AND (C < O)) AND 冲高回落变盘,REF(CLOSE,1),C),CLOSE,1.50,0),COLORBB66CC;
STICKLINE(粉色,IF(((O > REF(C,1)) AND (C < O)) AND 冲高回落变盘,REF(CLOSE,1),C),CLOSE,0.48,0),COLORCC77DD;
昨收 := REF(C,1);
ST涨停 := IF(((((C - 昨收) * 100) / 昨收) >= (5 - ((0.01 * 100) / 昨收))) AND (C > O),1,0);
ST跌停 := IF(((((昨收 - C) * 100) / 昨收) >= (5 - ((0.01 * 100) / 昨收))) AND (C < O),1,0);
涨停 := IF(((((C - 昨收) * 100) / 昨收) >= (10 - ((0.01 * 100) / 昨收))) AND (C > O),1,0);
跌停 := IF(((((昨收 - C) * 100) / 昨收) >= (10 - ((0.01 * 100) / 昨收))) AND (C < O),1,0);
STICKLINE((C > O) AND (涨停 != 1),H,L,0,0),COLOR5010BB;
STICKLINE(C > O,CLOSE,O,3.1,0),NODRAW,COLORLIGRAY;
STICKLINE(CLOSE > O,OPEN,CLOSE,2.35,0),NODRAW,COLORYELLOW;
STICKLINE(CLOSE > O,OPEN,CLOSE,1.50,0),NODRAW,COLOR8050B0;
STICKLINE(CLOSE > O,OPEN,CLOSE,0.48,0),NODRAW,COLORMAGENTA;
STICKLINE(C < O,CLOSE,O,3.1,0),COLOR008000;
STICKLINE(CLOSE < O,OPEN,CLOSE,2.35,0),COLOR996666;
STICKLINE(CLOSE < O,OPEN,CLOSE,1.50,0),COLORA00000;
STICKLINE(CLOSE < O,OPEN,CLOSE,0.48,0),NODRAW,COLOR00B000;
STICKLINE(粉色 AND 冲高回落变盘,IF(((O > REF(C,1)) AND (C < O)) AND 冲高回落变盘,REF(CLOSE,1),C),CLOSE,2.35,0),NODRAW,COLOR2060A0;
STICKLINE(粉色 AND 冲高回落变盘,IF(((O > REF(C,1)) AND (C < O)) AND 冲高回落变盘,REF(CLOSE,1),C),CLOSE,1.50,0),NODRAW,COLORA00099;
STICKLINE(粉色 AND 冲高回落变盘,IF(((O > REF(C,1)) AND (C < O)) AND 冲高回落变盘,REF(CLOSE,1),C),CLOSE,0.48,0),NODRAW,COLORFF6600;
STICKLINE(粉色 AND 冲高回落变盘,C,CLOSE,3.10,0),DOTLINE,COLORCC66AA;
STICKLINE(涨停,OPEN,CLOSE,3.10,0),DOTLINE,COLORAA9900;
STICKLINE(涨停,OPEN,CLOSE,2.35,0),NODRAW,COLOR8080FF;
STICKLINE(涨停,OPEN,CLOSE,1.50,0),NODRAW,COLOR0066CC;
STICKLINE(涨停,OPEN,CLOSE,0.48,0),NODRAW,COLOR40CC00;
STICKLINE(跌停,OPEN,CLOSE,3.10,0),NODRAW,COLORFF0080;
STICKLINE(跌停,OPEN,CLOSE,2.35,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1.50,0);
STICKLINE(跌停,OPEN,CLOSE,0.48,0);
薛斯布林顶 : DRAWBAND(XS压,RGB(72,38,102),XS压,RGB(0,0,0));
薛斯布林底 : DRAWBAND(XS底,RGB(31,45,86),XS底,RGB(0,0,0));
20日线1 : DRAWBAND(IF(20日 <= 多空,20日,DRAWNULL),RGB(204,0,204),20日,RGB(0,0,0));
多空线1 : DRAWBAND(IF(多空 >= 20日,多空,DRAWNULL),RGB(153,64,64),多空,RGB(0,0,0));
⑩日线1 : DRAWBAND(IF(⑩日 >= 多空,⑩日,DRAWNULL),RGB(168,168,0),⑩日,RGB(0,0,0));
⑤日线 : DRAWBAND(⑤日,RGB(192,192,192),⑤日,RGB(255,255,255));
风格类型 : DRAWTEXT_FIX(ISLASTBAR,0,0,0,FGBLOCK);
题材概念 : DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,GNBLOCK);

通达信玩玩主图指标公式

 

相关文章