在线检测未来函数

通达信KDJ三周期及选股指标公式

来源:Internet,编辑:股旁网,2014-09-24

N:=1;
月K:KDJ.K#MONTH,NODRAW,COLORWHITE;
月D:KDJ.D#MONTH,NODRAW,COLORYELLOW;
月J:KDJ.J#MONTH,NODRAW,COLORMAGENTA;
周K:KDJ.K#WEEK,NODRAW,COLORWHITE;
周D:KDJ.D#WEEK,NODRAW,COLORYELLOW;
周J:KDJ.J#WEEK,NODRAW,COLORMAGENTA;
日K:KDJ.K,NODRAW,COLORWHITE;
日D:KDJ.D,NODRAW,COLORYELLOW;
日J:KDJ.J,NODRAW,COLORMAGENTA;
金叉:=CROSS(日K,日D) AND (日D<40 OR 日D>60);
周金叉:=CROSS(周K,周D) AND (周D<40 OR 周D>60);
月金叉:=CROSS(月K,月D) AND (月D<40 OR 月D>60);
共振:=(周金叉 AND 日金叉) OR (周金叉 AND 月金叉) OR (日金叉 AND 月金叉)
OR (日金叉 AND 周金叉 AND 月金叉);
STICKLINE(共振,0,100,1,0),COLORRED;
NOTEXT月K:IF(N=3,月K,DRAWNULL),COLORWHITE;
NOTEXT月D:IF(N=3,月D,DRAWNULL),COLORYELLOW;
NOTEXT月J:IF(N=3,月J,DRAWNULL),COLORMAGENTA;
NOTEXT周K:IF(N=2,周K,DRAWNULL),COLORWHITE;
NOTEXT周D:IF(N=2,周D,DRAWNULL),COLORYELLOW;
NOTEXT周J:IF(N=2,周J,DRAWNULL),COLORMAGENTA;
NOTEXT日K:IF(N=1,日K,DRAWNULL),COLORWHITE;
NOTEXT日D:IF(N=1,日D,DRAWNULL),COLORYELLOW;
NOTEXT日J:IF(N=1,日J,DRAWNULL),COLORMAGENTA;
STICKLINE(日K>=日D,-10,-15,3,0),COLORMAGENTA;
STICKLINE(日K< 日D,-10,-15,3,0),COLORCYAN;
STICKLINE(周K>=周D,-20,-25,3,0),COLORLIRED;
STICKLINE(周K< 周D,-20,-25,3,0),COLORLIGREEN;
STICKLINE(月K>=月D,-30,-35,3,0),COLORMAGENTA;
STICKLINE(月K< 月D,-30,-35,3,0),COLORLICYAN;

{
选股公式:

月K:=KDJ.K#MONTH;
月D:=KDJ.D#MONTH;
月J:=KDJ.J#MONTH;
周K:=KDJ.K#WEEK;
周D:=KDJ.D#WEEK;
周J:=KDJ.J#WEEK;
日K:=KDJ.K;
日D:=KDJ.D;
日J:=KDJ.J;
日金叉:=CROSS(日K,日D) AND (日D<40 OR 日D>60);
周金叉:=CROSS(周K,周D) AND (周D<40 OR 周D>60);
月金叉:=CROSS(月K,月D) AND (月D<40 OR 月D>60);
共振:(周金叉 AND 日金叉) OR (周金叉 AND 月金叉) OR (日金叉 AND 月金叉)
OR (日金叉 AND 周金叉 AND 月金叉);
}

通达信KDJ三周期及选股指标公式

 

相关文章