在线检测未来函数

通达信波段为王主图及选股指标公式

来源:Internet,编辑:股旁网,2014-09-27

AAA:=(3*C+H+L+O)/6;
VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED;
VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/3;
VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
VAR4:(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/3;
VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORRED;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
{DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));}
IF((VAR1 <= REF(VAR1,1)),VAR1,DRAWNULL),COLORGREEN,LINETHICK3;
IF((VAR1 >= REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3;
STICKLINE(VAR4>VAR1,VAR4,VAR1,0,0),COLORBLUE;
DRAWKLINE(H,O,L,C);
DRAWTEXT(REF(VAR5,1)=REF(VAR1,1) AND VAR5<VAR1,L*0.99,'买入'),COLORRED;
DRAWTEXT(REF(VAR6,1)=REF(VAR1,1) AND VAR6<VAR1,L*0.98,'↖加仓'),COLORYELLOW;
DRAWTEXT(REF(VAR4,1)=REF(VAR1,1) AND VAR4>VAR1,H,'卖点'),COLORGREEN;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停};
突破:=CROSS(C,VAR4) AND ZT;
DRAWTEXT(突破,L,'爆点');
STICKLINE(突破,CLOSE,OPEN,3.2,0),COLOR0077FF;
STICKLINE(突破,CLOSE,OPEN,2.5,0),COLOR0099FF;
STICKLINE(突破,CLOSE,OPEN,1.9,0),COLOR00BBFF;
STICKLINE(突破,CLOSE,OPEN,1.2,0),COLOR00DDFF;
STICKLINE(突破,CLOSE,OPEN,0.3,0),COLOR00FFFF;

{
波段买入选股

AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/3;
VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
VAR4:=(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/3;
VAR5:=(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
买入:REF(VAR5,1)=REF(VAR1,1) AND VAR5<VAR1;

波段加仓选股:

AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/3;
VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
VAR4:=(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/3;
VAR5:=(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
加仓:REF(VAR6,1)=REF(VAR1,1) AND VAR6<VAR1;
}

通达信波段为王主图及选股指标公式

 

相关文章