在线检测未来函数

通达信顶底研判指标公式

来源:Internet,编辑:股旁网,2014-09-05

绿压顶箭头减仓:0,COLOR00FF88,NODRAW;
红托底箭头买入:0,COLORRED,NODRAW;
哭脸警惕波段顶:0,COLORFF6633,NODRAW;
趋势线:EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100,COLORYELLOW,LINETHICK1;
波段线:EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19)+100,COLORRED;
IF(波段线>REF(波段线,1),波段线,DRAWNULL),LINETHICK2,COLORRED;
IF(波段线<REF(波段线,1),波段线,DRAWNULL),COLORFF6C00,LINETHICK2;
短期线:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))+100,COLOR888888;
见顶:=(REF(趋势线,1)>85 AND REF(短期线,1)>85 AND REF(波段线,1)>65) AND CROSS(波段线,短期线);
顶部区域:(趋势线<REF(趋势线,1) AND REF(趋势线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95) AND 波段线>60 AND 短期线<83.5 AND 短期线<趋势线 AND 短期线<波段线+4,COLOR00FF00,NODRAW;
顶部:=FILTER(顶部区域,4);
底部区域:(波段线<12 AND 趋势线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (趋势线>REF(趋势线,1) OR 短期线>REF(短期线,1)))
OR (波段线<8 AND 趋势线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (波段线<10 AND 趋势线<7 AND 短期线<1),COLORFF00FF,NODRAW;
见底:=COUNT(底部区域,7)>=1 AND CROSS(趋势线,10);
DRAWICON(见底,趋势线,1);
STICKLINE(顶部,90,103,2,0),COLORGREEN,LINETHICK2;
STICKLINE(底部区域,-9,0,2,0),COLORRED;
DRAWICON(CROSS(波段线,趋势线) AND 波段线>48,趋势线,6);
低位金叉:=波段线<15 AND REF(波段线,1)<15 AND 趋势线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,波段线) AND 短期线>趋势线 AND (REF(短期线,1)<5 OR REF(短期线,2)<5) AND (趋势线>=波段线 OR REF(短期线,1)<1);
DRAWICON(CROSS(趋势线,短期线) AND 趋势线>80,趋势线*1.02,2);
90,COLOR00FF00,LINETHICK2;
80,COLOR996699;
20,COLORWHITE;
10,COLORCC6633,LINETHICK2;

通达信顶底研判指标公式

 

相关文章