在线检测未来函数

通达信极品探底指标公式

来源:Internet,编辑:股旁网,2014-10-04

L1:=30;
N:=6;
LH:=80;
{涨跌}
最高:=HHV(H,L1);
最低:=LLV(L,L1);
涨幅:(最低-最高)/最高,COLOR0000FF,NODRAW;
{一}
MTM:=C-REF(C,1);
MMS:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买一:IF(MMS<6,1,0),COLORFFFFFF;
{二}
VAR16:=4*SMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;
VAR1006:=8;
买二: IF(CROSS(VAR16,VAR1006),2,0),COLOR0000FF;
{三}
VAR26:=REF(LOW,1);
VAR36:=SMA(ABS(LOW-VAR26),3,1)/SMA(MAX(LOW-VAR26,0),3,1)*100;
VAR46:=EMA(IF(CLOSE*1.2,VAR36*10,VAR36/10),3);
VAR56:=LLV(LOW,L1);
VAR66:=HHV(VAR46,L1);
VAR76:=IF(LLV(LOW,90),1,0);
VAR86:=EMA(IF(LOW<=VAR56,(VAR46+VAR66*2)/2,0),3)/618*VAR76;
{ST01:STICKLINE(1<VAR86,VAR86,0 ,10 ,1 ),COLORMAGENTA;}
买三:IF(1<VAR86,3,0),COLOR0080FF;
{四}
VAR1G:=CLOSE/MA(CLOSE,40)*100 < 78;
VAR2G:=CLOSE/MA(CLOSE,60)*100 < 74;
VAR3G:=HIGH > LOW*1.051;
VAR4G:=VAR3G AND COUNT(VAR3G,5) > 1;
买四:IF(VAR4G AND (VAR1G OR VAR2G),4,0),COLORFFFF00;
{五}
VAR28:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR38:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR48:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR58:=(VAR28+2*VAR38+3*VAR48)/6;
VAR68:=MA(VAR58,3);
买五:IF(VAR68<=-10,5,0),COLORFF8000;
{六}
LC:=REF(CLOSE,1);
AA:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
XG:=CROSS(-13,AA);
RSI:=(SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*20);
BB:=MA(RSI,34);
CC:=BB-2.5*STD(RSI,34);
CF:=C>L;
买六:IF(XG AND CF AND RSI<CC,6,0),COLOR00FFFF;
{七}
VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),18,1)/SMA(ABS(CLOSE-VAR1),13,1)*100;
VAR3:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),20,1)*100;
VAR4:=BARSLAST(VAR3<48)<=3 AND CROSS(VAR2,VAR3);
VAR5:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,20)*100<-12.5;
VAR6:=LLV(LOW,5);
VAR7:=HHV(HIGH,10);
VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4);
VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
VARA:=1011131;
VARB:=IF(DATE<=VARA,VAR5,0) OR IF(DATE<=VARA,LH,0);
买七:IF(0-(-1)*VAR4 AND VAR5 AND CROSS(VAR8,VAR9) AND VAR8<=25,8,0),COLOR00FF80;
VARC:=REF(CLOSE,1);
VARD:=SMA(MAX(CLOSE-VARC,0),7,1)/SMA(ABS(CLOSE-VARC),7,1)*100;
VARE:=SMA(MAX(CLOSE-VARC,0),13,1)/SMA(ABS(CLOSE-VARC),13,1)*100;
VARF:=BARSLAST(VARE<43)<=3 AND CROSS(VARD,VARE);
VAR10:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<-12.5;
VAR11:=LLV(LOW,5);
VAR12:=HHV(HIGH,10);
VAR13:=EMA((CLOSE-VAR11)/(VAR12-VAR11)*100,4);
VAR14:=EMA(0.667*REF(VAR13,1)+0.333*VAR13,2);
VAR15:=1011131;
买八:IF(0-(-1)*VARF AND VAR10 AND CROSS(VAR13,VAR14) AND VAR13<=25,8,0),COLOR808040;
VAR17:=REF(CLOSE,1);
VAR18:=SMA(MAX(CLOSE-VAR17,0),7,1)/SMA(ABS(CLOSE-VAR17),7,1)*100;
VAR19:=SMA(MAX(CLOSE-VAR17,0),13,1)/SMA(ABS(CLOSE-VAR17),13,1)*100;
VAR1A:=BARSLAST(VAR19<33)<=3 AND CROSS(VAR18,VAR19);
VAR1B:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<-12.5;
VAR1C:=LLV(LOW,5);
VAR1D:=HHV(HIGH,10);
VAR1E:=EMA((CLOSE-VAR1C)/(VAR1D-VAR1C)*100,4);
VAR1F:=EMA(0.667*REF(VAR1E,1)+0.333*VAR1E,2);
VAR20:=1011131;
VAR21:=IF(DATE<=VAR20,VAR1B,0) OR IF(DATE<=VAR20,LH,0);
买九:IF(0-(-1)*VAR1A AND VAR1B AND CROSS(VAR1E,VAR1F) AND VAR1E<=25,8,0),COLORMAGENTA;
VAR22:=REF(CLOSE,1);
VAR23:=SMA(MAX(CLOSE-VAR22,0),7,1)/SMA(ABS(CLOSE-VAR22),7,1)*100;
VAR24:=SMA(MAX(CLOSE-VAR22,0),13,1)/SMA(ABS(CLOSE-VAR22),13,1)*100;
VAR25:=BARSLAST(VAR24<23)<=3 AND CROSS(VAR23,VAR24);
VAR266:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<-12.5;
VAR27:=LLV(LOW,5);
VAR288:=HHV(HIGH,10);
VAR29:=EMA((CLOSE-VAR27)/(VAR288-VAR27)*100,4);
VAR2A:=EMA(0.667*REF(VAR29,1)+0.333*VAR29,2);
VAR2B:=1011131;
VAR2C:=IF(DATE<=VAR2B,VAR266,0) OR IF(DATE<=VAR2B,LH,0);
买十:IF(0-(-1)*VAR25 AND VAR266 AND CROSS(VAR29,VAR2A) AND VAR29<=25,8,0),COLORGREEN;

通达信极品探底指标公式

 

相关文章