在线检测未来函数

通达信股市一条龙指标公式

来源:Internet,编辑:股旁网,2014-10-07

{参数:年:1990,2050,2014;月:1,12,自设;日:1,31,自设}
年:=2014;
月:=10;
日:=8
-0.2,DOTLINE;
-0.5,DOTLINE;
-0.8,DOTLINE;
-1,DOTLINE;
0,DOTLINE;
Z:=ISLASTBAR;
X:-(HHV(HIGH,30)-CLOSE)/(HHV(HIGH,30)-LLV (LOW,30)),COLORMAGENTA,LINETHICK3;
XX:=(((((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34))*1 ) * 100) * 5);
B001:=(((((CLOSE - MA(CLOSE,42)) / MA(CLOSE,42)) *1 ) * 100) * 5);
B002:=(((((CLOSE - MA(CLOSE,67)) / MA(CLOSE,67)) *1 ) * 100) * 5);
B003:=(((XX + B001) / 2) - (B002 ));
B004:=(((0 - 100) * (HHV(HIGH,34) - CLOSE)) / (HHV(HIGH,34) - LLV(LOW,34)));
B005:=(((0 - 100) * (HHV(HIGH,42) - CLOSE)) / (HHV(HIGH,42) - LLV(LOW,42)));
B006:=(((0 - 100) * (HHV(HIGH,72) - CLOSE)) / (HHV(HIGH,72) - LLV(LOW,72)));
B007:=EMA((((B004 + B005) / 2) - B006),6);
B008:=REF(CLOSE,1);
B009:=((((SMA(MAX((CLOSE - B008),0),19,1) / SMA(ABS((CLOSE - B008)),19,1)) * 100) - 50) *
1.25);
B010:=((((SMA(MAX((CLOSE - B008),0),34,1) / SMA(ABS((CLOSE - B008)),34,1)) * 100) - 50) *
1.25);
B011:=((((SMA(MAX((CLOSE - B008),0),72,1) / SMA(ABS((CLOSE - B008)),72,1)) * 100) - 50) *
1.25);
B012:=EMA(((((B009 + B010) / 2) - B011) * 5),6);
B013:=((((0 - 1) * ((B007 + B003) + B012)) / 3) * 1.5);
B016:=EMA(B012,4);
B017:=B012;
KKM1:=B013;
DPM1:=EMA(B013,4);
关注:=IF((YEAR = 年),1,0);
XY:=IF((MONTH = 月),1,0);
XM:=IF((DAY = 日),1,0);
XD:=(关注 * XY * XM);
VARX:=B017;
C023:=KKM1;
C024:=B016;
C025:=DPM1;
C026:=WINNER(CLOSE);
W:=(DMA(C026,((VOL / CAPITAL) * 1)) * 100);
HWXWINNER:=W;
XD1:=EMA(W,6);
XWXMH:=XD1;
DRAWTEXT_FIX(Z,0.01,0.01,0,'上穿每一条虚线都是一个起点,下穿每一条虚线都是一个减仓点')COLORLIMAGENTA,LINETHICK2;
DRAWTEXT_FIX(((HWXWINNER>XWXMH) AND Z AND (XD>0)),0.01,0.8,0,'发现大庄家连续活动,重点关注'),LINETHICK2;
DRAWTEXT_FIX((((VARX>C023) AND Z AND (VARX>C024)) AND (XD>0)),0.01,0.88,0,'从多头活动看:中线适度持股');
DRAWTEXT_FIX((((VARX>C023) AND Z AND (VARX<C024)) AND (XD>0)),0.01,0.88,0,'从多头活动看:中线获利减仓');
DRAWTEXT_FIX((((VARX<C023) AND Z AND (VARX>C024)) AND (XD>0)),0.01,0.88,0,'从多头活动看:中线择机进仓');
DRAWTEXT_FIX((((VARX<C023) AND Z AND (VARX<C024)) AND (XD>0)),0.01,0.88,0,'从多头活动看:中线空仓观望');
DRAWTEXT_FIX((((C023>VARX) AND Z AND (C023>C025)) AND (XD>0)),0.01,1,0,'从空头活动看:中线空仓观望');
DRAWTEXT_FIX((((C023>VARX) AND Z AND (C023<C025)) AND (XD>0)),0.01,1,0,'从空头活动看:中线择机进仓');
DRAWTEXT_FIX((((C023<VARX) AND Z AND (C023>C025)) AND (XD>0)),0.01,1,0,'从空头活动看:中线获利减仓');
DRAWTEXT_FIX((((C023<VARX) AND Z AND (C023<C025)) AND (XD>0)),0.01,1,0,'从空头活动看:中线适度持股');

通达信股市一条龙指标公式

 

相关文章