在线检测未来函数

飞狐长短MACD指标公式

来源:Internet,编辑:股旁网,2014-10-11

INPUT:SHORT(12,1,100,1),LONG(26,1,100,1), N(9,1,100,2),M(9,2,60);
DIF:指数平滑移动平均(收盘价,SHORT)-指数平滑移动平均(收盘价,LONG);
MACD:指数平滑移动平均(DIF,N);
DEF:=2*(DIF-MACD);
画柱线(DEF>=0 AND DEF>=向前引用(DEF,1),0,DEF*2,5,0)COLOR1011FF;
画柱线(DEF>=0 AND DEF< 向前引用(DEF,1),0,DEF*2,5,1),COLORFFFF00;
画柱线(DEF<0 AND DEF>=向前引用(DEF,1),0,DEF*2,5,1),COLOR1088FF;
画柱线(DEF<0 AND DEF< 向前引用(DEF,1),0,DEF*2,5,0),COLORFFFF00;
多头趋势:=条件函数(DIF>=0 AND MACD>=0 OR (DIF<0 AND MACD>=0),1,0);
空头趋势:=DIF<0 AND MACD<0 OR (DIF>=0 AND MACD<0);
缩头:=条件函数(DEF>0 AND 向前引用(DEF,1)>向前引用(DEF,2) AND DEF< 向前引用(DEF,1),1,0);
缩脚:=条件函数(DEF<0 AND 向前引用(DEF,1)< 向前引用(DEF,2) AND DEF>向前引用(DEF,1),1,0);
阻力:=条件函数(交叉函数(收盘价,简单移动平均(收盘价,20)) OR 交叉函数(收盘价,简单移动平均(收盘价,60)),1,0);
支撑:=条件函数(交叉函数(简单移动平均(收盘价,20),收盘价) OR 交叉函数(简单移动平均(收盘价,60),收盘价),1,0);
做多:=条件函数(交叉函数(MACD,DIF) AND DIF>0 AND MACD>0,1,0);
放空:=条件函数(交叉函数(DIF,MACD) AND DIF<0 AND MACD<0,1,0);
画图标(信号过滤(缩头,3) AND 缩头,DEF+0.01,5),ALIGN0;
画图标(信号过滤(缩脚,3) AND 缩脚,DEF,4),ALIGN1;
画图标(信号过滤(阻力,16) AND DEF>=0,DEF+0.01,12),ALIGN0;
画图标(信号过滤(支撑,16) AND DEF<0,DEF,12),ALIGN1;
DU0:=交叉函数(DIF,0);
UD0:=交叉函数(0,DIF);
TDU0:=上一次条件成立位置(DU0);
TUD0:=上一次条件成立位置(UD0);
DU3:=向前引用(DU0,1);
UD3:=向前引用(UD0,1);
TDU3:=上一次条件成立位置(DU3);
TUD3:=上一次条件成立位置(UD3);
UDGLINE:=条件函数(TDU3<TUD3,向前引用(最高值(最高价,2),TDU3),向前引用(最低值(最低价,2),TUD3));
JDU0:=向前引用(收盘价,1)<=向前引用(UDGLINE,1) AND 收盘价>UDGLINE AND TDU0<TUD0;
JUD0:=向前引用(收盘价,1)>=向前引用(UDGLINE,1) AND 收盘价<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND 统计总数(JDU0,TDU0)=1;
JUD1:=JUD0 AND 统计总数(JUD0,TUD0)=1;
JDU2:=JDU1 AND 向前引用(上一次条件成立位置(JUD1),1)<向前引用(上一次条件成立位置(JDU1),1);
JUD2:=JUD1 AND 向前引用(上一次条件成立位置(JUD1),1)>向前引用(上一次条件成立位置(JDU1),1);
JDU3:=JDU1 AND 向前引用(上一次条件成立位置(JUD1),1)>向前引用(上一次条件成立位置(JDU1),1);
JUD3:=JUD1 AND 向前引用(上一次条件成立位置(JUD1),1)<向前引用(上一次条件成立位置(JDU1),1);
BSLINE:=条件函数(上一次条件成立位置(JDU2)<上一次条件成立位置(JUD2),条件函数(向前引用(交叉函数(0,DEF),1),最低值(最低价,2),向前引用(最低值(最低价,2),上一次条件成立位置(向前引用(交叉函数(0,DEF),1)))),条件函数(向前引用(交叉函数(DEF,0),1),最高值(最高价,2),向前引用(最高值(最高价,2),上一次条件成立位置(向前引用(交叉函数(DEF,0),1)))));
画图标(JDU1 OR 上一次条件成立位置(JDU1)<上一次条件成立位置(JUD1),0,10),ALIGN4;
画图标(JUD1 OR 上一次条件成立位置(JDU1)>上一次条件成立位置(JUD1),0,11),ALIGN5;
画图标(交叉函数(DIF,MACD),DIF-0.01,6);
画图标(交叉函数(MACD,DIF),DIF,11);
低位金叉:=交叉函数(DIF,MACD) AND DIF<-0.1;
画柱线(低位金叉,0,0.25,5,0),COLORYELLOW;
显示文字(低位金叉,0.39, '低叉'),COLORWHITE;
JCCOUNT:=统计总数(交叉函数(DIF,MACD),上一次条件成立位置(MACD>=0));
二次金叉:=交叉函数(DIF,MACD) AND MACD<0 AND 统计总数(JCCOUNT=2,21)=1;
画柱线(二次金叉,0,0.15,5,0),COLORFF00FF;
画图标(二次金叉,MACD*0.9,1) ;
显示文字(二次金叉,0.26, '二叉'),COLORYELLOW;
强度:画分段线(DIF>=MACD,DIF),COLORRED,LINETHICK1;
A1:=上一次条件成立位置(向前引用(交叉函数(DIF,MACD),1));
背离:=向前引用(收盘价,A1+1)>收盘价 AND DIF>向前引用(DIF,A1+1) AND 交叉函数(DIF,MACD);
画柱线(底背离,0,0.05,5,0),COLOR00FF00;
底背:画直线(A1=0,MACD,底背离,MACD,0),COLORRED,LINETHICK2;
显示文字(底背离,0.10, '背离'),COLORFF00FF;
A2:=上一次条件成立位置(向前引用(交叉函数(MACD,DIF),1));
顶背离:=向前引用(收盘价,A2+1)<收盘价 AND 向前引用(DIF,A2+1)>DIF AND 交叉函数(MACD,DIF);
v1:=最低值(最低价,10);
v2:=最高值(最高价,25);
价位线:=指数平滑移动平均((收盘价-v1)/(v2-v1)*4,4);
xg:条件函数(交叉函数(价位线,0.3),0.13,0),Linethick2,COLORYELLOW;
VAR21:=(收盘价-最低值(最低价,21))/(最高值(最高价,21)-最低值(最低价,21))*90;
K2:=移动平均(VAR21,3,1) ;
D2:=移动平均(K2,3,1) ;
XgG:(交叉函数(K2,D2) AND D2<10)*0.2,COLOR0000FF,LINETHICK2;
DIFF8:=指数平滑移动平均(收盘价,8) - 指数平滑移动平均(收盘价,26);
DEA8:=指数平滑移动平均(DIFF8,50);
MACD8:2*(DIFF8-DEA8) ,COLOR00ffff;
mamacd:简单移动平均(macd8,5),colorffff00;
V1:=EMA(CLOSE,5)-EMA(CLOSE,340);
V2:=EMA(V1,144);;
V3:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,COLOR00BB00;
买:(((V3-向前引用(V3,1)>13 )and v3<56) or (V3-向前引用(V3,1)>30 ))*1/4,,LINETHICK2;
买入:IF(CROSS(V3,5) and v1<v2 and 买>-0,0.2,0),color0090FF;
DRAWTEXT(CROSS(V3,5) and v1<v2 and 买>-0,0.25,'买入'),COLORFF00FF;
A1:=成交额/成交量/1000;
B2:=(3*最高价+最低价+开盘价+2*收盘价)/7;
D3:=求和(成交额,13)/A1/1000;
E4:=动态移动平均(B2,成交量/D3);
买不输:=(收盘价-E4)/E4*1000;
点状:=-88,COLORYELLOW,点状线;
显示文字(交叉函数(买不输,-166),-0,'★:极低'),COLORCYAN;
显示文字(交叉函数(买不输,-120),-0,'★:较低'),COLORBLUE;
显示文字(交叉函数(买不输,点状),0,'★:稍低'),COLORGREEN;

飞狐长短MACD指标公式

 

相关文章