在线检测未来函数

飞狐大般若线主图指标公式

来源:Internet,编辑:股旁网,2014-10-14

VAR1:=EMA(CLOSE,3);
VAR2:=EMA(CLOSE,8);
MA21:=EMA(CLOSE,21);
STICKLINE((VAR1 < MA21),CLOSE,OPEN,8,0),color10A111;
STICKLINE((VAR1 < MA21),CLOSE,OPEN,6,0),color10B222;
STICKLINE((VAR1 < MA21),CLOSE,OPEN,4,0),color10C333;
STICKLINE((VAR1 < MA21),CLOSE,OPEN,2,0),color10D444;
STICKLINE((VAR1 < MA21),HIGH,LOW,0,0),color10E555;
STICKLINE((VAR1 > MA21),CLOSE,OPEN,8,0),colorAAFF;
STICKLINE((VAR1 > MA21),CLOSE,OPEN,6,0),color11BBFF;
STICKLINE((VAR1 > MA21),CLOSE,OPEN,4,0),color22CCFF;
STICKLINE((VAR1 > MA21),CLOSE,OPEN,2,0),color33DDFF;
STICKLINE((VAR1 > MA21),HIGH,LOW,0,0),color44EEFF;
STICKLINE(((VAR1 < VAR2) AND (VAR1 > MA21)),CLOSE,OPEN,8,0),colorBBBBBB;
STICKLINE(((VAR1 < VAR2) AND (VAR1 > MA21)),CLOSE,OPEN,6,0),colorCCCCCC;
STICKLINE(((VAR1 < VAR2) AND (VAR1 > MA21)),CLOSE,OPEN,4,0),colorDDDDDD;
STICKLINE(((VAR1 < VAR2) AND (VAR1 > MA21)),CLOSE,OPEN,2,0),colorEEEEEE;
STICKLINE(((VAR1 < VAR2) AND (VAR1 > MA21)),HIGH,LOW,0,0),colorFFFFFF;
STICKLINE(((VAR1 > VAR2) AND (VAR1 < MA21)),CLOSE,OPEN,8,0),colorFF00FF;
STICKLINE(((VAR1 > VAR2) AND (VAR1 < MA21)),CLOSE,OPEN,6,0),colorFF22FF;
STICKLINE(((VAR1 > VAR2) AND (VAR1 < MA21)),CLOSE,OPEN,4,0),colorFF44FF;
STICKLINE(((VAR1 > VAR2) AND (VAR1 < MA21)),CLOSE,OPEN,2,0),colorFF66FF;
STICKLINE(((VAR1 > VAR2) AND (VAR1 < MA21)),HIGH,LOW,0,0),colorFF77FF;
A1:=(((EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),3) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),6)) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),9)) / 3);
A2:=(((EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),5) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),10)) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),20)) / 3);
A3:=(((EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),7) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),14)) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),28)) / 3);
A4:=(((EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),9) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),18)) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),36)) / 3);
A5:=(((EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),11) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),22)) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),44)) / 3);
A6:=(((EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),13) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),26)) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),52)) / 3);
A:(((EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),21) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),34)) + EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),55)) / 3);
PARTLINE((A1 > REF(A1,1)),A1),colorFF00FF;
PARTLINE((A1 < REF(A1,1)),A1),colorFF00;
PARTLINE((A2 > REF(A2,1)),A2),colorFF00FF;
PARTLINE((A2 < REF(A2,1)),A2),colorFF00;
PARTLINE((A3 > REF(A3,1)),A3),colorFF00FF;
PARTLINE((A3 < REF(A3,1)),A3),colorFF00;
PARTLINE((A4 > REF(A4,1)),A4),colorFF00FF;
PARTLINE((A4 < REF(A4,1)),A4),colorFF00;
PARTLINE((A5 > REF(A5,1)),A5),colorFF00FF;
PARTLINE((A5 < REF(A5,1)),A5),colorFF00;
PARTLINE((A6 > REF(A6,1)),A6),colorFF00FF;
PARTLINE((A6 < REF(A6,1)),A6),colorFF00;
PARTLINE((A > REF(A,1)),A),LINETHICK3,colorFF00FF;
PARTLINE((A < REF(A,1)),A),LINETHICK3,colorFF00;

飞狐大般若线主图指标公式

 

相关文章