在线检测未来函数

通达信八旗兵仪表盘主图指标公式

来源:Internet,编辑:股旁网,2014-10-14

TS:=250;
N:=99;
M:=3;
显示仪表盘1:=1;
范围高A:=REFDATE(HHV(H,120),DATE)*1.05;
范围低A:=REFDATE(LLV(L,120),DATE)*0.95;
MA5:=MA(C,5),COLORCYAN,LINETHICK2;
MA24:=MA(C,24),COLORGREEN,LINETHICK2;
MA72:=MA(C,72),COLORRED,LINETHICK2;
MA200:=IF((MA(C,200)<=范围高A AND MA(C,200)>=范围低A) OR C>=MA(C,200),MA(C,200),DRAWNULL),COLORBLUE,LINETHICK2;
{=======================仪表盘=========================}
主升浪:=ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪回调:=ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪深调:=ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>IF(MA200=DRAWNULL,0,MA200);
初升浪:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72;
底部反弹:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA5>MA24;
探底阶段:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA24>MA5;
观望:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24>MA72 AND C<MA72,MA72>MA200 AND C<MA200);
有牛:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C>=MA72,MA72<MA200 AND C>=MA200);
放弃:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C<MA72,MA72<MA200 AND C<MA200);
DRAWGBK(显示仪表盘1=1 AND 主升浪=0 AND 主浪回调=0 AND 主浪深调=0 AND 初升浪=0 AND 底部反弹=0 AND 探底阶段=0 AND 观望=0 AND 有牛=0 AND 放弃=0,0,0,0,'观望',0)COLOR00BF00;
DRAWGBK(显示仪表盘1=1 AND 主升浪,0,0,0,'主升浪',0)COLORFF00FF;
DRAWGBK(显示仪表盘1=1 AND 主浪回调,0,0,0,'主浪回调',0)COLORFF8080;
DRAWGBK(显示仪表盘1=1 AND 主浪深调,0,0,0,'主浪深调',0)COLOR009500;
DRAWGBK(显示仪表盘1=1 AND 初升浪,0,0,0,'初升浪',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 底部反弹,0,0,0,'底部反弹',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 探底阶段,0,0,0,'探底阶段',0);
DRAWGBK(显示仪表盘1=1 AND 观望,0,0,0,'观望',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 有牛,0,0,0,'有牛',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 放弃,0,0,0,'放弃',0)COLOR00BF00;
{【八旗兵】}
{TS=130,N=99,M=3}
{筹码撑压}
{TS=130,N=99,M=3}
高:=CONST(REF(HHV(H,TS),M));
低:=CONST(REF(LLV(L,TS),M));
DA1:=IF(TS>TOTALBARSCOUNT,TOTALBARSCOUNT,TS);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
{八旗兵}
ZF:(EMA(SUM(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),49) * 10)+EMA(C,20);
飞扬古:=(EMA(MA(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),13) * 10000),LINETHICK0,COLORFFFFFF;
【康熙帝】:EMA(ZF,34),LINETHICK2,COLOR00FFFF;
ZFF:=(EMA(SUM(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),49) * 10000);
康熙帝:=EMA(ZFF,34),LINETHICK0,COLOR00FFFF;
大1:=MA(ZFF,3);
旗1:=MA(大1,3);
展1:=MA(旗1,3);
大:MA(ZF,3),COLOR66DDFF;
旗:MA(大,3),COLOR66CCFF;
展:MA(旗,3),COLOR66AAFF;
热:MA(展,3),COLOR9900FF;
血:MA(热,3),COLOR7700FF;
染:MA(血,3),COLOR0000FF;
IF(大<REF(大,1),大,DRAWNULL),COLORFFFCCC;
IF(旗<REF(旗,1),旗,DRAWNULL),COLORFFFBBB;
IF(展<REF(展,1),展,DRAWNULL),COLORFFF999;
IF(热<REF(热,1),热,DRAWNULL),COLORFFF888;
IF(血<REF(血,1),血,DRAWNULL),COLORFFF777;
IF(染<REF(染,1),染,DRAWNULL),COLORFFF555;
KK:=(高-低)/6;
超跌:=(飞扬古 < (0 - 200));
超跌A:=(((((((REF(超跌,1) OR REF(超跌,2)) OR REF(超跌,3)) OR REF(超跌,4)) OR REF(超跌,5)) OR REF(超跌,6)) OR REF(超跌,7)) AND (CROSS(飞扬古,(0 - 200)) OR CROSS(飞扬古,康熙帝)));
超跌B:=(((大1 < (0 - 300)) OR (旗1 < (0 - 300))) OR (展1< (0 - 300)));
DRAWICON(大1 < (0 - 300),【康熙帝】,6);
DRAWICON(((飞扬古 < (0 - 100)) AND CROSS(飞扬古,康熙帝)),L,7);
STICKLINE(超跌A,L*1.036,L*1.03,6,0),COLORFFFF00;
DRAWICON(超跌A,L*1.039,14);
STICKLINE(超跌A,L*1.036,L*1.027,1,0),POINTDOT,COLORFFFFFF;
STICKLINE((((超跌B OR REF(超跌B,1)) AND CROSS(飞扬古,康熙帝)) AND (飞扬古 > (0 - 200))),L*1.036,L*1.03,6,0),COLORFFFFFF;
DRAWICON((((超跌B OR REF(超跌B,1)) AND CROSS(飞扬古,康熙帝)) AND (飞扬古 > (0 - 200))),L*1.038,14);
STICKLINE((((超跌B OR REF(超跌B,1)) AND CROSS(飞扬古,康熙帝)) AND (飞扬古 > (0 - 200))),L*1.036,L*1.027,1,0),POINTDOT,COLORFFFFFF;
ARA:=(100 * WINNER(CLOSE));
VARA:=(0.85 * CLOSE);
VARB:=(100 * WINNER(VARA));
高控:=((ARA > 70) OR (VARB > 30));
M1:=((((飞扬古 > 0) AND (飞扬古 > 大)) AND (康熙帝 > REF(康熙帝,1))) AND (康熙帝 < 0));
M2:=(((((飞扬古 > 0) AND (飞扬古 > 康熙帝)) AND (康熙帝 > REF(康熙帝,1))) AND (康熙帝 > 0)) AND 高控);
M3:=(高控 AND (飞扬古 > 0));
AB:=ISLASTBAR;
STICKLINE((AB AND (M3 OR 大>REF(大,1) AND 旗>REF(旗,1) AND 展>REF(展,1))),(高+低)/2,高,1,0);
DRAWICON((AB AND (M3 OR 大>REF(大,1) AND 旗>REF(旗,1) AND 展>REF(展,1))),高,9);
DRAWTEXT((AB AND (M3 OR 大>REF(大,1) AND 旗>REF(旗,1) AND 展>REF(展,1))),高*0.99,' ██'),COLOR00FFFF;
DRAWTEXT((AB AND (M3 OR 大>REF(大,1) AND 旗>REF(旗,1) AND 展>REF(展,1))),高*0.99,' $'),COLOR0000FF;
DRAWTEXT((AB AND (M3 OR 大>REF(大,1) AND 旗>REF(旗,1) AND 展>REF(展,1))),高-KK,' ◥'),COLOR0000FF;
DRAWTEXT((AB AND M3),高-2*KK,' ◥'),COLORFF0000,FLINETHICK9;
DRAWTEXT((AB AND M3),高-3*KK,' ◥'),COLORFF0000,FLINETHICK9;
TT:=CONST((AB AND M3));
DRAWTEXT(TT AND CURRBARSCOUNT=20,高*0.99,'大旗不倒 赚钱不跑'),COLOR00FFFF;
{黄金分割}
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:=REFDATE(高,DATE),COLORWHITE;
%19.8:REFDATE(H19,DATE),COLORYELLOW;
%38.2:=REFDATE(H38,DATE),COLORMAGENTA;
%50:REFDATE(H中,DATE),COLORRED;
%61.8:=REFDATE(H61,DATE),COLORMAGENTA;
%80.9:REFDATE(H80,DATE),COLORYELLOW;
低点:=REFDATE(低,DATE),COLORWHITE;
DRAWTEXT(ISLASTBAR,%19.8,'%19.8'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%80.9,'%80.9'),COLORYELLOW;
CG:=MA(C,17),COLORYELLOW,LINETHICK0;
STICKLINE(CLOSE>=CG,LOW,HIGH,0.4,1), COLORRED;
STICKLINE(CLOSE>=CG,OPEN,CLOSE,3,0), COLORRED;
STICKLINE(CLOSE>=CG AND CLOSE>OPEN,OPEN,CLOSE,3,1), COLORRED;
STICKLINE(CLOSE<CG,HIGH,LOW,0.4,0), COLORGREEN;
STICKLINE(CLOSE<CG,CLOSE,OPEN,3,0), COLORGREEN;
STICKLINE(CLOSE<CG AND CLOSE>=OPEN,CLOSE,OPEN,3,1), COLORGREEN;

通达信八旗兵仪表盘主图指标公式

 

相关文章