在线检测未来函数

飞狐牛熊波浪主图指标公式

来源:Internet,编辑:股旁网,2014-10-15

量比:=v/ema(v,20);
c1:=(c+2*h+l+o)/5;
a1:=EMA((EMA(c1,2)+EMA(c1,4)+EMA(c1,6))/3,3);
a2:=EMA((EMA(c1,6)+EMA(c1,8)+EMA( c1,10))/3,3);
a3:=EMA((EMA(c1,10)+EMA(c1,12)+EMA( c1,14))/3,3);
a4:=EMA((EMA(c1,14)+EMA(c1,16)+EMA( c1,18))/3,3);
a5:=EMA((EMA(c1,18)+EMA(c1,20)+EMA( c1,22))/3,3);
a6:=EMA((EMA(c1,22)+EMA(c1,24)+EMA(c1,26))/3,3);
a:=EMA((EMA(c1,29)+EMA(c1,31)+EMA(c1,33))/3,3),colorwhite;
PARTLINE(c1>a,a),colormagenta,linethick2;
PARTLINE(c1<a,a),colorgreen,linethick2;
PARTLINE(a1>ref(a1,1),a1),colormagenta,POINTDOT;
PARTLINE(a2>ref(a2,1),a2),colormagenta,POINTDOT;
PARTLINE(a3>ref(a3,1),a3),colormagenta,POINTDOT;
PARTLINE(a4>ref(a4,1),a4),colormagenta,POINTDOT;
PARTLINE(a5>ref(a5,1),a5),colormagenta,POINTDOT;
PARTLINE(a6>ref(a6,1),a6),colormagenta,POINTDOT;
PARTLINE(a1<ref(a1,1),a1),colorgreen,POINTDOT;
PARTLINE(a2<ref(a2,1),a2),colorgreen,POINTDOT;
PARTLINE(a3<ref(a3,1),a3),colorgreen,POINTDOT;
PARTLINE(a4<ref(a4,1),a4),colorgreen,POINTDOT;
PARTLINE(a5<ref(a5,1),a5),colorgreen,POINTDOT;
PARTLINE(a6<ref(a6,1),a6),colorgreen,POINTDOT;
tj:=c1>a;
tj2:=c1>open or c1=open and c1>ref(c1,1);
STICKLINE(tj2,HIGH,LOW,0.5,0),colorred;
STICKLINE(tj,OPEN,CLOSE,8,0),color102088;
STICKLINE(tj,OPEN,CLOSE,7,0),color102099;
STICKLINE(tj,OPEN,CLOSE,6,0),color1020aa;
STICKLINE(tj,OPEN,CLOSE,5,0),color1020bb;
STICKLINE(tj,OPEN,CLOSE,4,0),color1020cc;
STICKLINE(tj,OPEN,CLOSE,3,0),color1020dd;
STICKLINE(tj,OPEN,CLOSE,2,0),color1020ee;
STICKLINE(tj,OPEN,CLOSE,1,0),color1020ff;
STICKLINE(not(tj),OPEN,CLOSE,8,0),colorff7700;
STICKLINE(not(tj),OPEN,CLOSE,7,0),colorff8800;
STICKLINE(not(tj),OPEN,CLOSE,6,0),colorff9900;
STICKLINE(not(tj),OPEN,CLOSE,5,0),colorffaa00;
STICKLINE(not(tj),OPEN,CLOSE,4,0),colorffbb00;
STICKLINE(not(tj),OPEN,CLOSE,3,0),colorffcc00;
STICKLINE(not(tj),OPEN,CLOSE,2,0),colorffdd00;
STICKLINE(not(tj),OPEN,CLOSE,1,0),colorffee00;
c11:=ref(c,1);
c2:=hhv(c11,2);
c3:=llv(c11,1);
et:=hhv(c11,2);
et1:=ref(et,1);
xb:=llv(c11,1);
xb1:=ref(xb,1);
m:=BARSLAST(c<xb and c11>=xb1);
m1:=ref(m,1);
n9:=BARSLAST(c>et and c11<=et1);
n1:=ref(n9,1);
m2:=BARSLAST(m-n9>0 and m1<=n1)+1;
n2:=BARSLAST(n9-m>0 and n1<=m1)+1;
et2:=hhv(et,m2);
xb2:=llv(xb,n2);
app:=if(m-n9>0 and m1<=n1,1,if(n9-m>0 and n1<=m1,0,2));
h11:=if(m-n9>0,c,et2);
h2:=if(app=1,c,c2);
h3:=if(m-n9<0,c,xb2);
h4:=if(app=1,c,xb2);
关键位:=if(m-n9>0 or app=1 ,c,h3);
p1:=l<a and c>a and 量比>1 and a1>ref(a1,1) and 关键位>ref(关键位,1) or cross(c,a) and 量比>1 and 关键位>ref(关键位,1);
DRAWTEXT(p1,L*0.99,'买'),COLORgreen,ALIGN0;
量比:=v/ema(v,20);
c1:=(c+2*h+l+o)/5;
a1:=EMA((EMA(c1,2)+EMA(c1,4)+EMA(c1,6))/3,3);
a2:=EMA((EMA(c1,6)+EMA(c1,8)+EMA( c1,10))/3,3);
a3:=EMA((EMA(c1,10)+EMA(c1,12)+EMA( c1,14))/3,3);
a4:=EMA((EMA(c1,14)+EMA(c1,16)+EMA( c1,18))/3,3);
a5:=EMA((EMA(c1,18)+EMA(c1,20)+EMA( c1,22))/3,3);
a6:=EMA((EMA(c1,22)+EMA(c1,24)+EMA(c1,26))/3,3);
a:=EMA((EMA(c1,29)+EMA(c1,31)+EMA(c1,33))/3,3),colorwhite;
PARTLINE(c1>a,a),colormagenta,linethick2;
PARTLINE(c1<a,a),colorgreen,linethick2;
PARTLINE(a1>ref(a1,1),a1),colormagenta,POINTDOT;
PARTLINE(a2>ref(a2,1),a2),colormagenta,POINTDOT;
PARTLINE(a3>ref(a3,1),a3),colormagenta,POINTDOT;
PARTLINE(a4>ref(a4,1),a4),colormagenta,POINTDOT;
PARTLINE(a5>ref(a5,1),a5),colormagenta,POINTDOT;
PARTLINE(a6>ref(a6,1),a6),colormagenta,POINTDOT;
PARTLINE(a1<ref(a1,1),a1),colorgreen,POINTDOT;
PARTLINE(a2<ref(a2,1),a2),colorgreen,POINTDOT;
PARTLINE(a3<ref(a3,1),a3),colorgreen,POINTDOT;
PARTLINE(a4<ref(a4,1),a4),colorgreen,POINTDOT;
PARTLINE(a5<ref(a5,1),a5),colorgreen,POINTDOT;
PARTLINE(a6<ref(a6,1),a6),colorgreen,POINTDOT;
tj:=c1>a;
tj2:=c1>open or c1=open and c1>ref(c1,1);
STICKLINE(tj2,HIGH,LOW,0.5,0),colorred;
STICKLINE(tj,OPEN,CLOSE,8,0),color102088;
STICKLINE(tj,OPEN,CLOSE,7,0),color102099;
STICKLINE(tj,OPEN,CLOSE,6,0),color1020aa;
STICKLINE(tj,OPEN,CLOSE,5,0),color1020bb;
STICKLINE(tj,OPEN,CLOSE,4,0),color1020cc;
STICKLINE(tj,OPEN,CLOSE,3,0),color1020dd;
STICKLINE(tj,OPEN,CLOSE,2,0),color1020ee;
STICKLINE(tj,OPEN,CLOSE,1,0),color1020ff;
STICKLINE(not(tj),OPEN,CLOSE,8,0),colorff7700;
STICKLINE(not(tj),OPEN,CLOSE,7,0),colorff8800;
STICKLINE(not(tj),OPEN,CLOSE,6,0),colorff9900;
STICKLINE(not(tj),OPEN,CLOSE,5,0),colorffaa00;
STICKLINE(not(tj),OPEN,CLOSE,4,0),colorffbb00;
STICKLINE(not(tj),OPEN,CLOSE,3,0),colorffcc00;
STICKLINE(not(tj),OPEN,CLOSE,2,0),colorffdd00;
STICKLINE(not(tj),OPEN,CLOSE,1,0),colorffee00;
c11:=ref(c,1);
c2:=hhv(c11,2);
c3:=llv(c11,1);
et:=hhv(c11,2);
et1:=ref(et,1);
xb:=llv(c11,1);
xb1:=ref(xb,1);
m:=BARSLAST(c<xb and c11>=xb1);
m1:=ref(m,1);
n9:=BARSLAST(c>et and c11<=et1);
n1:=ref(n9,1);
m2:=BARSLAST(m-n9>0 and m1<=n1)+1;
n2:=BARSLAST(n9-m>0 and n1<=m1)+1;
et2:=hhv(et,m2);
xb2:=llv(xb,n2);
app:=if(m-n9>0 and m1<=n1,1,if(n9-m>0 and n1<=m1,0,2));
h11:=if(m-n9>0,c,et2);
h2:=if(app=1,c,c2);
h3:=if(m-n9<0,c,xb2);
h4:=if(app=1,c,xb2);
关键位:=if(m-n9>0 or app=1 ,c,h3);
p1:=l<a and c>a and 量比>1 and a1>ref(a1,1) and 关键位>ref(关键位,1) or cross(c,a) and 量比>1 and 关键位>ref(关键位,1);
DRAWTEXT(p1,L*0.99,'买'),COLORgreen,ALIGN0 ;

飞狐牛熊波浪主图指标公式

 

相关文章