在线检测未来函数

飞狐加仓止损趋势主图指标公式

来源:Internet,编辑:股旁网,2014-10-16

H1:EMA(CLOSE,3),linethick2,colorred;
H2:EMA(H1,20),linethick2,coloryellow;
DRAWICON(CROSS(H1,H2)AND CLOSE<EMA(CLOSE,60) ,LOW,1);
STICKLINE(H1>H2,H1,H2,1,0.8),COLORRED;
STICKLINE(H1<H2,H1,H2,1,0.8),COLORGREEN;
x1:=EMA(C,7);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH,'★ 快跑' ),COLORYELLOW;
VarA:=REF(CLOSE,1);
VarB:=SMA(MAX(CLOSE-VarA,0),6,1)/SMA(ABS(CLOSE-VarA),6,1)*100;
DRAWTEXT(CROSS(75,VarB),HIGH,'☆短出'),Color00FF00 ;
选股1:cross(h1,h2),LINETHICK0,colorgreen;
DRAWTEXT(cross(h1,h2),l,'☆加仓'),ALIGN0,coloryellow,linethick3;
选股2:cross(h2,h1),LINETHICK0,colorred;
DRAWTEXT(cross(h2,h1),l,'☆止损'),ALIGN0,colorred,linethick3;
input:Q(27,1,250);
MA5:MA(CLOSE,5),linethick1;
MA10:MA(CLOSE,10),linethick1;
MA20:MA(CLOSE,20),Color0000FF,linethick1;
MA30:MA(CLOSE,30),ColorFFFF00,linethick1;
MA60:MA(CLOSE,60),ColorFF0000,linethick1;
MA120:MA(CLOSE,120),Color00FF00,linethick1;
MA250:MA(CLOSE,250),Colorgray,linethick1;
Var1:=(开盘价+最低价+最高价+收盘价)/4;
stickline(1,var1,var1,6,0),ColorFF00FF;
拐点:=ma(c,3); 拐点1:=ma(c,3);
gd1:=ref(count(拐点<=ref(拐点,1),5)=5 ,1) and 拐点>ref(拐点,1),linethick2 ,colorred ;
gd2:=ref(count(拐点1<=ref(拐点1,1),5)=5 ,1) and 拐点1>ref(拐点1,1),linethick2 ,colorred ;
DRAWICON(gd1,0.98*c,1);
DRAWICON(gd2,0.98*c,8);

飞狐加仓止损趋势主图指标公式

 

相关文章