在线检测未来函数

同花顺翻底朝天指标公式

来源:Internet,编辑:股旁网,2014-10-17

套牢度:100*(1-WINNER(CLOSE));
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),15,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
LOWV:=LLV(LOW,6);
HIGHV:=HHV(HIGH,6);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,2);
短1:EMA(RSV,2),colorwhite;
短2:MA(短1,2),coloryellow;
DRAWTEXT(CROSS(短1,短2),短1,'始');
DRAWTEXT(CROSS(短2,短1),短2,'终');
ABC:25;
BBC:10;
VAR12:=REF(LOW,1);
VAR13:=SMA(ABS(LOW-VAR12),3,1)/SMA(MAX(LOW-VAR12,0),3,1)*100;
VAR14:=EMA(IF(CLOSE*1.3,VAR13*10,VAR13/10),3);
VAR15:=LLV(LOW,30);
VAR6:=HHV(VAR14,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR15,(VAR14+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
资金:STICKLINE(VAR9>-120,0,VAR9,3,1),colorred;
花:=(SMA(SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1),3,1)+100)-(SMA((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70,9,1)+100);
花仙女:=IF(花>20,花-20,0);
出手:IF(CROSS(花仙女,0.01),18,0),colorred;
DRAWICON(出手>0,18,4);
CCTV:STICKLINE(REF(花仙女,1)<花仙女,花仙女,REF(花仙女,1),0.08,0),coloryellow;
BBS:STICKLINE(REF(花仙女,1)>花仙女,花仙女,REF(花仙女,1),0.08,0),colorred;
DRAWTEXT(CROSS(花仙女,0.01),1,'底确认'),COLORFF00FF;
短B:=CROSS(ZIG(3,10),REF(ZIG(3,10),1)),coloryellow;
长S:=CROSS(REF(ZIG(3,10),1),ZIG(3,10)),coloryellow;
DRAWICON(短B,1,17);
DRAWICON(长S,115,18);
VAR3A:=MA(CLOSE,13);
VAR4A:=100-ABS((CLOSE-VAR3A)/VAR3A*100);
VAR5A:=LLV(LOW,120);
VAR6A:=HHV(HIGH,120);
VAR7A:=(VAR6A-VAR5A)/100;
VAR8A:=SMA((CLOSE-VAR5A)/VAR7A,20,1);
VAR9A:=SMA((OPEN-VAR5A)/VAR7A,20,1);
VARA:=3*VAR8A-2*SMA(VAR8A,10,1);
VARB:=3*VAR9A-2*SMA(VAR9A,10,1);
VARC:=100-VARB;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12AA:=CLOSE-REF(CLOSE,1);
VAR13AA:=MAX(VAR12AA,0);
VAR14AA:=ABS(VAR12AA);
VAR15AA:=SMA(VAR13AA,7,1)/SMA(VAR14AA,7,1)*100;
VAR16:=SMA(VAR13AA,13,1)/SMA(VAR14AA,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
STICKLINE(VAR20,0,80,0.05,0),LINETHICK,colorred;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,90,'超级主力建仓!') , colorred;
VARE11:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF11:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10AA:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11AA:=VARF11<REF(VAR10AA,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR11AA AND COUNT(VAR11AA,30)=1,70,'大资金进场'),LINETHICK,colorred;
STICKLINE(VAR11AA AND COUNT(VAR11AA,30)=1,1,60,0.05,0),colorred,LINETHICK;
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
V12:=(EMA(V11,3)-REF(EMA(V11,3),1))/REF(EMA(V11,3),1)*100;
准备: STICKLINE(EMA(V11,3)<=13,0,15,0.05,0),colorlired;
AA:=(EMA(V11,3)<=13) AND FILTER((EMA(V11,3)<=13),15);
DRAWTEXT (AA,-10,'准备'),colorlired;
买入: STICKLINE(EMA(V11,3)<=13 AND V12>13,0,50,0.05,0),LINETHICK1,colorred;
BB:= (EMA(V11,3)<=13 AND V12>13) AND FILTER((EMA(V11,3)<=13 AND V12>13),10);
DRAWTEXT (BB,40,'主力资金进'),colorred;
卖临界:100;
CC:=(EMA(V11,3)>=90 AND V12) AND FILTER((EMA(V11,3)>=90 AND V12),10);
DD:=(EMA(V11,3)>=120 AND V12) AND FILTER((EMA(V11,3)>=120 AND V12),10);
STICKLINE(IF(VB>=0,VB,0) AND EMA(V11,3)<13,0,15,0.05,0),colorlired,LINETHICK1;
STICKLINE(IF(VB<=0,VB,0) AND EMA(V11,3)>90,0,10,0.01,0),LINETHICK1;
STICKLINE( IF(V4>=0,V4,1) AND EMA(V11,3)<13,0,15,0.05,0),colorlired,LINETHICK1;
STICKLINE(IF(V4<=0,V4,1) AND EMA(V11,3)>90,0,10,0.01,0),colorliblue,LINETHICK1;
DRAWTEXT (CC,20,'主力减仓'),colorliblue;
V10:=PEAKBARS(3,15,1)<10;
V12AA:=IF(V10=1,50,0);
头部:= IF(V12AA=50,100,0);
卖:IF(IF(V12AA=50,100,0)>REF(IF(V12AA=50,100,0),1),40,0);
DRAWTEXT(卖,50,'主力清仓 ');
V9AA:=TROUGHBARS(3,15,1)<10;
V11AA:=IF(V9AA=1,50,0);
底部:= IF(V11AA=50,50,0),coloryellow;
买:IF( 底部>REF(底部,1),40,0),colorred;
DRAWTEXT(买,30,'主力抄底 '),colorred;
V7AA:=TROUGHBARS(3,15,1)<10;
V911:=IF(V7AA=1,50,0);
AAA:=(O+H+L+C)/4;
B2B:=MA(AAA,3);
CIA:=SUM(IF(AAA>REF(AAA,1),AAA*VOL,0),4)/SUM(IF(AAA<REF(AAA,1),AAA*VOL,0),4);
DNA:=REF(100-(100/(1+CIA)),1);
A1:=HHV(AAA,10);
A2:=LLV(AAA,30);
A3:=A1-A2;
A4:=EMA((AAA-A2)/A3,1)*100;
B1:=HHV(AAA,16);
B2:=LLV(AAA,90);
B3:=B1-B2;
B4:=EMA((AAA-B2)/B3,1)*100;
C1:=HHV(AAA,30);
C2:=LLV(AAA,240);
C3:=C1-C2;
C4:=EMA((AAA-C2)/C3,1)*100;
中线:B4,colormagenta,LINETHICK1;
VAR1211:=(HIGH+LOW+CLOSE)/3;
VAR1311:=(VAR1211-MA(VAR1211,14))/(0.015*AVEDEV(VAR1211,14));
VAR1411:=(VAR1211-MA(VAR1211,70))/(0.015*AVEDEV(VAR1211,70));
VAR1511:=IF(VAR1311>=150 AND VAR1311<200 AND VAR1411>=150 AND VAR1411<200,10,0);
VAR1611:=IF(VAR1311<=-150 AND VAR1311>-200 AND VAR1411<=-150 AND VAR1411>-200,-10,VAR1511);
VAR1711:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR1811:=100-ABS(VAR1711);
VAR1911:=IF(VAR18<90,VAR1811,100);
VAR1A11:=IF(VARE>0,VARE,0);
VAR1B11:=IF(VAR1411>=200 AND VAR1311>=150,15,IF(VAR1411<=-200 AND VAR1311<=-150,-15,VAR1611))+60;
VAR1C11:=VAR1A11>48 AND VAR1B11>60 AND VAR1911<100;
DRAWTEXT(VAR1C11 AND COUNT(VAR1C11,30)=1,60,'大资金出货'),LINETHICK1,COLORFFCC66;
LOWWW:0;

同花顺翻底朝天指标公式

 

相关文章