在线检测未来函数

通达信将军东征主图指标公式

来源:Internet,编辑:股旁网,2014-10-20

均价1:=(2*C+(C+H+L+O)/4+O)/4;
R:=(2*L+3*均价1)/5;R1:=(2*H+3*均价1)/5;
KX:=(R+R1)/2;
CC:=ABS(R-EMA(KX,13))/EMA(KX,13);
XS:DMA(KX,CC),COLORRED DOTLINE;
XH:(1+7/100)*XS COLORYELLOW DOTLINE;
XL:(1-7/100)*XS,COLORYELLOW DOTLINE;
XT:(1+13/100)*XS,COLORGREEN DOTLINE;
XD:(1-13/100)*XS,COLORGREEN DOTLINE;
均价:=(C+(C+H+L+O)/4+O)/3;
操盘线:EMA(MA(IF(MA(均价,3)>MA(均价,4),MA((均价+3*H)/4,3),REF(MA((均价+3*L)/4,3),1)),3),5),COLORWHITE,LINETHICK2;
A1:REF(操盘线,1), COLOR8A8A8A;
A2:REF(操盘线,2), COLOR898989;
A3:REF(操盘线,3), COLOR888888;
A4:REF(操盘线,4), COLOR878787;
A5:REF(操盘线,5), COLOR868686;
A6:REF(操盘线,6), COLOR858585;
A7:REF(操盘线,7), COLOR848484;
A8:REF(操盘线,8), COLOR838383;
A9:REF(操盘线,9), COLOR828282;
A10:REF(操盘线,10), COLOR818181;
A11:=REF(操盘线,11), COLOR808080;
A12:=REF(操盘线,12), COLOR7A7A7A;
A13:=REF(操盘线,13), COLOR797979;
A14:=REF(操盘线,14), COLOR787878;
A15:=REF(操盘线,15), COLOR777777;
A16:=REF(操盘线,16), COLOR767676;
A17:=REF(操盘线,17), COLOR757575;
A18:=REF(操盘线,18), COLOR747474;
A19:=REF(操盘线,19), COLOR737373;
A20:=REF(操盘线,20), COLOR727272;
A21:=REF(操盘线,21), COLOR717171;
A22:=REF(操盘线,22), COLOR707070;
A23:=REF(操盘线,23), COLOR6A6A6A;
A24:=REF(操盘线,24), COLOR696969;
压力:MAX(A1,MAX(A2,MAX(A3,MAX(A4,MAX(A5,MAX(A6,MAX(A7,MAX(A8,MAX(A9,MAX(A10,MAX(A11,MAX(A12,MAX(A13,MAX(A14,MAX(A15,MAX(A16,MAX(A17,
MAX(A18,MAX(A19,MAX(A20,MAX(A21,MAX(A22,MAX(A23,A24))))))))))))))))))))))),COLORYELLOW,LINETHICK2;
IF((操盘线>=压力),操盘线,DRAWNULL),COLORRED,LINETHICK2;
IF((操盘线<压力),压力,DRAWNULL),COLORRED,LINETHICK2;
QA1:=REF(CLOSE,3)=HHV(CLOSE,2*3+1);
QB1:=BACKSET(QA1,3+1);
QC1:=FILTER(QB1,3) AND CLOSE=HHV(CLOSE,3+1);
QD1:=BARSLAST(QC1);
QE1:=IF(QC1,CURRBARSCOUNT,0);
QF1:=IF(QD1,REF(QE1,QD1),QE1);
QG1:=CONST(QF1);
次水平线:=DRAWLINE(CURRBARSCOUNT=QG1,CLOSE,ISLASTBAR,REF(CLOSE,QG1-1),1),COLORYELLOW ;
T1B:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1B));
CC1C:=CONST(CURRBARSCOUNT);
T2B:=CONST(BARSLAST(CURRBARSCOUNT>CC1C+T1B AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2B));
T3M:=CONST(BARSLAST(CURRBARSCOUNT>CC1C+T2B AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3M));
必杀线:=DRAWLINE(CURRBARSCOUNT=T3M+1, T3HIGH, ISLASTBAR, T3HIGH, 1),COLORRED,LINETHICK1 ;
STICKLINE(必杀线,必杀线,必杀线,3,1),COLORCYAN;
STICKLINE(次水平线,次水平线,次水平线,3,0),COLOR70DB93};
DRAWNUMBER(ISLASTBAR,必杀线,必杀线),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,次水平线,次水平线),COLORYELLOW;
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.11,0.12,0,'净流(亿):'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.1,0,'1日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.23,0.1,0,'3日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.28,0.1,0,'5日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.33,0.1,0,'10日'),COLOR8080FF,LINETHICK1;
DRAWNUMBER_FIX(1,0.18,0.15,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.23,0.15,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.28,0.15,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.33,0.15,0,CONST((净流10))),COLORYELLOW;
Z1A:=STRCAT(HYBLOCK,' ');
Z2A:=STRCAT(Z1A,FGBLOCK);
Z3A:=STRCAT(Z2A,DYBLOCK);
Z4A:=STRCAT(Z3A,' ');
DRAWTEXT_FIX(ISLASTBAR,0.25,0.98,0,STRCAT(Z4A,GNBLOCK)),COLORCYAN;
{攻防价位}
实体:=MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE);
攻防价位:(REF(实体*0.618+MIN(OPEN,CLOSE),1)),NODRAW,COLORYELLOW;
STICKLINE(ISLASTBAR,攻防价位,攻防价位,18,0),COLOR70DB93;
DRAWNUMBER(ISLASTBAR,攻防价位,攻防价位),COLORFFFF00;
DRAWKLINE(H,O,L,C);

通达信将军东征主图指标公式

 

相关文章