在线检测未来函数

通达信顺势擒龙主图指标公式

来源:Internet,编辑:股旁网,2014-10-25

AAA:=(3*C+H+L+O)/6;
VAR1:=WMA(AAA,8);
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
龙线:VAR1,COLORRED;
渊线:VAR6,COLORYELLOW;
龙跃于渊:IFF(龙线>渊线,龙线,DRAWNULL),NODRAW,COLORRED;
潜龙勿用:IFF(VAR1==VAR6,VAR6,DRAWNULL),COLORGREEN;
MA20:=EMA(CLOSE,20);
MA40:=EMA(CLOSE,40);
MA60:=EMA(C,60);
AA:=BARSLAST(MA40>MA60 AND (MA20==MA40 OR MA20>MA40));
BB:=REF(COUNT(C<MA60,AA)==AA,1);
CC:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
顺势擒龙:IFF((BB AND CC),龙线,0),NODRAW,COLORYELLOW;
上线:=MAX(CLOSE,OPEN);
下线:=MIN(CLOSE,OPEN);
STICKLINE(顺势擒龙,H,L,0,0),COLORYELLOW;
STICKLINE(顺势擒龙,上线,下线,8,0),COLOR00FFFF;
STICKLINE(顺势擒龙,上线-0.10*ABS(上线-下线),下线+0.10*ABS(上线-下线),8,0),COLOR00DDFF;
STICKLINE(顺势擒龙,上线-0.15*ABS(上线-下线),下线+0.15*ABS(上线-下线),8,0),COLOR00BBFF;
STICKLINE(顺势擒龙,上线-0.20*ABS(上线-下线),下线+0.20*ABS(上线-下线),8,0),COLOR0099FF;
STICKLINE(顺势擒龙,上线-0.25*ABS(上线-下线),下线+0.25*ABS(上线-下线),8,0),COLOR0077FF;
STICKLINE(顺势擒龙,上线-0.30*ABS(上线-下线),下线+0.30*ABS(上线-下线),8,0),COLOR0055FF;
STICKLINE(顺势擒龙,上线-0.35*ABS(上线-下线),下线+0.35*ABS(上线-下线),8,0),COLOR0033FF;
STICKLINE(顺势擒龙,上线-0.40*ABS(上线-下线),下线+0.40*ABS(上线-下线),8,0),COLOR0022FF;
STICKLINE(顺势擒龙,上线-0.45*ABS(上线-下线),下线+0.45*ABS(上线-下线),8,0),COLOR0000FF;

通达信顺势擒龙主图指标公式

 

相关文章