在线检测未来函数

通达信超级密码箱主图指标公式

来源:Internet,编辑:股旁网,2014-10-29

M1:=12;
M2:=50;
M3:=60;
EXP1:EXPMA(CLOSE,M1);
EXP2:EXPMA(CLOSE,M2);
EXP3:EXPMA(CLOSE,M3);
AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);
BA:=EMA(AB,5);
A1{高}:=REFDATE(REF(HHV(H,96),5),DATE);
B1{低}:=REFDATE(REF(LLV(L,96),5),DATE);
DY{中}:=((A1)+(B1))/2;
箱顶:IF(AB>0 AND AB-BA<=0,A1,A1),LINETHICK3,COLOR00FF00;
箱腰:IF(AB>0 AND AB-BA<=0,DY,DY),LINETHICK3,COLOR00FF00;
箱低:IF(AB>0 AND AB-BA<=0,B1,B1),LINETHICK3,COLOR00FF00;
高1:IF(AB>0 AND AB-BA>0,A1,DRAWNULL),LINETHICK3,COLORRED;
中1:IF(AB>0 AND AB-BA>0,DY,DRAWNULL),LINETHICK3,COLORRED;
低1:IF(AB>0 AND AB-BA>0,B1,DRAWNULL),LINETHICK3,COLORRED;
顶周期:=TOPRANGE(H);底周期:=LOWRANGE(L);
上内:=LLVBARS(H,顶周期);上外:=LLVBARS(L,顶周期);
下内:=HHVBARS(L,底周期);下外:=HHVBARS(H,底周期);
上力度:=HHV(L,上内+1)>LLV(H,上内+1);
下力度:=HHV(L,下内+1)>LLV(H,下内+1);
上包含:=COUNT(L>=REF(L,1),上外)>2 AND COUNT(H>=REF(H,1),上内)>2;
下包含:=COUNT(H<=REF(H,1),下外)>2 AND COUNT(L<=REF(L,1),下内)>2;
顶0:=顶周期 AND 上力度 AND 上包含 AND 上外>3;
底0:=底周期 AND 下力度 AND 下包含 AND 下外>3;
顶分天数:=BARSLAST(顶0);
底分天数:=BARSLAST(底0);
含中间K线:=IF(顶分天数=0,底分天数,顶分天数)>=3;
顶:=顶0 AND 含中间K线 AND H=HHV(H,BARSLAST(底0));
底:=底0 AND 含中间K线 AND L=LLV(L,BARSLAST(顶0));
NOTEXT上笔划线:DRAWLINE(底,L,顶,H,0),COLORLIRED,LINETHICK3;
NOTEXT下笔划线:DRAWLINE(顶,H,底,L,0),COLORLIGREEN,LINETHICK3;
分界点:=NOTEXT上笔划线 AND NOTEXT下笔划线;
位置调整:=
IF(PERIOD=11,0.02,{年}
IF(PERIOD=10,0.02,{季}
IF(PERIOD=9,0.02, {多日}
IF(PERIOD=8,0.001,{多分钟}
IF(PERIOD=7,0.02, {月}
IF(PERIOD=6,0.01, {周}
IF(PERIOD=5,0.005, {日}
IF(PERIOD=4,0.002,{60F}
IF(PERIOD=3,0.001,{30F}
IF(PERIOD=2,0.001,{15F}
IF(PERIOD=1,0.0003,{5F}
IF(PERIOD=0,0.0002,{1F}0))))))))))));
DRAWNUMBER(分界点 AND 顶,H+H*位置调整,H),COLORLIGREEN;
DRAWNUMBER(分界点 AND 底,L,L),COLORLIMAGENTA;

通达信超级密码箱主图指标公式

 

相关文章