在线检测未来函数

通达信短线猎杀主图指标公式

来源:Internet,编辑:股旁网,2014-10-29

逃跑线:MA(CLOSE,5),COLOR00FFFF;
猎杀线:MA(CLOSE,34),COLOR00AAFF;
追捕线:MA(CLOSE,55),COLOR0066FF;
多头:=猎杀线>REF(猎杀线,1) AND 追捕线>REF(追捕线,1);
BUY:=FILTER(EXIST(CROSS(猎杀线,追捕线),3) AND C>MAX(逃跑线,MAX(猎杀线,追捕线)) AND 多头,3);
SELLB:=CROSS(逃跑线,C);
SELL:=SELLB AND COUNT(SELLB,BARSLAST(BUY))=1;
短线猎杀买入:BUY,NODRAW,COLORYELLOW;
短线猎杀卖出:SELL,NODRAW,COLORGREEN;
上线:=MAX(CLOSE,OPEN);
下线:=MIN(CLOSE,OPEN);
STICKLINE(BUY,H,L,0,0),COLORYELLOW;
STICKLINE(BUY,上线,下线,8,0),COLOR00FFFF;
STICKLINE(BUY,上线-0.10*ABS(上线-下线),下线+0.10*ABS(上线-下线),8,0),COLOR00DDFF;
STICKLINE(BUY,上线-0.15*ABS(上线-下线),下线+0.15*ABS(上线-下线),8,0),COLOR00BBFF;
STICKLINE(BUY,上线-0.20*ABS(上线-下线),下线+0.20*ABS(上线-下线),8,0),COLOR0099FF;
STICKLINE(BUY,上线-0.25*ABS(上线-下线),下线+0.25*ABS(上线-下线),8,0),COLOR0077FF;
STICKLINE(BUY,上线-0.30*ABS(上线-下线),下线+0.30*ABS(上线-下线),8,0),COLOR0055FF;
STICKLINE(BUY,上线-0.35*ABS(上线-下线),下线+0.35*ABS(上线-下线),8,0),COLOR0033FF;
STICKLINE(BUY,上线-0.40*ABS(上线-下线),下线+0.40*ABS(上线-下线),8,0),COLOR0022FF;
STICKLINE(BUY,上线-0.45*ABS(上线-下线),下线+0.45*ABS(上线-下线),8,0),COLOR0000FF;
DRAWICON(BUY,L,1);
DRAWICON(SELL,H,2);

通达信短线猎杀主图指标公式

 

相关文章