在线检测未来函数

大智慧准买卖指标公式

来源:Internet,编辑:股旁网,2014-10-28

RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:= SMA(RSV,3,1);
D:= SMA(K,3,1);
J:= 3*K-2*D;
STICKLINE(K>D,D,K,6,0),COLORFF00FF;
STICKLINE(K<=D,D,K,6,0),COLORFF0000;
DRAWTEXT(K>D,0,'買'),COLOR0000FF;
DRAWTEXT(K<D,0,'賣'),COLORFF0000;
DRAWTEXT(D<REF(D,1),0,'賣'),COLORFF0000;
DRAWTEXT(J>=REF(J,1),0,'買'),COLOR0000FF;
N:= 2;
M:= 3;
VAR2:= 1;
VAR3:= REF(HIGH,1)*1.1;
VAR4:= HIGH*1.1;
VAR5:= (VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
VAR6:= REF(LOW,1)*0.9;
VAR7:= LOW*0.9;
VAR8:= (VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
VAR9:= EMA(VAR8,30);
VARA:= EMA(VAR5,30);
VARB:= VARA-2;
VARC:= IF(CLOSE<=VAR9,VARB,VARA);
VARD:= MA(CLOSE,80)-MA(CLOSE,10)/17;
STICKLINE(VARC-VARB=0 AND VAR2 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),50,0,5,0),LINETHICK0,COLOR0000FF;
DRAWTEXT(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),4),55,'买入'),COLOR00FFFF;
VARE:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
卖出线: SMA(SMA(VARE,3,1),3,1),LINETHICK0,COLORFF6633;
买入线: 3*SMA(VARE,3,1)-2*卖出线,LINETHICK0,COLOR0000FF;
DRAWICON(CROSS(90,买入线),90,2),COLOR00FFFF;
STICKLINE(CROSS(90,买入线),15,0,5,0),LINETHICK0,COLOR008000;
STICKLINE(SMA(VARE,3,1)>卖出线,SMA(VARE,3,1),卖出线,4,0),LINETHICK0,COLOR1133FF;

大智慧准买卖指标公式

 

相关文章