在线检测未来函数

通达信红宝利中线指标公式

来源:Internet,编辑:股旁网,2014-10-30

AR1:=((((2 * CLOSE) + HIGH) + LOW) / 4);
AR2:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
VARC:=EMA((((AR1 - AR2) / (VARB - AR2)) * 100),8);
VARD:=EMA(VARC,5);
升:=((VARC - VARD) > 0);
跌:=((VARC - VARD) < 0);
升势:STICKLINE(((VARC - VARD) > 0),VARC,VARD,3,1),COLORFF10FF;
跌势:STICKLINE(((VARC - VARD) < 0),VARC,VARD,3,1),COLOR10FF10;
VAR10:=REF(CLOSE,1);
VAR11:=((SMA(MAX((CLOSE - VAR10),0),7,1) / SMA(ABS((CLOSE - VAR10)),7,1)) * 100);
VAR12:=(FILTER(CROSS(79,VAR11),4) * 190);
VAR13:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR14:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
VAR15:=(FILTER(CROSS(VAR13,VAR14),4) * 200);
VAR16:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
VAR18:=IFF((VAR16 > 90),50,100);
VAR19:=(FILTER(CROSS(VAR18,VAR16),4) * 100);
VR1:=((4 * SMA((((CLOSE - LLV(LOW,25)) / (HHV(HIGH,25) - LLV(LOW,25))) * 100),5,1)) - (3 * SMA(SMA((((CLOSE - LLV(LOW,25)) / (HHV(HIGH,25) - LLV(LOW,25))) * 100),5,1),3,1)));
买入:=IFF(CROSS(VR1,8),2,0);
红柱买:STICKLINE(买入>0,0,50,2,0),COLORRED;
STICKLINE(VAR12,100,80,4,0),COLORFFFF00;
STICKLINE(VAR15,100,90,8,0),COLORFF00FF;
DRAWTEXT(VAR12,80,'顶1'),COLORGREEN;
DRAWTEXT(VAR15,100,'顶2');
DRAWICON(VAR19,100,12);

通达信红宝利中线指标公式

 

相关文章