在线检测未来函数

通达信飞越彩泓主图指标公式

来源:Internet,编辑:股旁网,2014-11-02

R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R4:=(REF(R3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R6:=(REF(R5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R8:=(REF(R7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RA:=(REF(R9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RC:=(REF(RB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
RE:=(REF(RD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RF:=(REF(RE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R11:=(REF(R10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R13:=(REF(R12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R15:=(REF(R14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R17:=(REF(R16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R19:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
短买春:R19,NODRAW,COLOR00DD00;
秋离场:R1A,NODRAW,COLOR2288EE;
持股:R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,NODRAW,COLOR0000FF;
急速超跌关注:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORBBBBBB,NODRAW;
Q1:=CONST(IF(短买春,0,IF(秋离场,180,IF(红持股,220,IF(急速超跌关注,150,100))))),NODRAW;
Q2:=CONST(IF(短买春,150,IF(秋离场,100,IF(红持股,0,IF(急速超跌关注,150,100))))),NODRAW;
Q3:=CONST(IF(短买春,0,IF(秋离场,50,IF(红持股,50,IF(急速超跌关注,150,100))))),NODRAW;
DRAWGBK(C>0,RGB(Q1,Q2,Q3),RGB(0,50,50),0,' ',0);
{彩色K线}
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
MA5:MA(CLOSE,5),COLORWHITE,LINETHICK2;
MA10:MA(CLOSE,10),COLORYELLOW,LINETHICK2;
MA20:MA(CLOSE,20),COLORMAGENTA,LINETHICK2;
MA40:MA(CLOSE,40),COLORF0F000,LINETHICK2;
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK2;
MA120:MA(CLOSE,120),COLORBROWN,LINETHICK2;
MA250:MA(CLOSE,250),COLORBLUE,LINETHICK2;
MA600:MA(CLOSE,300),COLORRED,LINETHICK2;
DRAWICON(CROSS(MA60,MA120),MA60,1); {60日上穿120日做记号}
DRAWICON(CROSS(MA60,MA250),MA60,1); {60日上穿250日做记号}
DRAWICON(CROSS(MA60,MA600),MA60,1); {60日上穿600日做记号}
DRAWICON(CROSS(MA120,MA250),MA120,1);{120日上穿250日做记号}
DRAWICON(CROSS(MA120,MA600),MA120,1);{120日上穿600日做记号}
DRAWICON(CROSS(MA250,MA600),MA250,1); {250日上穿600日做记号}
反弹托:=MA5>MA20 AND MA5>MA20 AND MA20<MA60 AND MA60<MA120 AND CROSS(MA10,MA20);
月价托:=MA5>MA20 AND MA5>MA10 AND CROSS(MA10,MA20);
季价托:=MA20>MA60 AND MA20>MA40 AND CROSS(MA40,MA60);
短长价托:=MA5>MA60 AND MA5>MA10 AND CROSS(MA10,MA60);
半年托:=MA60>MA120 AND CROSS(MA60,MA120);
熊来:=MA60<MA120 AND CROSS(MA120,MA60);
年托:=MA120>MA250 AND CROSS(MA120,MA250);
月蜘蛛:=MA5>MA10 AND MA10>MA20 AND CROSS(MA5,MA20)AND CROSS(MA10,MA20);
DRAWTEXT(CROSS(MA250,MA600),MA250,'飞越彩泓'),COLORMAGENTA,LINETHICK4;
DRAWTEXT(月蜘蛛,L-0.12,'金蜘蛛'),COLOR0011FF;
STICKLINE(月蜘蛛,H,L,0.5,1),COLOR0011FF;
STICKLINE(月蜘蛛,O,C,6,1),LINETHICK2,COLOR0011FF;
DRAWTEXT(反弹托,L-0.12,'反弹托'),COLOR0055FF;
STICKLINE(反弹托,H,L,0.5,1),COLOR0055FF;
STICKLINE(反弹托,O,C,6,1),LINETHICK2,COLOR0055FF;
DRAWTEXT(月价托,L-0.12,'月价托'),COLORYELLOW;
STICKLINE(月价托,H,L,0.5,1),COLORYELLOW;
STICKLINE(月价托,O,C,6,1),LINETHICK2,COLORYELLOW;
DRAWTEXT(季价托,L-0.12,'季价托'),COLOR0099FF;
STICKLINE(季价托,H,L,0.5,1),COLOR0099FF;
STICKLINE(季价托,O,C,6,1),LINETHICK2,COLOR0099FF;
DRAWTEXT(短长价托,L-0.12,'短长价托'),COLOR36C0C1;
STICKLINE(短长价托,H,L,0.4,1),COLOR36C0C1;
STICKLINE(短长价托,O,C,6,1),LINETHICK2,COLOR36C0C1;
DRAWTEXT(半年托,MA120-0.08,'牛市来'),COLORRED;
DRAWTEXT(年托,MA250-0.08,'年托'),COLORRED;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL20:=MA(VOL,20),COLORFF00FF ;
量托:=VOL5>=VOL20 AND CROSS(VOL10,VOL20) AND REF(VOL10,1)<REF(VOL20,1);
DRAWTEXT(量托,L-0.12,'量托'),COLORWHITE;
STICKLINE(量托,H,L,0.4,1),COLORWHITE;
STICKLINE(量托,O,C,6,1),LINETHICK2,COLORWHITE;
AA:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10));
BB:=REF(COUNT(C<MA60,AA)=AA,1);
CC:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC,COLOR00FF00;
DRAWTEXT(芙蓉出水,H+0.12,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,4,1),LINETHICK2,COLORFF00FF;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,30);
ZJ:=AMOUNT/10000;{资金}
TM:=V-MA(V,10);{量填满}
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
DRAWTEXT(一穿三,L-0.12,'穿三线'),COLORFFFFFF;
STICKLINE(一穿三,H,L,0.5,1),COLORFFFFFF;
STICKLINE(一穿三,O,C,3,1),LINETHICK2,COLORFFFFFF;
C6:=REF(C,1);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
VVAR2:=LLV(LOW,10);
VVAR3:=HHV(HIGH,25);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'短进'),COLORFF00FF;
DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'见底'),COLORRED;
DRAWICON(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,1);
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;
阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
拉升线:IF(CURRBARSCOUNT=1 AND REF(C,1)<REF(C,2) AND C>REF(C,1) AND MA5>REF(MA5,1),CONST(REF(C,1)*1.01),DRAWNULL),COLORYELLOW;
M1:STICKLINE(CURRBARSCOUNT=1 AND C>=REF(C,1),拉升线,拉升线*0.998,20,0),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1 AND 拉升线=CONST(REF(C,1)*1.01),L*0.99,'上穿此线介入'),COLORYELLOW;
DRAWKLINE(H,拉升线,L,C);
{筹码突破}
筹码突破:C>TYX3 AND(C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),COLORRED;
{45度异动}
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45上升'),COLORYELLOW;
{底顶侦探}
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=EMA(EMA(EMA(VAR1,4),4),4);
SJ:=(VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
SD:=MA(SJ,2);
SK:=MA(SJ,1);
VAR3:=CROSS(SK,SD) AND SK<0;
VAR4:=CROSS(SK,0);
VAR6:=CROSS(SK,SD) AND SK>0;
BY:=VAR3, STICK;
DRAWICON(BY,L*0.96,23);
BE:=VAR4 OR VAR6, STICK;
DRAWICON(BE,L*0.96,25);
VAR7:=CROSS(SD,SK);
MC:=VAR7, STICK;
{漓江}
VAR13:=(2*CLOSE+HIGH+LOW)/4;
T:=80, POINTDOT;
VAR14:=LLV(LOW,5);
VAR15:=HHV(HIGH,4);
SK1:=EMA((VAR13-VAR14)/(VAR15-VAR14)*100,4);
SD1:=EMA(0.667*REF(SK1,1)+0.333*SK1,2);
{VAR4:=(HHV(HIGH,4)-VAR1)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
漓江倒影: SMA(VAR4,4,1), LINESTICK;}
VAR17:=(VAR13-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
VAR18:=SMA(VAR17,2,1);
桂林山水:=SMA(VAR18,2,1), LINESTICK;
{顶底背离}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLORRED;
{DRAWICON(CROSS(FF,MA15),(LOW * 0.99),7); }
{顶背离}
RSI1:=((SMA(MAX((CLOSE - (REF(CLOSE,1))),0),3,1) / SMA(ABS((CLOSE - (REF(CLOSE,1)))),3,1))* 100);
DRAWTEXT(CROSS(88,RSI1) AND (MA(C,3))>(EMA(C,3)) ,(HIGH + 0.3),'顶背离'),COLORGREEN;
{DRAWICON(CROSS(88,RSI1) AND (MA(C,3))>(EMA(C,3)) ,(HIGH + 0.3),8); };
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)>C AND
REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)
<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")
>0,L-0.02,'MACD底背离'),COLORRED;{MACD底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)>C AND
REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)<"KDJ.K" AND
CROSS("KDJ.K","KDJ.D"),L-0.10,'KDJ底背离'),COLORBLUE;{KDJ底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)>C AND
REF("RSI.RSI1",BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)
<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")
>0,L-0.18,'RSI底背离');{RSI底背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)<C
AND REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)
>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")
>0,H+0.16,'MACD顶背离'),COLORGREEN;{MACD顶背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)<C
AND REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)
>"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.08,'KDJ顶背离');{KDJ顶背离};
{涨跌提示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(涨停,OPEN,CLOSE,1.5,0),COLORYELLOW;
跌停:=IF((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(跌停,OPEN,CLOSE,1.5,0),COLORWHITE;

通达信飞越彩泓主图指标公式

 

相关文章