在线检测未来函数

飞狐五行线分割主图指标公式

来源:Internet,编辑:股旁网,2014-11-03

{均线}
Var1:=(HIGH+LOW+OPEN+CLOSE)/4;
A线:MA(3*Var1-2*SMA(Var1,2,1),13),COLORGREEN,LINETHICK1;
B线:=EMA(MA(CLOSE,13),2);
C线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),60)*0.985,linethick1,colorgray;
FILLRGN(A线>C线,A线,C线),COLOR0984FF,LINETHICK1;
FILLRGN(A线>B线,B线,A线),COLOR83CBFC,LINETHICK1;
FILLRGN(A线<=B线*1.0062,A线,C线),COLORFFFF68,LINETHICK1;
D线:B线,linethick1,LINEDOT,colorFFFF00;
PARTLINE(A线>C线,C线),LINETHICK1,Color002288;
PARTLINE(A线<C线,C线),LINETHICK1,Color11412E;
PARTLINE(A线>B线,A线),LINETHICK1,Color002288;
PARTLINE(A线<B线,A线),LINETHICK1,Color11412E;
{最佳实用五行分割线}
SS:=30;
HhC:=HHV(h,SS);
LLc:=LLV(L,SS);
AA:PARTLINE(BARPOS>=SYSPARAM(1)-SS,hHC[SYSPARAM(1)]),COLORGREEN;{1}
DRAWNUMBER(BARPOS=SYSPARAM(1)-SS,hHC[SYSPARAM(1)],hHC[SYSPARAM(1)],2),COLORFF88CC,PXUP25;
BB:PARTLINE(BARPOS>=SYSPARAM(1)-SS,(hHC[SYSPARAM(1)]*3+LLc[SYSPARAM(1)])/4),COLORYELLOW,POINTDOT;{2}
CC:PARTLINE(BARPOS>=SYSPARAM(1)-SS,(hHC[SYSPARAM(1)]+LLc[SYSPARAM(1)])/2),COLORWHITE;{3}
DRAWNUMBER(BARPOS=SYSPARAM(1)-SS,(hHC[SYSPARAM(1)]+LLc[SYSPARAM(1)])/2,(hHC[SYSPARAM(1)]+LLc[SYSPARAM(1)])/2,2),COLORFF88CC,PXUP25;
DD:PARTLINE(BARPOS>=SYSPARAM(1)-SS,(hHC[SYSPARAM(1)]+LLc[SYSPARAM(1)]*3)/4),COLORYELLOW,POINTDOT;{4}
EE:PARTLINE(BARPOS>=SYSPARAM(1)-SS,LLc[SYSPARAM(1)]),COLORRED;{5}
DRAWNUMBER(BARPOS=SYSPARAM(1)-SS,LLc[SYSPARAM(1)],LLc[SYSPARAM(1)],2),COLORFF88CC,PXUP25;
{K线 }
MA10:=ma(C,10),coloryellow,linethick;
STICKLINE(C>MA10 and C>O,C,O,8,1), COLOR0505B6;
STICKLINE(C>MA10 and C>O,O,L,1,1), COLOR0505B6;
STICKLINE(C>MA10 and C>O,C,H,1,1), COLOR0505B6;
STICKLINE(C>MA10 and C<O,C,O,8,0), COLOR0505B6;
STICKLINE(C>MA10 and C<O,O,L,1,1), COLOR0505B6;
STICKLINE(C>MA10 and C<O,C,H,1,1), COLOR0505B6;
STICKLINE(C<MA10 and C>O,C,O,8,1), COLOR618F6A;
STICKLINE(C<MA10 and C>O,O,L,1,1), COLOR618F6A;
STICKLINE(C<MA10 and C>O,C,H,1,1), COLOR618F6A;
STICKLINE(C<MA10 and C<O,C,O,8,0), COLOR618F6A;
STICKLINE(C<MA10 and C<O,C,L,1,1), COLOR618F6A;
STICKLINE(C<MA10 and C<O,O,H,1,1), COLOR618F6A;

飞狐五行线分割主图指标公式

 

相关文章