在线检测未来函数

通达信立体渔网主图指标公式

来源:Internet,编辑:股旁网,2014-11-03

CC:=(3*C+H+L+O)/6;
MA6:=EMA(MA(IF(MA(CC,3)>MA(CC,4),MA((CC+3*H)/4,3),REF(MA((CC+3*L)/4,3),1)),3),5);
REF(MA6,1), COLOR8A8A8A;
REF(MA6,2), COLOR898989;
REF(MA6,3), COLOR888888;
REF(MA6,4), COLOR878787;
REF(MA6,5), COLOR868686;
REF(MA6,6), COLOR858585;
REF(MA6,7), COLOR848484;
REF(MA6,8), COLOR838383;
REF(MA6,9), COLOR828282;
REF(MA6,10), COLOR818181;
REF(MA6,11), COLOR808080;
REF(MA6,12), COLOR7A7A7A;
REF(MA6,13), COLOR797979;
REF(MA6,14), COLOR787878;
REF(MA6,15), COLOR777777;
REF(MA6,16), COLOR767676;
REF(MA6,17), COLOR757575;
REF(MA6,18), COLOR747474;
REF(MA6,19), COLOR737373;
REF(MA6,20), COLOR727272;
REF(MA6,21), COLOR717171;
REF(MA6,22), COLOR707070;
REF(MA6,23), COLOR6A6A6A;
REF(MA6,24), COLOR696969;
REF(MA6,25), COLOR686868;
REF(MA6,26), COLOR676767;
REF(MA6,27), COLOR666666;
REF(MA6,28), COLOR656565;
REF(MA6,29), COLOR646464;
REF(MA6,30), COLOR636363;
REF(MA6,31), COLOR626262;
REF(MA6,32), COLOR616161;
REF(MA6,33), COLOR606060;
A0:=FROMOPEN;
P:=DATETODAY(FROMOPEN);
A:=IF(P=1,A0,IF(P=2,A0/5,IF(P=3,A0/15,IF(P=4,A0/30,IF(P=5,A0/60,IF(P=0,0,1))))));
均价线:=IF(CAPITAL>0,SUM(AMOUNT,A)/100/SUM(VOL,A),SUM(CLOSE*VOL,A)/SUM(VOL,A));
额势:=IF(CAPITAL>0,均价线,1);
取势:=IF(SMA(额势,3,2)>SMA(额势,5,3),(O+2*HHV(H,2))/3,(O+2*LLV(L,2))/3);
短1:=(EMA(取势,1)+MA(取势,3)+MA(取势,5))/3;
短2:=(EMA(取势,3)+MA(取势,6)+MA(取势,9))/3;
趋势线1:=SMA(FORCAST(CLOSE,13),5,1),COLORCYAN,LINETHICK1;
趋势线2:(EMA(SMA(FORCAST(取势,12),4,1),4)+趋势线1)/2,LINETHICK1;
趋势线3:(EMA(SMA(FORCAST(取势,12),20,1),4)+趋势线1)/2,LINETHICK1;
浅蓝:PLOYLINE(趋势线1>REF(趋势线1,1),趋势线2),COLORFFAA00,LINETHICK2;
橘黄:PLOYLINE(趋势线1<REF(趋势线1,1),趋势线2),COLOR0088FF,LINETHICK2;
MA6,COLOR66FFFF,LINETHICK6;
PLOYLINE(1,MA6),COLOR878787;
A01:="RSI.RSI1"(6,12,24);
ZF:=(C-REF(C,1))/REF(C,1)*100;
选股:(CROSS(A01,50) AND ZF>3)*10,LINETHICK;
DRAWICON(CROSS(A01,50) AND ZF>3,L*0.98,1);
MA20:=MA(C,20),COLORWHITE,LINETHICK2;
乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;
卖点:=CROSS(C,乖离线);
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7) ;
X9:=FILTER(X8,4) ;
出货:=X9;
条件A:=卖点 AND C<O;
条件B:出货 AND C<O,LINETHICK;
显示A_B:=(REF(BARSLAST(条件A OR 条件B)>=4,1) AND 条件B ) OR 条件A;
限制性出现出货:DRAWTEXT((REF(BARSLAST(条件A OR 条件B)>=4,1) AND 条件B ),(HIGH * 1.02),'出货'),COLOR9000F5;
允许出现卖点:DRAWTEXT(条件A ,H+0.13,'卖点'),COLOR00FF00;
DRAWTEXT(显示A_B,(H+L)/2,'★'),COLORLIGREEN;
★:DRAWTEXT(C>MA(C,20) AND (MA(C,5)>MA(C,10) AND MA(C,5)<MA(C,20)) OR (C>MA(C,20) AND MA(C,5)>MA(C,10) AND MA(C,10)<MA(C,20)) OR(C>MA(C,20) AND MA(C,5)>MA(C,10) AND MA(C,10)<MA(C,20)),MA(C,20),'★'),COLORLIRED;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,3.2,0 ),COLOR003333;
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,2.8,0 ),COLOR004444;
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,2.4,0 ),COLOR005555;
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,2,0 ),COLOR007777;
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,1.6,0 ),COLOR009999;
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,1.2,0 ),COLOR00BBBB;
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,0.8,0 ),COLOR00DDDD;
STICKLINE(CLOSE<OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,0.4,0 ),COLOR00FFFF;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,3.2,0 ),COLOR000033;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,2.8,0 ),COLOR000044;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,2.4,0 ),COLOR000055;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,2,0 ),COLOR000077;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,1.6,0 ),COLOR000099;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,1.2,0 ),COLOR0000BB;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,0.8,0 ),COLOR0000DB;
STICKLINE(CLOSE>=OPEN AND CLOSE>=REF(CLOSE,1),CLOSE,OPEN,0.4,0 ),COLOR0000FF;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,3.2,0 ),COLORFF00CA;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,2.8,0 ),COLORFF00CC;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,2.4,0 ),COLORFF00DB;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,2,0 ),COLORFF00DD;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,1.6,0 ),COLORFF00DF;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,1.2,0 ),COLORFF00EE;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,0.8,0 ),COLORFF00EF;
STICKLINE(CLOSE>=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,0.4,0 ),COLORFF00FF;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,3.2,0 ),COLOR333300;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,2.8,0 ),COLOR444400;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,2.4,0 ),COLOR555500;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,2,0 ),COLOR777700;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,1.6,0 ),COLOR999900;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,1.2,0 ),COLORBBBB00;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,0.8,0 ),COLORDDDD00;
STICKLINE(CLOSE<OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,0.4,0 ),COLORFFFF00;

通达信立体渔网主图指标公式

 

相关文章