在线检测未来函数

通达信奇效多空指标公式

来源:Internet,编辑:股旁网,2014-11-05

{A:EMA((CLOSE-REF(C,1))/REF(C,1)*10-
(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*10,5),LINETHICK1,COLORRED;
STICKLINE(A>0,0,A,3,2),LINETHICK1,COLORRED;
STICKLINE(A<0,0,A,3,2),LINETHICK2,COLORGREEN;}
HSNP1:=CLOSE-REF(CLOSE,1);
HSNP2:=IF(CLOSE-REF(CLOSE,1)>=0,HSNP1,0);
HSNP3:=REF(CLOSE,1)-CLOSE;
HSNP4:=IF(CLOSE-REF(CLOSE,1)<=0,HSNP3,0);
HSN:=SUM(HSNP2,90)/SUM(HSNP4,90);
HSNP6:=100-100/(1+HSN);
HSNP7:=EMA(HSNP6,21);
HSNP8:=EMA(HSNP7,5);
HSNP:=EMA(HSNP8,3);
NP:= (HSNP7-HSNP),COLORMAGENTA,LINETHICK1;
涨动力:IF(NP>0,NP,0),COLORMAGENTA;
NL:=(HSNP-HSNP7),COLORYELLOW,LINETHICK1;
跌动力:=IF(NL>0,NL,0),COLORBLUE;
STICKLINE(NL<0,0,-NL,1,2),COLOR0B0B77;
STICKLINE(NP<0,0,NP,1,2),COLOR666666;
JJ :=(C*2+H+L)/4;
SK := EMA(JJ,13) - EMA(JJ,21);
SD := EMA(SK,3);
SP := EMA(SK,10);
长线1:IF(SD>=SP,SD,SP),LINETHICK2,COLORMAGENTA;
长线2:IF(SP-SD,SP,SD),LINETHICK2,COLORWHITE;
A1:=EMA(CLOSE,7)-EMA(CLOSE,21);
B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);
做多:IF(A1>=B1,A1,B1),LINETHICK2,COLORRED;
做空:IF(B1-A1,B1,A1),LINETHICK2,COLORGREEN;

通达信奇效多空指标公式

 

相关文章