在线检测未来函数

飞狐BIAS和MACD指标公式

来源:Internet,编辑:股旁网,2014-11-12

DRAWGBK(C=C,COLORRGB(130,130,130),COLORRGB(30,30,30),1);
BIAS1 := (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
BIAS2 := (CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
BIAS3 := (CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
BIASAA:=(BIAS1+BIAS2+BIAS3)/3;
dif:=(ema(BIASAA,5)-ema(BIASAA,34));
de:=ema(dif,9);
macd:3*(dif-de);
//////////////
{红柱}
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,3,0),COLOR0000AA;
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,2.7,0),COLOR0000BB;
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,2.3,0),COLOR0000CC;
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,2,0),COLOR0000CC;
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,1.6,0),COLOR0000DD;
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,1.2,0),COLOR0000EE;
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,0.8,0),COLOR0000FF;
STICKLINE(macd>0 and macd>ref(macd,1),macd,0,0.5,0),COLORRED;
{黄柱}
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,3,0),color0090FF;
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,2.7,0),color009FFF;
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,2.3,0),color00a6FF;
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,2,0),color00b5FF;
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,1.6,0),color00c4FF;;
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,1.2,0),Color00d3ff;
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,0.8,0),color00e2FF;
STICKLINE(macd>0 and macd<ref(macd,1),macd,0,0.5,0),color00FFFF;
{蓝柱}
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,3,0),COLORFF0000;
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,2.7,0),COLORFF3300;
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,2.3,0),COLORFF5500;
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,2,0),COLORFF7700;
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,1.6,0),COLORFF9900;
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,1.2,0),COLORFFBB00;
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,0.8,0),COLORFFDD00;
STICKLINE(macd<0 and macd<ref(macd,1),macd,0,0.5,0),COLORFFFF00;
{粉柱}
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,3,0),ColorFF00a9;
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,2.7,0),ColorFF00a1;
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,2.3,0),ColorFF00aa;
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,2,0),ColorFF00bb;
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,1.6,0),ColorFF00cc;
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,1.2,0),ColorFF00dd;
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,0.8,0),ColorFF00ee;
STICKLINE(macd<0 and macd>ref(macd,1),macd,0,0.5,0),ColorFF00ff;
/////////
b5:=sMA(BIAS1,2,1),COLORGREEN,LINETHICK1,LINEDOT;
b13:=sma(BIAS2,2,1),LINETHICK0,COLORRED;
b34:=sMA(BIAS3,5,1),COLORWHITE,LINETHICK1;
m13_5:ema(b13,5),COLORWHITE,LINETHICK1;
m13_10:ema(b13,10),COLORCYAN,LINETHICK1;
m34_5:=ema(b34,5),COLORGREEN,,LINEDOT;
m34_10:=ema(b34,10),COLORMAGENTA,LINEDOT;
PARTLINE(B13>REF(B13,1),B13),COLORRED,LINETHICK3;
PARTLINE(B13<REF(B13,1),B13),ColorFF0F80,LINETHICK3;
cysm13:b13,LINETHICK0,COLORBROWN;
主力:m34_5,COLORGREEN,,LINEDOT;
游资:m34_10,COLORMAGENTA,LINEDOT;
/////////
DRAWICON(CROSS(b13,m13_5),m13_5,12),ALIGN;
DRAWICON(CROSS(m13_5,b13),m13_5,11),ALIGN;
DRAWICON(cross(m13_5,m13_10) and b13>ref(b13,1),0,3),ALIGN;
DRAWICON(cross(m34_5,m13_10) and b13>ref(b13,1) ,0,1),ALIGN;
VERTLINE(cross(主力,游资)),LINEDOT,COLORRED;
/////////////
AAA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AAA,0),5,1)/SMA(ABS(CLOSE-AAA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6;
短线出击:IF(CROSS(短线买点,1) AND (短线买点<30),10,0),COLORWHITE,LINETHICK2;

飞狐BIAS和MACD指标公式

 

相关文章