在线检测未来函数

通达信筹码出逃指标公式

来源:Internet,编辑:股旁网,2014-11-15

L3: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(3),0),RGB(85,85,85),IF(PERIOD=5 OR PERIOD=6,100*PPART(5),0),RGB(85,85,85));
L5: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(5),0),RGB(120,30,30),IF(PERIOD=5 OR PERIOD=6,100*PPART(10),0),RGB(120,30,30));
L10: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(10),0),RGB(200,100,100),IF(PERIOD=5 OR PERIOD=6,100*PPART(20),0),RGB(200,100,100));
L20: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(20),0),RGB(180,60,120),IF(PERIOD=5 OR PERIOD=6,100*PPART(30),0),RGB(180,60,120));
L30: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(30),0),RGB(150,80,00),IF(PERIOD=5 OR PERIOD=6,100*PPART(60),0),RGB(150,80,00));
L60: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(60),0),RGB(180,180,80),IF(PERIOD=5 OR PERIOD=6,100*PPART(100),0),RGB(180,180,80));
L100: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(100),0),RGB(150,150,0),IF(PERIOD=5 OR PERIOD=6,100*PPART(240),0),RGB(150,150,0));
L240: DRAWBAND(IF(PERIOD=5 OR PERIOD=6,100*PPART(240),0),RGB(100,80,80),IF(PERIOD=5 OR PERIOD=6,100*PPART(240),0),RGB(100,80,80));
DRAWICON(CROSS(L30,60),60,1);
DRAWICON(CROSS(L60,60),60,1);
DRAWICON(CROSS(L60,50),50,1);
LL30: 100*PPART(30);
LL31:=100*PPART(31);
CT30:(LL31-REF(LL30,1))/REF(LL30,1)*100 COLORGRAY LINETHICK3;
LL60:=100*PPART(60);
LL61:=100*PPART(61);
CT60:(LL61-REF(LL60,1))/REF(LL60,1)*100 COLORRED LINETHICK3;
Q30:PWINNER(30,C)*100 COLORBLUE LINETHICK2;
Q60:=PWINNER(60,C)*100 COLORBLACK LINETHICK2;
ZF30:(C/ REF(MA(C,30),30)-1)*100 COLORLIBLUE LINETHICK2;
ZF60:(C/ REF(MA(C,60),60)-1)*100 COLORGREEN LINETHICK2;
ZQ60:=REF(Q60,1);
WC:WINNER(C)*100 COLORWHITE;
WC10:MA(WC,10)COLORRED,LINETHICK2;
PP1:=PPART(1)*100;
PP10:=PPART(10)*100;
PP11:=PPART(11)*100;
PP20:=PPART(20)*100;
PP21:=PPART(21)*100;
PP30:=PPART(30)*100;
PP31:=PPART(31)*100;
PP60:=PPART(60)*100;
PP61:=PPART(61)*100;
PP100:=PPART(100)*100;
PP101:=PPART(101)*100;
PC10:=(100-PP10);
PC11:=(PP1-PP11);
PC20:=(PP10-PP20);
PC21:=(PP11-PP21);
PC30:=(PP20-PP30);
PC31:=(PP21-PP31);
PC60:=(PP30-PP60);
PC61:=(PP31-PP61);
PC10C:=-(REF(PC10,1)-PC11)*REF(PP10,1)/100;
PC20C:=-(REF(PC20,1)-PC21)*REF(PP20,1)/100;
PC30C:=-(REF(PC30,1)-PC31)*REF(PP30,1)/100;
PC60C:=-(REF(PC60,1)-PC61)*REF(PP60,1)/100;
CT:(PC10C+PC20C+PC30C+PC60C);
LJ10:=-SUM(PC10C,30);
LJ20:=-SUM(PC20C,30);
LJ30:=-SUM(PC30C,30);
LJ60:=-SUM(PC60C,30);
L1:-SUM(CT,30) COLORYELLOW LINETHICK2;
{TM:BARSLAST(
(CROSS(WC10,L1) AND LLV(Q60,10)<1 AND L1<9 )
OR ( CROSS(Q60,WC10) AND WC10<20 )
OR ( CROSS(Q60,WC10) AND L60>58 AND WC10<33 )
);}
TM:=BARSLAST((CROSS(Q60,WC10) AND WC10<30 AND Q60>REF(Q60,1) AND WC10>REF(WC10,1) )
OR (CROSS(Q60,10) AND WC10>REF(WC10,1) AND REF(WC10,1)>REF(WC10,2) AND WC10<60 )
);
{OR (CROSS(Q60,WC10) AND L60>60)}
LW5:=LWINNER(5,C)*100;
LW6:=LWINNER(6,C)*100;
LW1:=LWINNER(1,C)*100;
LW2:=LWINNER(2,C)*100;
LWC5:=LW5-LW1;
LWC6:=LW6-LW2;
CTL5:=LWC6-REF(LWC5,1)/REF(LWC5,1) COLORBLACK LINETHICK1 ;
CT5:=SUM(CTL5,5)COLORMAGENTA LINETHICK2;
LW10:=LWINNER(10,C)*100;
LW11:=LWINNER(11,C)*100;
LWC10:=LW10-LW1;
LWC11:=LW11-LW2;
CTL10:=LWC11-REF(LWC10,1)/REF(LWC10,1) COLORRED LINETHICK1 ;
CT10:=SUM(CTL10,5)COLORRED LINETHICK2;
LT10:=-SUM(PC10C,TM);
LT20:=-SUM(PC20C,TM);
LT30:=-SUM(PC30C,TM);
LT60:=-SUM(PC60C,TM);
LT:IF((LT10+LT20+LT30+LT60)<100,(LT10+LT20+LT30+LT60),100) COLORWHITE LINETHICK2;
TM2:=BARSLAST(CROSS(L60,70) );
LT101:=-SUM(PC10C,TM2);
LT201:=-SUM(PC20C,TM2);
LT301:=-SUM(PC30C,TM2);
LT601:=-SUM(PC60C,TM2);
LT1:IF((LT101+LT201+LT301+LT601)<100,(LT101+LT201+LT301+LT601),100) COLORWHITE LINETHICK2;
60;
20;
10;
2;
0;
-20;
 

通达信筹码出逃指标公式

 

相关文章