在线检测未来函数

飞狐MACD背离二叉指标公式

来源:Internet,编辑:股旁网,2014-11-16

v1:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
v2:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<v2,v2,MA(CLOSE,17)),COLORFF00FF,LINETHICK1;
ma10:=MA(C,10),COLORWHITE,LINETHICK1;
ma30:MA(C,30),COLOR00ff00,LINETHICK2;
stickline(ma10>= REF(ma10,1),ma10,ref(ma10,1),8,1),COLORRED,LINETHICK2;
stickline(ma10< REF(ma10,1),ma10,ref(ma10,1),8,1),COLORff9900,LINETHICK2;
A1:=BARSLAST(REF(CROSS("MACD.DIFF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)> C AND REF("MACD.DIFF"(12,26,9),A1+1)<"MACD.DIFF"(12,26,9)
AND CROSS("MACD.DIFF"(12,26,9),"MACD.DEA"(12,26,9));
DRAWTEXT(B1> 0,L-0.02,'底背离'),COLOR00FFFF;{底背离}
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIFF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIFF"(12,26,9),C1+1)>"MACD.DIFF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),
"MACD.DIFF"(12,26,9));
DRAWTEXT(D1> 0,H+0.16,'顶背离'),COLOR00FF00;{顶背离}
Jm:=CROSS("Macd.DIFF"(12,26,9),"Macd.DEA"(12,26,9));
Jma:=CROSS("Macd.DEA"(12,26,9),"Macd.DIFF"(12,26,9));
Drawtext (Jm,l,'金叉'),colorwhite;{金叉}
Drawtext (Jma,h,'死叉'),coloryellow;{死叉}
JmCOUNT:=COUNT(Jm,BARSLAST("Macd.DEA"(12,26,9)>=0));
Jmtj:1*("Macd.DEA"(12,26,9)<0 and Count(JmCount=2,21)=1),linethick0;
JmaCOUNT:=COUNT(Jma,BARSLAST("Macd.DEA"(12,26,9)>=0));
Jmatj:1*("Macd.DEA"(12,26,9)>0 and Count(JmaCount=2,21)=1),linethick0;
Drawtext (Jmtj,l,'二次金叉'),colorwhite;{macd二次金叉}
Drawtext (Jmatj,h,'二次死叉'),colorwhite;{macd二次死叉}

飞狐MACD背离二叉指标公式

 

相关文章