在线检测未来函数

通达信成交量画矩形指标公式

来源:Internet,编辑:股旁网,2014-11-17

VM:=20;N:=20;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
V5:=MA(V,5);
V8:=MA(V,8);
V13:=MA(V,13);
T5:=ALIGNRIGHT(MOD(CURRBARSCOUNT,5));
T8:=ALIGNRIGHT(MOD(CURRBARSCOUNT,8));
T13:=ALIGNRIGHT(MOD(CURRBARSCOUNT,13));
TA5:=BARSLAST(CROSS(T5=0,0.5));
TA8:=BARSLAST(CROSS(T8=0,0.5));
TA13:=BARSLAST(CROSS(T13=0,0.5));
VH5:=REFX(HHV(V5,TA5+1),BARSNEXT(T5=1));
VH8:=REFX(HHV(V8,TA8+1),BARSNEXT(T8=1));
VH13:=REFX(HHV(V13,TA13+1),BARSNEXT(T13=1));
STICKLINE(T5=1,0,VH5,0,0),COLORYELLOW;
STICKLINE(T5=0,0,VH5,0,0),COLORYELLOW;
STICKLINE(TA5>0 AND TA5<4,VH5,VH5,8,0),COLORYELLOW;
STICKLINE(T8=1,0,VH8,0,0),COLORLIMAGENTA;
STICKLINE(T8=0,0,VH8,0,0),COLORLIMAGENTA;
STICKLINE(TA8>0 AND TA8<7,VH8,VH8,8,0),COLORLIMAGENTA;
STICKLINE(T13=1,0,VH13,0,0),COLORGREEN;
STICKLINE(T13=0,0,VH13,0,0),COLORGREEN;
STICKLINE(TA13>0 AND TA13<12,VH13,VH13,8,0),COLORGREEN;

通达信成交量画矩形指标公式

 

相关文章