在线检测未来函数

同花顺MACD面积指标公式

来源:Internet,编辑:股旁网,2014-11-18

W:=6;
M:=1;
MM:=9*M;
SHORT:=MM*4/3;
LONG:=MM*26/9;
DIFF: (EMA(CLOSE*10,SHORT)-EMA(CLOSE*10,LONG));
DEA:EMA(DIFF,MM),COLOR58FF58;
MACD:2*(DIFF-DEA),COLORFFFF00,LINETHICK0;
AMACD:=ABS(MACD);
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,W,1),COLOR6058FF;
STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,W,0),COLOR6058FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,W,1),COLORFFFF00;
STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,W,0),COLORFFFF00;
红柱面积 := IF (MACD>0,SUM(AMACD,BARSLAST(MACD<0)),0),linethick0,colorred;
绿柱面积 := IF (MACD<0,SUM(AMACD,BARSLAST(MACD>0)),0),linethick0,colorblue;
BV:=SUM(MACD,0);
红转绿:=CROSS(MACD,0);
绿转红:=CROSS(0,MACD);
BC:=BARSLAST(红转绿 OR 绿转红)+1;

同花顺MACD面积指标公式

 

相关文章