在线检测未来函数

飞狐安全级别主图指标公式

来源:Internet,编辑:股旁网,2014-11-20

X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲'),LINETHICK2,colorFF;
DRAWTEXT(CROSS(Y,X),(LOW * 0.95),'安全C级'),LINETHICK2,colorFF;
DRAWTEXT(CROSS(X,Y),(HIGH * 1.015),'◆'),colorFF6699;
DRAWTEXT(CROSS(X,Y),(HIGH * 1.05),'绝对快逃'),LINETHICK2,colorFF6699;
DRAWicon(DB,(HIGH * 1.005),2);
DRAWTEXT(DB,(HIGH * 1.05),'快逃'),LINETHICK2,colorFF6699;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);
VAR6:=((AK + VAR5) / 2);
VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT((CD = 0.6),(LOW * 0.99),'□'),LINETHICK2,colorFFFFFF;
DRAWTEXT((CD = 0.6),(LOW * 0.95),'安全A级'),colorFFFFFF;
DRAWTEXT((AB = 1),(LOW * 0.99),'■'),LINETHICK2,color33CC99;
DRAWTEXT((AB = 1),(LOW * 0.97),'安全 B 级'),color33CC99;

飞狐安全级别主图指标公式

 

相关文章