在线检测未来函数

通达信变色K线加冷暖通道主图指标公式

来源:Internet,编辑:股旁网,2014-11-24

DRAWBAND(MA(CLOSE,10),RGB(80,0,0),MA(CLOSE,20),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK2;
MA120:MA(CLOSE,120),COLORLIMAGENTA,LINETHICK2;
MA250:MA(CLOSE,250),COLORBLUE,LINETHICK2;
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}
C涨停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
涨停:= IF(ST, C>=C涨停5, C>=C涨停10);
跌停:= IF(ST, C<=C跌停5, C<=C跌停10);
盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);
盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}
STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}
大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);
STICKLINE(大阳线,OPEN,CLOSE,2.5,0),COLORMAGENTA;
大阴线:=C<O AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);
STICKLINE(大阴线,OPEN,CLOSE,2.5,0),COLORCYAN;
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;
假阴:=C<O AND C>REF(C,1);
STICKLINE(假阴,O,C,0.5,0),COLORRED;{假阴柱};
假阳:=C>O AND C<REF(C,1);
STICKLINE(假阳,O,C,0.5,0),COLORGREEN;{假阳柱};

通达信变色k线加冷暖通道主图指标公式

 

相关文章