在线检测未来函数

飞狐增幅走势主图指标公式

来源:Internet,编辑:股旁网,2014-11-25

股价1:=(C+H+L)/3;
SS:=REFX(MA(股价1,3),1);
增幅1:=REFX(MA(REFX(MA(SS,3),1),3),1)-REF(REFX(MA(REFX(MA(SS,3),1),3),1),1);
X31:=REFX(MA(股价1,3),1);
J31:=(REFX(MA(股价1,3),1)*3+0.5*股价1-0.5*REF(股价1,1)+增幅1)/3;
Y31:=IF(BARPOS=SYSPARAM(3),J31,X31);
股价2:=Y31;
SS2:=REFX(MA(股价2,3),1);
增幅2:=REFX(MA(REFX(MA(SS2,3),1),3),1)-REF(REFX(MA(REFX(MA(SS2,3),1),3),1),1);
X32:=REFX(MA(股价2,3),1);
J32:=(REFX(MA(股价2,3),1)*3+0.5*股价2-0.5*REF(股价2,1)+增幅2)/3;
Y32:=IF(BARPOS=SYSPARAM(3),J32,X32);
股价3:=Y32;
SS3:=REFX(MA(股价3,3),1);
增幅3:=REFX(MA(REFX(MA(SS3,3),1),3),1)-REF(REFX(MA(REFX(MA(SS3,3),1),3),1),1);
X33:=REFX(MA(股价3,3),1);
J33:=(REFX(MA(股价3,3),1)*3+0.5*股价3-0.5*REF(股价3,1)+增幅3)/3;
Y33:=IF(BARPOS=SYSPARAM(3),J33,X33);
股价4:=Y33;
SS4:=REFX(MA(股价4,3),1);
增幅4:=REFX(MA(REFX(MA(SS4,3),1),3),1)-REF(REFX(MA(REFX(MA(SS4,3),1),3),1),1);
X34:=REFX(MA(股价4,3),1);
J34:=(REFX(MA(股价4,3),1)*3+0.5*股价4-0.5*REF(股价4,1)+增幅4)/3;
Y34:=IF(BARPOS=SYSPARAM(3),J34,X34);
股价5:=Y34;
SS5:=REFX(MA(股价5,3),1);
增幅5:=REFX(MA(REFX(MA(SS5,3),1),3),1)-REF(REFX(MA(REFX(MA(SS5,3),1),3),1),1);
X35:=REFX(MA(股价5,3),1);
J35:=(REFX(MA(股价5,3),1)*3+0.5*股价5-0.5*REF(股价5,1)+增幅5)/3;
Y35:=IF(BARPOS=SYSPARAM(3),J35,X35);
股价6:=Y35;
SS6:=REFX(MA(股价6,3),1);
增幅6:=REFX(MA(REFX(MA(SS6,3),1),3),1)-REF(REFX(MA(REFX(MA(SS6,3),1),3),1),1);
X36:=REFX(MA(股价6,3),1);
J36:=(REFX(MA(股价6,3),1)*3+0.5*股价6-0.5*REF(股价6,1)+增幅6)/3;
Y36:=IF(BARPOS=SYSPARAM(3),J36,X36);
股价7:=Y36;
SS7:=REFX(MA(股价7,3),1);
增幅7:=REFX(MA(REFX(MA(SS7,3),1),3),1)-REF(REFX(MA(REFX(MA(SS7,3),1),3),1),1);
X37:=REFX(MA(股价7,3),1);
J37:=(REFX(MA(股价7,3),1)*3+0.5*股价7-0.5*REF(股价7,1)+增幅7)/3;
Y37:=IF(BARPOS=SYSPARAM(3),J37,X37);
股价8:=Y37;
SS8:=REFX(MA(股价8,3),1);
增幅8:=REFX(MA(REFX(MA(SS8,3),1),3),1)-REF(REFX(MA(REFX(MA(SS8,3),1),3),1),1);
X38:=REFX(MA(股价8,3),1);
J38:=(REFX(MA(股价8,3),1)*3+0.5*股价8-0.5*REF(股价8,1)+增幅8)/3;
Y38:=IF(BARPOS=SYSPARAM(3),J38,X38);
股价9:=Y38;
SS9:=REFX(MA(股价9,3),1);
增幅9:=REFX(MA(REFX(MA(SS9,3),1),3),1)-REF(REFX(MA(REFX(MA(SS9,3),1),3),1),1);
X39:=REFX(MA(股价9,3),1);
J39:=(REFX(MA(股价9,3),1)*3+0.5*股价9-0.5*REF(股价9,1)+增幅9)/3;
Y39:=IF(BARPOS=SYSPARAM(3),J39,X39);
股价10:=Y39;
SS10:=REFX(MA(股价10,3),1);
增幅10:=REFX(MA(REFX(MA(SS10,3),1),3),1)-REF(REFX(MA(REFX(MA(SS10,3),1),3),1),1);
X310:=REFX(MA(股价10,3),1);
J310:=(REFX(MA(股价10,3),1)*3+0.5*股价10-0.5*REF(股价10,1)+增幅10)/3;
Y310:=IF(BARPOS=SYSPARAM(3),J310,X310);
股价11:=Y310;
SS11:=REFX(MA(股价11,3),1);
增幅11:=REFX(MA(REFX(MA(SS11,3),1),3),1)-REF(REFX(MA(REFX(MA(SS11,3),1),3),1),1);
X311:=REFX(MA(股价11,3),1);
J311:=(REFX(MA(股价11,3),1)*3+0.5*股价11-0.5*REF(股价11,1)+增幅11)/3;
Y311:=IF(BARPOS=SYSPARAM(3),J311,X311);
股价12:=Y311;
SS12:=REFX(MA(股价12,3),1);
增幅12:=REFX(MA(REFX(MA(SS12,3),1),3),1)-REF(REFX(MA(REFX(MA(SS12,3),1),3),1),1);
X312:=REFX(MA(股价12,3),1);
J312:=(REFX(MA(股价12,3),1)*3+0.5*股价12-0.5*REF(股价12,1)+增幅12)/3;
Y312:=IF(BARPOS=SYSPARAM(3),J312,X312);
股价13:=Y312;
SS13:=REFX(MA(股价13,3),1);
增幅13:=REFX(MA(REFX(MA(SS13,3),1),3),1)-REF(REFX(MA(REFX(MA(SS13,3),1),3),1),1);
X313:=REFX(MA(股价13,3),1);
J313:=(REFX(MA(股价13,3),1)*3+0.5*股价13-0.5*REF(股价13,1)+增幅13)/3;
Y313:=IF(BARPOS=SYSPARAM(3),J313,X313);
股价14:=Y313;
SS14:=REFX(MA(股价14,3),1);
增幅14:=REFX(MA(REFX(MA(SS14,3),1),3),1)-REF(REFX(MA(REFX(MA(SS14,3),1),3),1),1);
X314:=REFX(MA(股价14,3),1);
J314:=(REFX(MA(股价14,3),1)*3+0.5*股价14-0.5*REF(股价14,1)+增幅14)/3;
Y314:=IF(BARPOS=SYSPARAM(3),J314,X314);
股价15:=Y314;
SS15:=REFX(MA(股价15,3),1);
增幅15:=REFX(MA(REFX(MA(SS15,3),1),3),1)-REF(REFX(MA(REFX(MA(SS15,3),1),3),1),1);
X315:=REFX(MA(股价15,3),1);
J315:=(REFX(MA(股价15,3),1)*3+0.5*股价15-0.5*REF(股价15,1)+增幅15)/3;
Y315:=IF(BARPOS=SYSPARAM(3),J315,X315);
股价16:=Y315;
SS16:=REFX(MA(股价16,3),1);
增幅16:=REFX(MA(REFX(MA(SS16,3),1),3),1)-REF(REFX(MA(REFX(MA(SS16,3),1),3),1),1);
X316:=REFX(MA(股价16,3),1);
J316:=(REFX(MA(股价16,3),1)*3+0.5*股价16-0.5*REF(股价16,1)+增幅16)/3;
Y316:=IF(BARPOS=SYSPARAM(3),J316,X316);
股价17:=Y316;
SS17:=REFX(MA(股价17,3),1);
增幅17:=REFX(MA(REFX(MA(SS17,3),1),3),1)-REF(REFX(MA(REFX(MA(SS17,3),1),3),1),1);
X317:=REFX(MA(股价17,3),1);
J317:=(REFX(MA(股价17,3),1)*3+0.5*股价17-0.5*REF(股价17,1)+增幅17)/3;
Y317:=IF(BARPOS=SYSPARAM(3),J317,X317);
股价18:=Y317;
SS18:=REFX(MA(股价18,3),1);
增幅18:=REFX(MA(REFX(MA(SS18,3),1),3),1)-REF(REFX(MA(REFX(MA(SS18,3),1),3),1),1);
X318:=REFX(MA(股价18,3),1);
J318:=(REFX(MA(股价18,3),1)*3+0.5*股价18-0.5*REF(股价18,1)+增幅18)/3;
Y318:=IF(BARPOS=SYSPARAM(3),J318,X318);
股价19:=Y318;
SS19:=REFX(MA(股价19,3),1);
增幅19:=REFX(MA(REFX(MA(SS19,3),1),3),1)-REF(REFX(MA(REFX(MA(SS19,3),1),3),1),1);
X319:=REFX(MA(股价19,3),1);
J319:=(REFX(MA(股价19,3),1)*3+0.5*股价19-0.5*REF(股价19,1)+增幅19)/3;
Y319:=IF(BARPOS=SYSPARAM(3),J319,X319);
股价20:=Y319;
SS20:=REFX(MA(股价20,3),1);
增幅20:=REFX(MA(REFX(MA(SS20,3),1),3),1)-REF(REFX(MA(REFX(MA(SS20,3),1),3),1),1);
X320:=REFX(MA(股价20,3),1);
J320:=(REFX(MA(股价20,3),1)*3+0.5*股价20-0.5*REF(股价20,1)+增幅20)/3;
Y320:=IF(BARPOS=SYSPARAM(3),J320,X320);
股价21:=Y320;
SS21:=REFX(MA(股价21,3),1);
增幅21:=REFX(MA(REFX(MA(SS21,3),1),3),1)-REF(REFX(MA(REFX(MA(SS21,3),1),3),1),1);
X321:=REFX(MA(股价21,3),1);
J321:=(REFX(MA(股价21,3),1)*3+0.5*股价21-0.5*REF(股价21,1)+增幅21)/3;
Y321:=IF(BARPOS=SYSPARAM(3),J321,X321);
股价22:=Y320;
SS22:=REFX(MA(股价22,3),1);
增幅22:=REFX(MA(REFX(MA(SS22,3),1),3),1)-REF(REFX(MA(REFX(MA(SS22,3),1),3),1),1);
X322:=REFX(MA(股价22,3),1);
J322:=(REFX(MA(股价22,3),1)*3+0.5*股价22-0.5*REF(股价22,1)+增幅22)/3;
Y322:=IF(BARPOS=SYSPARAM(3),J322,X322);
股价23:=Y322;
SS23:=REFX(MA(股价23,3),1);
增幅23:=REFX(MA(REFX(MA(SS23,3),1),3),1)-REF(REFX(MA(REFX(MA(SS23,3),1),3),1),1);
X323:=REFX(MA(股价23,3),1);
J323:=(REFX(MA(股价23,3),1)*3+0.5*股价23-0.5*REF(股价23,1)+增幅23)/3;
Y323:=IF(BARPOS=SYSPARAM(3),J323,X323);
股价24:=Y323;
SS24:=REFX(MA(股价24,3),1);
增幅24:=REFX(MA(REFX(MA(SS24,3),1),3),1)-REF(REFX(MA(REFX(MA(SS24,3),1),3),1),1);
X324:=REFX(MA(股价24,3),1);
J324:=(REFX(MA(股价24,3),1)*3+0.5*股价24-0.5*REF(股价24,1)+增幅24)/3;
Y324:=IF(BARPOS=SYSPARAM(3),J324,X324);
股价25:=Y324;
SS25:=REFX(MA(股价25,3),1);
增幅25:=REFX(MA(REFX(MA(SS25,3),1),3),1)-REF(REFX(MA(REFX(MA(SS25,3),1),3),1),1);
X325:=REFX(MA(股价25,3),1);
J325:=(REFX(MA(股价25,3),1)*3+0.5*股价25-0.5*REF(股价25,1)+增幅25)/3;
Y325:=IF(BARPOS=SYSPARAM(3),J325,X325);
股价26:=Y325;
SS26:=REFX(MA(股价26,3),1);
增幅26:=REFX(MA(REFX(MA(SS26,3),1),3),1)-REF(REFX(MA(REFX(MA(SS26,3),1),3),1),1);
X326:=REFX(MA(股价26,3),1);
J326:=(REFX(MA(股价26,3),1)*3+0.5*股价26-0.5*REF(股价26,1)+增幅26)/3;
Y326:=IF(BARPOS=SYSPARAM(3),J326,X326);
股价27:=Y326;
SS27:=REFX(MA(股价27,3),1);
增幅27:=REFX(MA(REFX(MA(SS27,3),1),3),1)-REF(REFX(MA(REFX(MA(SS27,3),1),3),1),1);
X327:=REFX(MA(股价27,3),1);
J327:=(REFX(MA(股价27,3),1)*3+0.5*股价27-0.5*REF(股价27,1)+增幅27)/3;
Y327:=IF(BARPOS=SYSPARAM(3),J327,X327);
股价28:=Y327;
SS28:=REFX(MA(股价28,3),1);
增幅28:=REFX(MA(REFX(MA(SS28,3),1),3),1)-REF(REFX(MA(REFX(MA(SS28,3),1),3),1),1);
X328:=REFX(MA(股价28,3),1);
J328:=(REFX(MA(股价28,3),1)*3+0.5*股价28-0.5*REF(股价28,1)+增幅28)/3;
Y328:=IF(BARPOS=SYSPARAM(3),J328,X328);
股价29:=Y328;
SS29:=REFX(MA(股价29,3),1);
增幅29:=REFX(MA(REFX(MA(SS29,3),1),3),1)-REF(REFX(MA(REFX(MA(SS29,3),1),3),1),1);
X329:=REFX(MA(股价29,3),1);
J329:=(REFX(MA(股价29,3),1)*3+0.5*股价29-0.5*REF(股价29,1)+增幅29)/3;
Y329:=IF(BARPOS=SYSPARAM(3),J329,X329);
股价30:=Y329;
SS30:=REFX(MA(股价30,3),1);
增幅30:=REFX(MA(REFX(MA(SS30,3),1),3),1)-REF(REFX(MA(REFX(MA(SS30,3),1),3),1),1);
X330:=REFX(MA(股价30,3),1);
J330:=(REFX(MA(股价30,3),1)*3+0.5*股价30-0.5*REF(股价30,1)+增幅30)/3;
Y330:=IF(BARPOS=SYSPARAM(3),J330,X330);
股价31:=Y330;
SS31:=REFX(MA(股价31,3),1);
增幅31:=REFX(MA(REFX(MA(SS31,3),1),3),1)-REF(REFX(MA(REFX(MA(SS31,3),1),3),1),1);
X331:=REFX(MA(股价31,3),1);
J331:=(REFX(MA(股价31,3),1)*3+0.5*股价31-0.5*REF(股价31,1)+增幅31)/3;
Y331:=IF(BARPOS=SYSPARAM(3),J331,X331);
股价32:=Y331;
SS32:=REFX(MA(股价32,3),1);
增幅32:=REFX(MA(REFX(MA(SS32,3),1),3),1)-REF(REFX(MA(REFX(MA(SS32,3),1),3),1),1);
X332:=REFX(MA(股价32,3),1);
J332:=(REFX(MA(股价32,3),1)*3+0.5*股价32-0.5*REF(股价32,1)+增幅32)/3;
Y332:=IF(BARPOS=SYSPARAM(3),J332,X332);
股价33:=Y332;
SS33:=REFX(MA(股价33,3),1);
增幅33:=REFX(MA(REFX(MA(SS33,3),1),3),1)-REF(REFX(MA(REFX(MA(SS33,3),1),3),1),1);
X333:=REFX(MA(股价33,3),1);
J333:=(REFX(MA(股价33,3),1)*3+0.5*股价33-0.5*REF(股价33,1)+增幅33)/3;
Y333:=IF(BARPOS=SYSPARAM(3),J333,X333);
股价34:=Y333;
SS34:=REFX(MA(股价34,3),1);
增幅34:=REFX(MA(REFX(MA(SS34,3),1),3),1)-REF(REFX(MA(REFX(MA(SS34,3),1),3),1),1);
X334:=REFX(MA(股价34,3),1);
J334:=(REFX(MA(股价34,3),1)*3+0.5*股价34-0.5*REF(股价34,1)+增幅34)/3;
Y334:=IF(BARPOS=SYSPARAM(3),J334,X334);
股价35:=Y334;
SS35:=REFX(MA(股价35,3),1);
增幅35:=REFX(MA(REFX(MA(SS35,3),1),3),1)-REF(REFX(MA(REFX(MA(SS35,3),1),3),1),1);
X335:=REFX(MA(股价35,3),1);
J335:=(REFX(MA(股价35,3),1)*3+0.5*股价35-0.5*REF(股价35,1)+增幅35)/3;
Y335:=IF(BARPOS=SYSPARAM(3),J335,X335);
股价36:=Y335;
SS36:=REFX(MA(股价36,3),1);
增幅36:=REFX(MA(REFX(MA(SS36,3),1),3),1)-REF(REFX(MA(REFX(MA(SS36,3),1),3),1),1);
X336:=REFX(MA(股价36,3),1);
J336:=(REFX(MA(股价36,3),1)*3+0.5*股价36-0.5*REF(股价36,1)+增幅36)/3;
Y336:=IF(BARPOS=SYSPARAM(3),J336,X336);
股价37:=Y336;
SS37:=REFX(MA(股价37,3),1);
增幅37:=REFX(MA(REFX(MA(SS37,3),1),3),1)-REF(REFX(MA(REFX(MA(SS37,3),1),3),1),1);
X337:=REFX(MA(股价37,3),1);
J337:=(REFX(MA(股价37,3),1)*3+0.5*股价37-0.5*REF(股价37,1)+增幅37)/3;
Y337:=IF(BARPOS=SYSPARAM(3),J337,X337);
股价38:=Y337;
SS38:=REFX(MA(股价38,3),1);
增幅38:=REFX(MA(REFX(MA(SS38,3),1),3),1)-REF(REFX(MA(REFX(MA(SS38,3),1),3),1),1);
X338:=REFX(MA(股价38,3),1);
J338:=(REFX(MA(股价38,3),1)*3+0.5*股价38-0.5*REF(股价38,1)+增幅38)/3;
Y338:=IF(BARPOS=SYSPARAM(3),J338,X338);
股价39:=Y338;
SS39:=REFX(MA(股价39,3),1);
增幅39:=REFX(MA(REFX(MA(SS39,3),1),3),1)-REF(REFX(MA(REFX(MA(SS39,3),1),3),1),1);
X339:=REFX(MA(股价39,3),1);
J339:=(REFX(MA(股价39,3),1)*3+0.5*股价39-0.5*REF(股价39,1)+增幅39)/3;
Y339:=IF(BARPOS=SYSPARAM(3),J339,X339);
股价40:=Y339;
SS40:=REFX(MA(股价40,3),1);
增幅40:=REFX(MA(REFX(MA(SS40,3),1),3),1)-REF(REFX(MA(REFX(MA(SS40,3),1),3),1),1);
X340:=REFX(MA(股价40,3),1);
J340:=(REFX(MA(股价40,3),1)*3+0.5*股价40-0.5*REF(股价40,1)+增幅40)/3;
Y340:=IF(BARPOS=SYSPARAM(3),J340,X340);
股价41:=Y340;
SS41:=REFX(MA(股价41,3),1);
增幅41:=REFX(MA(REFX(MA(SS41,3),1),3),1)-REF(REFX(MA(REFX(MA(SS41,3),1),3),1),1);
X341:=REFX(MA(股价41,3),1);
J341:=(REFX(MA(股价41,3),1)*3+0.5*股价41-0.5*REF(股价41,1)+增幅41)/3;
Y341:=IF(BARPOS=SYSPARAM(3),J341,X341);
股价42:=Y341;
SS42:=REFX(MA(股价42,3),1);
增幅42:=REFX(MA(REFX(MA(SS42,3),1),3),1)-REF(REFX(MA(REFX(MA(SS42,3),1),3),1),1);
X342:=REFX(MA(股价42,3),1);
J342:=(REFX(MA(股价42,3),1)*3+0.5*股价42-0.5*REF(股价42,1)+增幅42)/3;
Y342:=IF(BARPOS=SYSPARAM(3),J342,X342);
股价43:=Y342;
SS43:=REFX(MA(股价43,3),1);
增幅43:=REFX(MA(REFX(MA(SS43,3),1),3),1)-REF(REFX(MA(REFX(MA(SS43,3),1),3),1),1);
X343:=REFX(MA(股价43,3),1);
J343:=(REFX(MA(股价43,3),1)*3+0.5*股价43-0.5*REF(股价43,1)+增幅43)/3;
Y343:=IF(BARPOS=SYSPARAM(3),J343,X343);
股价44:=Y343;
SS44:=REFX(MA(股价44,3),1);
增幅44:=REFX(MA(REFX(MA(SS44,3),1),3),1)-REF(REFX(MA(REFX(MA(SS44,3),1),3),1),1);
X344:=REFX(MA(股价44,3),1);
J344:=(REFX(MA(股价44,3),1)*3+0.5*股价44-0.5*REF(股价44,1)+增幅44)/3;
Y344:=IF(BARPOS=SYSPARAM(3),J344,X344);
股价45:=Y344;
SS45:=REFX(MA(股价45,3),1);
增幅45:=REFX(MA(REFX(MA(SS45,3),1),3),1)-REF(REFX(MA(REFX(MA(SS45,3),1),3),1),1);
X345:=REFX(MA(股价45,3),1);
J345:=(REFX(MA(股价45,3),1)*3+0.5*股价45-0.5*REF(股价45,1)+增幅45)/3;
Y345:=IF(BARPOS=SYSPARAM(3),J345,X345);
股价46:=Y345;
SS46:=REFX(MA(股价46,3),1);
增幅46:=REFX(MA(REFX(MA(SS46,3),1),3),1)-REF(REFX(MA(REFX(MA(SS46,3),1),3),1),1);
X346:=REFX(MA(股价46,3),1);
J346:=(REFX(MA(股价46,3),1)*3+0.5*股价46-0.5*REF(股价46,1)+增幅46)/3;
Y346:=IF(BARPOS=SYSPARAM(3),J346,X346);
股价47:=Y346;
SS47:=REFX(MA(股价47,3),1);
增幅47:=REFX(MA(REFX(MA(SS47,3),1),3),1)-REF(REFX(MA(REFX(MA(SS47,3),1),3),1),1);
X347:=REFX(MA(股价47,3),1);
J347:=(REFX(MA(股价47,3),1)*3+0.5*股价47-0.5*REF(股价47,1)+增幅47)/3;
Y347:=IF(BARPOS=SYSPARAM(3),J347,X347);
股价48:=Y347;
SS48:=REFX(MA(股价48,3),1);
增幅48:=REFX(MA(REFX(MA(SS48,3),1),3),1)-REF(REFX(MA(REFX(MA(SS48,3),1),3),1),1);
X348:=REFX(MA(股价48,3),1);
J348:=(REFX(MA(股价48,3),1)*3+0.5*股价48-0.5*REF(股价48,1)+增幅48)/3;
Y348:=IF(BARPOS=SYSPARAM(3),J348,X348);
股价49:=Y348;
SS49:=REFX(MA(股价49,3),1);
增幅49:=REFX(MA(REFX(MA(SS49,3),1),3),1)-REF(REFX(MA(REFX(MA(SS49,3),1),3),1),1);
X349:=REFX(MA(股价49,3),1);
J349:=(REFX(MA(股价49,3),1)*3+0.5*股价49-0.5*REF(股价49,1)+增幅49)/3;
Y349:=IF(BARPOS=SYSPARAM(3),J349,X349);
股价50:=Y349;
SS50:=REFX(MA(股价50,3),1);
增幅50:=REFX(MA(REFX(MA(SS50,3),1),3),1)-REF(REFX(MA(REFX(MA(SS50,3),1),3),1),1);
X350:=REFX(MA(股价50,3),1);
J350:=(REFX(MA(股价50,3),1)*3+0.5*股价50-0.5*REF(股价50,1)+增幅50)/3;
Y350:=IF(BARPOS=SYSPARAM(3),J350,X350);
股价51:=Y350;
SS51:=REFX(MA(股价51,3),1);
增幅51:=REFX(MA(REFX(MA(SS51,3),1),3),1)-REF(REFX(MA(REFX(MA(SS51,3),1),3),1),1);
X351:=REFX(MA(股价51,3),1);
J351:=(REFX(MA(股价51,3),1)*3+0.5*股价51-0.5*REF(股价51,1)+增幅51)/3;
Y351:=IF(BARPOS=SYSPARAM(3),J351,X351);
股价52:=Y351;
SS52:=REFX(MA(股价52,3),1);
增幅52:=REFX(MA(REFX(MA(SS52,3),1),3),1)-REF(REFX(MA(REFX(MA(SS52,3),1),3),1),1);
X352:=REFX(MA(股价52,3),1);
J352:=(REFX(MA(股价52,3),1)*3+0.5*股价52-0.5*REF(股价52,1)+增幅52)/3;
Y352:=IF(BARPOS=SYSPARAM(3),J352,X352);
股价53:=Y352;
SS53:=REFX(MA(股价53,3),1);
增幅53:=REFX(MA(REFX(MA(SS53,3),1),3),1)-REF(REFX(MA(REFX(MA(SS53,3),1),3),1),1);
X353:=REFX(MA(股价53,3),1);
J353:=(REFX(MA(股价53,3),1)*3+0.5*股价53-0.5*REF(股价53,1)+增幅53)/3;
Y353:=IF(BARPOS=SYSPARAM(3),J353,X353);
股价54:=Y353;
SS54:=REFX(MA(股价54,3),1);
增幅54:=REFX(MA(REFX(MA(SS54,3),1),3),1)-REF(REFX(MA(REFX(MA(SS54,3),1),3),1),1);
X354:=REFX(MA(股价54,3),1);
J354:=(REFX(MA(股价54,3),1)*3+0.5*股价54-0.5*REF(股价54,1)+增幅54)/3;
Y354:=IF(BARPOS=SYSPARAM(3),J354,X354);
股价55:=Y354;
SS55:=REFX(MA(股价55,3),1);
增幅55:=REFX(MA(REFX(MA(SS55,3),1),3),1)-REF(REFX(MA(REFX(MA(SS55,3),1),3),1),1);
X355:=REFX(MA(股价55,3),1);
J355:=(REFX(MA(股价55,3),1)*3+0.5*股价55-0.5*REF(股价55,1)+增幅55)/3;
Y355:=IF(BARPOS=SYSPARAM(3),J355,X355);
股价56:=Y355;
SS56:=REFX(MA(股价56,3),1);
增幅56:=REFX(MA(REFX(MA(SS56,3),1),3),1)-REF(REFX(MA(REFX(MA(SS56,3),1),3),1),1);
X356:=REFX(MA(股价56,3),1);
J356:=(REFX(MA(股价56,3),1)*3+0.5*股价56-0.5*REF(股价56,1)+增幅56)/3;
Y356:=IF(BARPOS=SYSPARAM(3),J356,X356);
股价57:=Y356;
SS57:=REFX(MA(股价57,3),1);
增幅57:=REFX(MA(REFX(MA(SS57,3),1),3),1)-REF(REFX(MA(REFX(MA(SS57,3),1),3),1),1);
X357:=REFX(MA(股价57,3),1);
J357:=(REFX(MA(股价57,3),1)*3+0.5*股价57-0.5*REF(股价57,1)+增幅57)/3;
Y357:=IF(BARPOS=SYSPARAM(3),J357,X357);
股价58:=Y357;
SS58:=REFX(MA(股价58,3),1);
增幅58:=REFX(MA(REFX(MA(SS58,3),1),3),1)-REF(REFX(MA(REFX(MA(SS58,3),1),3),1),1);
X358:=REFX(MA(股价58,3),1);
J358:=(REFX(MA(股价58,3),1)*3+0.5*股价58-0.5*REF(股价58,1)+增幅58)/3;
Y358:=IF(BARPOS=SYSPARAM(3),J358,X358);
股价59:=Y358;
SS59:=REFX(MA(股价59,3),1);
增幅59:=REFX(MA(REFX(MA(SS59,3),1),3),1)-REF(REFX(MA(REFX(MA(SS59,3),1),3),1),1);
X359:=REFX(MA(股价59,3),1);
J359:=(REFX(MA(股价59,3),1)*3+0.5*股价59-0.5*REF(股价59,1)+增幅59)/3;
Y359:=IF(BARPOS=SYSPARAM(3),J359,X359);
股价60:=Y359;
SS60:=REFX(MA(股价60,3),1);
增幅60:=REFX(MA(REFX(MA(SS60,3),1),3),1)-REF(REFX(MA(REFX(MA(SS60,3),1),3),1),1);
X360:=REFX(MA(股价60,3),1);
J360:=(REFX(MA(股价60,3),1)*3+0.5*股价60-0.5*REF(股价60,1)+增幅60)/3;
Y360:=IF(BARPOS=SYSPARAM(3),J360,X360);
股价61:=Y360;
SS61:=REFX(MA(股价61,3),1);
增幅61:=REFX(MA(REFX(MA(SS61,3),1),3),1)-REF(REFX(MA(REFX(MA(SS61,3),1),3),1),1);
X361:=REFX(MA(股价61,3),1);
J361:=(REFX(MA(股价61,3),1)*3+0.5*股价61-0.5*REF(股价61,1)+增幅61)/3;
Y361:=IF(BARPOS=SYSPARAM(3),J361,X361);
股价62:=Y361;
SS62:=REFX(MA(股价62,3),1);
增幅62:=REFX(MA(REFX(MA(SS62,3),1),3),1)-REF(REFX(MA(REFX(MA(SS62,3),1),3),1),1);
X362:=REFX(MA(股价62,3),1);
J362:=(REFX(MA(股价62,3),1)*3+0.5*股价62-0.5*REF(股价62,1)+增幅62)/3;
Y362:=IF(BARPOS=SYSPARAM(3),J362,X362);
股价63:=Y362;
SS63:=REFX(MA(股价63,3),1);
增幅63:=REFX(MA(REFX(MA(SS63,3),1),3),1)-REF(REFX(MA(REFX(MA(SS63,3),1),3),1),1);
X363:=REFX(MA(股价63,3),1);
J363:=(REFX(MA(股价63,3),1)*3+0.5*股价63-0.5*REF(股价63,1)+增幅63)/3;
Y363:=IF(BARPOS=SYSPARAM(3),J363,X363);
股价64:=Y363;
SS64:=REFX(MA(股价64,3),1);
增幅64:=REFX(MA(REFX(MA(SS64,3),1),3),1)-REF(REFX(MA(REFX(MA(SS64,3),1),3),1),1);
X364:=REFX(MA(股价64,3),1);
J364:=(REFX(MA(股价64,3),1)*3+0.5*股价64-0.5*REF(股价64,1)+增幅64)/3;
Y364:=IF(BARPOS=SYSPARAM(3),J364,X364);
股价65:=Y364;
SS65:=REFX(MA(股价65,3),1);
增幅65:=REFX(MA(REFX(MA(SS65,3),1),3),1)-REF(REFX(MA(REFX(MA(SS65,3),1),3),1),1);
X365:=REFX(MA(股价65,3),1);
J365:=(REFX(MA(股价65,3),1)*3+0.5*股价65-0.5*REF(股价65,1)+增幅65)/3;
Y365:=IF(BARPOS=SYSPARAM(3),J365,X365);
股价66:=Y365;
SS66:=REFX(MA(股价66,3),1);
增幅66:=REFX(MA(REFX(MA(SS66,3),1),3),1)-REF(REFX(MA(REFX(MA(SS66,3),1),3),1),1);
X366:=REFX(MA(股价66,3),1);
J366:=(REFX(MA(股价66,3),1)*3+0.5*股价66-0.5*REF(股价66,1)+增幅66)/3;
Y366:=IF(BARPOS=SYSPARAM(3),J366,X366);
股价67:=Y366;
SS67:=REFX(MA(股价67,3),1);
增幅67:=REFX(MA(REFX(MA(SS67,3),1),3),1)-REF(REFX(MA(REFX(MA(SS67,3),1),3),1),1);
X367:=REFX(MA(股价67,3),1);
J367:=(REFX(MA(股价67,3),1)*3+0.5*股价67-0.5*REF(股价67,1)+增幅67)/3;
Y367:=IF(BARPOS=SYSPARAM(3),J367,X367);
股价68:=Y367;
SS68:=REFX(MA(股价68,3),1);
增幅68:=REFX(MA(REFX(MA(SS68,3),1),3),1)-REF(REFX(MA(REFX(MA(SS68,3),1),3),1),1);
X368:=REFX(MA(股价68,3),1);
J368:=(REFX(MA(股价68,3),1)*3+0.5*股价68-0.5*REF(股价68,1)+增幅68)/3;
Y368:=IF(BARPOS=SYSPARAM(3),J368,X368);
股价69:=Y368;
SS69:=REFX(MA(股价69,3),1);
增幅69:=REFX(MA(REFX(MA(SS69,3),1),3),1)-REF(REFX(MA(REFX(MA(SS69,3),1),3),1),1);
X369:=REFX(MA(股价69,3),1);
J369:=(REFX(MA(股价69,3),1)*3+0.5*股价69-0.5*REF(股价69,1)+增幅69)/3;
Y369:=IF(BARPOS=SYSPARAM(3),J369,X369);
股价70:=Y369;
SS70:=REFX(MA(股价70,3),1);
增幅70:=REFX(MA(REFX(MA(SS70,3),1),3),1)-REF(REFX(MA(REFX(MA(SS70,3),1),3),1),1);
X370:=REFX(MA(股价70,3),1);
J370:=(REFX(MA(股价70,3),1)*3+0.5*股价70-0.5*REF(股价70,1)+增幅70)/3;
Y370:=IF(BARPOS=SYSPARAM(3),J370,X370);
股价71:=Y370;
SS71:=REFX(MA(股价71,3),1);
增幅71:=REFX(MA(REFX(MA(SS71,3),1),3),1)-REF(REFX(MA(REFX(MA(SS71,3),1),3),1),1);
X371:=REFX(MA(股价71,3),1);
J371:=(REFX(MA(股价71,3),1)*3+0.5*股价71-0.5*REF(股价71,1)+增幅71)/3;
Y371:=IF(BARPOS=SYSPARAM(3),J371,X371);
股价72:=Y371;
SS72:=REFX(MA(股价72,3),1);
增幅72:=REFX(MA(REFX(MA(SS72,3),1),3),1)-REF(REFX(MA(REFX(MA(SS72,3),1),3),1),1);
X372:=REFX(MA(股价72,3),1);
J372:=(REFX(MA(股价72,3),1)*3+0.5*股价72-0.5*REF(股价72,1)+增幅72)/3;
Y372:=IF(BARPOS=SYSPARAM(3),J372,X372);
股价73:=Y372;
SS73:=REFX(MA(股价73,3),1);
增幅73:=REFX(MA(REFX(MA(SS73,3),1),3),1)-REF(REFX(MA(REFX(MA(SS73,3),1),3),1),1);
X373:=REFX(MA(股价73,3),1);
J373:=(REFX(MA(股价73,3),1)*3+0.5*股价73-0.5*REF(股价73,1)+增幅73)/3;
Y373:=IF(BARPOS=SYSPARAM(3),J373,X373);
股价74:=Y373;
SS74:=REFX(MA(股价74,3),1);
增幅74:=REFX(MA(REFX(MA(SS74,3),1),3),1)-REF(REFX(MA(REFX(MA(SS74,3),1),3),1),1);
X374:=REFX(MA(股价74,3),1);
J374:=(REFX(MA(股价74,3),1)*3+0.5*股价74-0.5*REF(股价74,1)+增幅74)/3;
Y374:=IF(BARPOS=SYSPARAM(3),J374,X374);
股价75:=Y374;
SS75:=REFX(MA(股价75,3),1);
增幅75:=REFX(MA(REFX(MA(SS75,3),1),3),1)-REF(REFX(MA(REFX(MA(SS75,3),1),3),1),1);
X375:=REFX(MA(股价75,3),1);
J375:=(REFX(MA(股价75,3),1)*3+0.5*股价75-0.5*REF(股价75,1)+增幅75)/3;
Y375:=IF(BARPOS=SYSPARAM(3),J375,X375);
股价76:=Y375;
SS76:=REFX(MA(股价76,3),1);
增幅76:=REFX(MA(REFX(MA(SS76,3),1),3),1)-REF(REFX(MA(REFX(MA(SS76,3),1),3),1),1);
X376:=REFX(MA(股价76,3),1);
J376:=(REFX(MA(股价76,3),1)*3+0.5*股价76-0.5*REF(股价76,1)+增幅76)/3;
Y376:=IF(BARPOS=SYSPARAM(3),J376,X376);
股价77:=Y376;
SS77:=REFX(MA(股价77,3),1);
增幅77:=REFX(MA(REFX(MA(SS77,3),1),3),1)-REF(REFX(MA(REFX(MA(SS77,3),1),3),1),1);
X377:=REFX(MA(股价77,3),1);
J377:=(REFX(MA(股价77,3),1)*3+0.5*股价77-0.5*REF(股价77,1)+增幅77)/3;
Y377:=IF(BARPOS=SYSPARAM(3),J377,X377);
股价78:=Y377;
SS78:=REFX(MA(股价78,3),1);
增幅78:=REFX(MA(REFX(MA(SS78,3),1),3),1)-REF(REFX(MA(REFX(MA(SS78,3),1),3),1),1);
X378:=REFX(MA(股价78,3),1);
J378:=(REFX(MA(股价78,3),1)*3+0.5*股价78-0.5*REF(股价78,1)+增幅78)/3;
Y378:=IF(BARPOS=SYSPARAM(3),J378,X378);
股价79:=Y378;
SS79:=REFX(MA(股价79,3),1);
增幅79:=REFX(MA(REFX(MA(SS79,3),1),3),1)-REF(REFX(MA(REFX(MA(SS79,3),1),3),1),1);
X379:=REFX(MA(股价79,3),1);
J379:=(REFX(MA(股价79,3),1)*3+0.5*股价79-0.5*REF(股价79,1)+增幅79)/3;
Y379:=IF(BARPOS=SYSPARAM(3),J379,X379);
股价80:=Y379;
SS80:=REFX(MA(股价80,3),1);
增幅80:=REFX(MA(REFX(MA(SS80,3),1),3),1)-REF(REFX(MA(REFX(MA(SS80,3),1),3),1),1);
X380:=REFX(MA(股价80,3),1);
J380:=(REFX(MA(股价80,3),1)*3+0.5*股价80-0.5*REF(股价80,1)+增幅80)/3;
Y380:=IF(BARPOS=SYSPARAM(3),J380,X380);
股价81:=Y380;
SS81:=REFX(MA(股价81,3),1);
增幅81:=REFX(MA(REFX(MA(SS81,3),1),3),1)-REF(REFX(MA(REFX(MA(SS81,3),1),3),1),1);
X381:=REFX(MA(股价81,3),1);
J381:=(REFX(MA(股价81,3),1)*3+0.5*股价81-0.5*REF(股价81,1)+增幅81)/3;
Y381:=IF(BARPOS=SYSPARAM(3),J381,X381);
股价82:=Y381;
SS82:=REFX(MA(股价82,3),1);
增幅82:=REFX(MA(REFX(MA(SS82,3),1),3),1)-REF(REFX(MA(REFX(MA(SS82,3),1),3),1),1);
X382:=REFX(MA(股价82,3),1);
J382:=(REFX(MA(股价82,3),1)*3+0.5*股价82-0.5*REF(股价82,1)+增幅82)/3;
Y382:=IF(BARPOS=SYSPARAM(3),J382,X382);
股价83:=Y382;
SS83:=REFX(MA(股价83,3),1);
增幅83:=REFX(MA(REFX(MA(SS83,3),1),3),1)-REF(REFX(MA(REFX(MA(SS83,3),1),3),1),1);
X383:=REFX(MA(股价83,3),1);
J383:=(REFX(MA(股价83,3),1)*3+0.5*股价83-0.5*REF(股价83,1)+增幅83)/3;
Y383:=IF(BARPOS=SYSPARAM(3),J383,X383);
股价84:=Y383;
SS84:=REFX(MA(股价84,3),1);
增幅84:=REFX(MA(REFX(MA(SS84,3),1),3),1)-REF(REFX(MA(REFX(MA(SS84,3),1),3),1),1);
X384:=REFX(MA(股价84,3),1);
J384:=(REFX(MA(股价84,3),1)*3+0.5*股价84-0.5*REF(股价84,1)+增幅84)/3;
Y384:=IF(BARPOS=SYSPARAM(3),J384,X384);
股价85:=Y384;
SS85:=REFX(MA(股价85,3),1);
增幅85:=REFX(MA(REFX(MA(SS85,3),1),3),1)-REF(REFX(MA(REFX(MA(SS85,3),1),3),1),1);
X385:=REFX(MA(股价85,3),1);
J385:=(REFX(MA(股价85,3),1)*3+0.5*股价85-0.5*REF(股价85,1)+增幅85)/3;
Y385:=IF(BARPOS=SYSPARAM(3),J385,X385);
股价86:=Y385;
SS86:=REFX(MA(股价86,3),1);
增幅86:=REFX(MA(REFX(MA(SS86,3),1),3),1)-REF(REFX(MA(REFX(MA(SS86,3),1),3),1),1);
X386:=REFX(MA(股价86,3),1);
J386:=(REFX(MA(股价86,3),1)*3+0.5*股价86-0.5*REF(股价86,1)+增幅86)/3;
Y386:=IF(BARPOS=SYSPARAM(3),J386,X386);
股价87:=Y386;
SS87:=REFX(MA(股价87,3),1);
增幅87:=REFX(MA(REFX(MA(SS87,3),1),3),1)-REF(REFX(MA(REFX(MA(SS87,3),1),3),1),1);
X387:=REFX(MA(股价87,3),1);
J387:=(REFX(MA(股价87,3),1)*3+0.5*股价87-0.5*REF(股价87,1)+增幅87)/3;
Y387:=IF(BARPOS=SYSPARAM(3),J387,X387);
股价88:=Y387;
SS88:=REFX(MA(股价88,3),1);
增幅88:=REFX(MA(REFX(MA(SS88,3),1),3),1)-REF(REFX(MA(REFX(MA(SS88,3),1),3),1),1);
X388:=REFX(MA(股价88,3),1);
J388:=(REFX(MA(股价88,3),1)*3+0.5*股价88-0.5*REF(股价88,1)+增幅88)/3;
Y388:=IF(BARPOS=SYSPARAM(3),J388,X388);
股价89:=Y388;
SS89:=REFX(MA(股价89,3),1);
增幅89:=REFX(MA(REFX(MA(SS89,3),1),3),1)-REF(REFX(MA(REFX(MA(SS89,3),1),3),1),1);
X389:=REFX(MA(股价89,3),1);
J389:=(REFX(MA(股价89,3),1)*3+0.5*股价89-0.5*REF(股价89,1)+增幅89)/3;
Y389:=IF(BARPOS=SYSPARAM(3),J389,X389);
股价90:=Y389;
SS90:=REFX(MA(股价90,3),1);
增幅90:=REFX(MA(REFX(MA(SS90,3),1),3),1)-REF(REFX(MA(REFX(MA(SS90,3),1),3),1),1);
X390:=REFX(MA(股价90,3),1);
J390:=(REFX(MA(股价90,3),1)*3+0.5*股价90-0.5*REF(股价90,1)+增幅90)/3;
Y390:=IF(BARPOS=SYSPARAM(3),J390,X390);
股价91:=Y390;
SS91:=REFX(MA(股价91,3),1);
增幅91:=REFX(MA(REFX(MA(SS91,3),1),3),1)-REF(REFX(MA(REFX(MA(SS91,3),1),3),1),1);
X391:=REFX(MA(股价91,3),1);
J391:=(REFX(MA(股价91,3),1)*3+0.5*股价91-0.5*REF(股价91,1)+增幅91)/3;
Y391:=IF(BARPOS=SYSPARAM(3),J391,X391);
股价92:=Y391;
SS92:=REFX(MA(股价92,3),1);
增幅92:=REFX(MA(REFX(MA(SS92,3),1),3),1)-REF(REFX(MA(REFX(MA(SS92,3),1),3),1),1);
X392:=REFX(MA(股价92,3),1);
J392:=(REFX(MA(股价92,3),1)*3+0.5*股价92-0.5*REF(股价92,1)+增幅92)/3;
Y392:=IF(BARPOS=SYSPARAM(3),J392,X392);
股价93:=Y392;
SS93:=REFX(MA(股价93,3),1);
增幅93:=REFX(MA(REFX(MA(SS93,3),1),3),1)-REF(REFX(MA(REFX(MA(SS93,3),1),3),1),1);
X393:=REFX(MA(股价93,3),1);
J393:=(REFX(MA(股价93,3),1)*3+0.5*股价93-0.5*REF(股价93,1)+增幅93)/3;
Y393:=IF(BARPOS=SYSPARAM(3),J393,X393);
股价94:=Y393;
SS94:=REFX(MA(股价94,3),1);
增幅94:=REFX(MA(REFX(MA(SS94,3),1),3),1)-REF(REFX(MA(REFX(MA(SS94,3),1),3),1),1);
X394:=REFX(MA(股价94,3),1);
J394:=(REFX(MA(股价94,3),1)*3+0.5*股价94-0.5*REF(股价94,1)+增幅94)/3;
Y394:=IF(BARPOS=SYSPARAM(3),J394,X394);
股价95:=Y394;
SS95:=REFX(MA(股价95,3),1);
增幅95:=REFX(MA(REFX(MA(SS95,3),1),3),1)-REF(REFX(MA(REFX(MA(SS95,3),1),3),1),1);
X395:=REFX(MA(股价95,3),1);
J395:=(REFX(MA(股价95,3),1)*3+0.5*股价95-0.5*REF(股价95,1)+增幅95)/3;
Y395:=IF(BARPOS=SYSPARAM(3),J395,X395);
股价96:=Y395;
SS96:=REFX(MA(股价96,3),1);
增幅96:=REFX(MA(REFX(MA(SS96,3),1),3),1)-REF(REFX(MA(REFX(MA(SS96,3),1),3),1),1);
X396:=REFX(MA(股价96,3),1);
J396:=(REFX(MA(股价96,3),1)*3+0.5*股价96-0.5*REF(股价96,1)+增幅96)/3;
Y396:IF(BARPOS=SYSPARAM(3),J396,X396),COLORRED;
高险区3:Y396*1.15,COLORMAGENTA;
高险区2:Y396*1.125,COLORCYAN;
高险区1:Y396*1.1,COLORYELLOW;
运动趋势:PARTLINE(Y396<REF(Y396,1),Y396),COLORGREEN;
良机区1:Y396*0.9,COLORYELLOW;
良机区2:Y396*0.875,COLORCYAN;
良机区3:Y396*0.85,COLORMAGENTA;
WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
WSR2:=CROSS(WSR1,5);
WSR3:=CROSS(8,WSR1);
WSR4:=CROSS(WSR1,-5);
WSR5:=CROSS(WSR1,-8);
WSR6:=WSR3;
WSR7:=WSR4 OR WSR5;
WSR8:=WSR7 AND FILTER(WSR7,5) AND OPEN<Y396;
DRAWICON(WSR8,L*0.993,4);
WSR9:=WSR6 AND FILTER(WSR6,5) AND OPEN>Y396;
DRAWICON(WSR9,H*1.013,5);
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
W1:=C>REF(C,1) AND MACD>0 AND MACD<REF(MACD,1) AND V<REF(V,1);
W2:=C>REF(C,1) AND MACD<0 AND MACD<REF(MACD,1) AND V<REF(V,1);
XG:=W1 OR W2;
VAR1:=AMOUNT/VOL/7;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,10)/VAR1/7;
VAR4:=DMA(VAR2,VOL/VAR3);
VAR5:=(CLOSE-VAR4)/VAR4*100;
XG1:=CROSS(VAR5,MA(VAR5,2)) AND VAR5<0 AND C<(HHV(H,5)*0.88) AND REF(O>C,1) AND REF(O>C,2);
XG3:=XG AND XG1;
WSR10:=XG3;
DRAWICON(WSR10 AND FILTER(WSR10,10),L*0.977,8);
WSR11:=HIGH>高险区2;
DRAWICON(WSR11 AND FILTER(WSR11,5),HIGH*1.022,9);
WSR16:=(INDEXC-MA(INDEXC,3))/MA(INDEXC,3);
WSR17:=(INDEXC-MA(INDEXC,8))/MA(INDEXC,8);
WSR18:=(INDEXC-MA(INDEXC,18))/MA(INDEXC,18);
WSR19:=(WSR16 + WSR17 + WSR18)/3;
WSR20:=(C-MA(C,3))/MA(C,3);
WSR21:=(C-MA(C,8))/MA(C,8);
WSR22:=(C-MA(C,18))/MA(C,18);
WSR23:=(WSR20 + WSR21 + WSR22)/3;
WSR24:=(WSR19>REF(WSR19,1) AND CROSS(WSR23,WSR19))*50;
WSR25:=(INDEXC-MA(INDEXC,6))/MA(INDEXC,6);
WSR26:=(INDEXC-MA(INDEXC,12))/MA(INDEXC,12);
WSR27:=(INDEXC-MA(INDEXC,24))/MA(INDEXC,24);
WSR28:=(WSR25 + WSR26 + WSR27)/3;
WSR29:=(C-MA(C,6))/MA(C,6);
WSR30:=(C-MA(C,12))/MA(C,12);
WSR31:=(C-MA(C,24))/MA(C,24);
WSR32:=(WSR29 + WSR30 + WSR31)/3;
WSR33:=(WSR28>REF(WSR28,1) AND CROSS(WSR32,WSR28))*20;
WSR34:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13);
WSR35:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR36:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR37:=(WSR34 + WSR35 + WSR36)/3;
WSR38:=(C-MA(C,13))/MA(C,13);
WSR39:=(C-MA(C,34))/MA(C,34);
WSR40:=(C-MA(C,55))/MA(C,55);
WSR41:=(WSR38 + WSR39 + WSR40)/3;
WSR42:=(WSR37>REF(WSR37,1) AND CROSS(WSR41,WSR37));
WSR43:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13);
WSR44:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR45:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR46:=(WSR43 + WSR44 + WSR45)/3;
WSR47:=(C-MA(C,30))/MA(C,30);
WSR48:=(C-MA(C,60))/MA(C,60);
WSR49:=(C-MA(C,90))/MA(C,90);
WSR50:=(WSR47 + WSR48 + WSR49)/3;
WSR51:=(WSR46>REF(WSR46,1) AND CROSS(WSR50,WSR46));
WSR52:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR53:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR54:=(INDEXC-MA(INDEXC,89))/MA(INDEXC,89);
WSR55:=(WSR52 + WSR53 + WSR54)/3;
WSR56:=(C-MA(C,60))/MA(C,60);
WSR57:=(C-MA(C,120))/MA(C,120);
WSR58:=(C-MA(C,220))/MA(C,220);
WSR59:=(WSR56 + WSR57 + WSR58)/3;
WSR60:=(WSR59>REF(WSR59,1) AND CROSS(WSR59,WSR55));
WSR61:=WSR24 OR WSR33 OR WSR42 OR WSR51 OR WSR60;
DRAWICON(WSR61 AND FILTER(WSR61,5) AND HIGH<Y396, LOW*0.965,12);

飞狐增幅走势主图指标公式

 

相关文章