在线检测未来函数

通达信荣盛轨道主图指标公式

来源:Internet,编辑:股旁网,2014-11-26

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
次上轨:(1+7/100)*DD,DOTLINE,COLORGREEN;
次下轨:(1-7/100)*DD,DOTLINE,COLORGREEN;
中轨:(次上轨+次下轨)/2,DOTLINE,COLORGREEN;
上轨:(1+14/100)*DD,DOTLINE,COLOR8000FF;
下轨:(1-14/100)*DD,DOTLINE,COLORFF0000;
ZD:=(C-REF(C,1))/REF(C,1)*100;
HDZ,:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));
趋势强度:=IF(C>次上轨,IF(C>上轨,4,3),IF(C>次下轨 AND C<次上轨,2,IF(C<下轨,0,1)));
STICKLINE(趋势强度=0,H,L,0,1),COLORBLUE;
STICKLINE(趋势强度=1,H,L,0,1),COLORGREEN;
STICKLINE(趋势强度=2,H,L,0,1),COLORGRAY;
STICKLINE(趋势强度=3,H,L,0,1),COLORYELLOW;
STICKLINE(趋势强度=4,H,L,0,1),COLORMAGENTA;
STICKLINE(趋势强度=0,C,O,1,0),COLORBLUE;
STICKLINE(趋势强度=1,C,O,1,0),COLORGREEN;
STICKLINE(趋势强度=2,C,O,1,0),COLORGRAY;
STICKLINE(趋势强度=3,C,O,1,0),COLORYELLOW;
STICKLINE(趋势强度=4,C,O,1,0),COLORMAGENTA;

通达信荣盛轨道主图指标公式

 

相关文章