在线检测未来函数

通达信MACD金线王指标公式

来源:Internet,编辑:股旁网,2014-11-28

DIF:EMA(CLOSE,12)-EMA(CLOSE,25);
DEA:EMA(DIF,5);
MACD:=(DIF-DEA)*2;
STICKLINE(MACD>0,MACD,0,3,1),COLORRED;
STICKLINE(MACD<0,MACD,0,3,1),COLORCYAN;
MACD120:REF(MACD/2,BARSLAST(MACD=HHV(MACD,120))),COLORRED,LINETHICK2;
MACD250:REF(MACD/2,BARSLAST(MACD=HHV(MACD,250))),COLORWHITE,LINETHICK2;
XG:=NOT(REF(MACD120,1)=MACD120);
STICKLINE(XG,0,MACD,2,0),COLORYELLOW;
STICKLINE(MACD>=MACD250,MACD250,MACD,2,0),COLORMAGENTA;
行情:=NOT(REF(MACD120,1)=REF(MACD250,1)) AND MACD120=MACD250;
DRAWTEXT(XG,0,'↖金柱'),COLORYELLOW;
DRAWTEXT(大行情,0,'↖大牛启动'),COLORYELLOW;

通达信MACD金线王指标公式

 

相关文章