在线检测未来函数

通达信中长线主图指标公式

来源:Internet,编辑:股旁网,2014-12-02

M:=20;
N:=2;
MID :=MA(CLOSE,M);
UPPER:= MID + N*STD(CLOSE,M);
LOWER:= MID - N*STD(CLOSE,M);
WX:=MA(C,0);
{M3:MA(CLOSE,3);
M5:MA(CLOSE,5);}
M25:EMA(CLOSE,25),COLOR000000,LINETHICK1;
M99:EMA(CLOSE,99),COLOR0000FF,LINETHICK2;
EM13:EMA(CLOSE,13),COLOR8080FF;
{M12:MA(CLOSE,120);};
买线:EMA(C,2);
{卖线:EMA(SLOPE(C,21)*20+C,42),CROSSDOT,COLORWHITE;
DRAWICON(CROSS(买线,卖线),L,5);
DRAWICON(CROSS(卖线,买线),H,6);}
{M120:MA(CLOSE,120);}
{MACYC:MA(CYC2.CYC5,60);};
{工作线:EMA(C,25),COLOR00FF00,LINETHICK2;
九号线:EMA(CLOSE,99),COLORRED,LINETHICK2;}
EXP17:=EMA(CLOSE,17),COLORWHITE,LINETHICK2;
M60:MA(CLOSE,60),COLORMAGENTA;
{REF(C#DAY,1);};
{SC:=100*(CLOSE-MA(CLOSE,60));
快线:=((EMA(CLOSE,21) - EMA(CLOSE,34)));
慢线:=EMA(快线,6);
T1:=CROSS(EMA(SC,7),EMA(SC,18)) AND CROSS(快线,慢线);
STICKLINE(T1,HHV(H,60),LLV(L,60),0,0),COLORWHITE;};
{DRAWKLINE(H,O,L,C),COLORWHITE;};
NCLOSE := (3*C+OPEN+HIGH+LOW)/6;
MA5D := MA(NCLOSE,8);
D := CLOSE<MA5D;
E := CLOSE>MA5D;
R1 := REF(D,1) AND REF(D,2) AND (E) AND CLOSE>REF(H,1);
DRAWICON (R1,LOW-(HIGH-LOW)/4,4),COLORRED;
R2 := REF(E,1) AND REF(E,2) AND (D) AND CLOSE<REF(L,1);
DRAWICON (R2,H+(HIGH-LOW)/4,5);
止赢:LLV(L,120)+(HHV(H,120)-LLV(L,120))*0.8,COLORWHITE,LINETHICK1;
止损:LLV(L,120)+(HHV(H,120)-LLV(L,120))*0.2,COLORGREEN,LINETHICK1;

通达信中长线主图指标公式

 

相关文章