在线检测未来函数

大智慧趋势监控指标公式

来源:Internet,编辑:股旁网,2014-12-04

NN:=-1;
{构造牛熊带};
N1:=6+NN; N2:=34+6*NN; N3:=89+34*NN;
E5:=(EMA(CLOSE,4)+EMA(CLOSE,5))/2;A5:=(MA(CLOSE,4)+MA(CLOSE,5))/2;
E9:=EMA(CLOSE,N1);A9:=MA(CLOSE,N1);E36:=EMA(CLOSE,N2);A36:=MA(CLOSE,N2);
E153:=EMA(CLOSE,N3);A153:=MA(CLOSE,N3);
ZQ:=DATATYPE;
MX:=IF(ZQ=13,A5,IF(ZQ=10,A9,IF(ZQ=9,A36,A153)));
EX:=IF(ZQ=13,E5,IF(ZQ=10,E9,IF(ZQ=9,E36,E153)));
牛市:IF((EX-MX)>0,80,0),COLORRED,LINETHICK2;
熊市:IF((EX-MX)<0,80,0),COLORGREEN,LINETHICK2;
{人气监控}
MTM:=CLOSE-REF(CLOSE,6);
MAMTM:=MA(MTM,13);
{人气:=(MTM-MAMTM)*10;}
人气:IF((MTM-MAMTM)*10>2,140,0),COLORWHITE,LINETHICK2;
{趋向监控}
N:=14;M:=5;
TR1:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),
ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:=DMP*100/TR1;
MDI:=DMM*100/TR1;
ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1);
DX:=(ADX*14-REF(ADX,1)*13)*IF(PDI>MDI,1,-1);
EMADX:=EMA(DX,M);
趋向:IF((DX-EMADX)>4,160,0),COLORMAGENTA,LINETHICK3;
{强势监控}
BBI1:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
BBI2:=(MA(INDEXC,3)+MA(INDEXC,6)+MA(INDEXC,12)+MA(INDEXC,24))/4;
个股:=(C-BBI1)/BBI1*100;
大盘:=(INDEXC-BBI2)/BBI2*100;
强势:IF((个股-大盘>1),180,0),COLORRED,LINETHICK3;
{筹码监控}
HL10:=WINNER(C/1.1)*100;
{筹码选:HL10-REF(HL10,1)>15,COLORYELLOW;}
突破:IF((HL10-REF(HL10,1))>15,220,0),COLORYELLOW,LINETHICK4;
庄进:=IF((REF(C,1)<MA(C,72) AND C>MA(C,72)),30,0) AND WINNER(C)*100>50 AND CROSS(C,COST(50))AND (DX-EMADX)>4;
STICKLINE(庄进,130,0,4,0),COLOR770077;
STICKLINE(庄进,130,0,3,0),COLOR990099;
STICKLINE(庄进,130,0,2,0),COLORBB00BB;
STICKLINE(庄进,130,0,1,0),COLORDD00DD;
STICKLINE(庄进,130,0,0.3,0),COLORFF00FF;
DRAWTEXT(庄进,90,'庄进'),COLORYELLOW;

大智慧趋势监控指标公式

 

相关文章