在线检测未来函数

通达信KDJ+宝塔顶底指标公式

来源:Internet,编辑:股旁网,2014-12-04

{白色柱子大底}
大底1:STICKLINE(CROSS(((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100),-24),80,0,2,0),COLORYELLOW;
AAAA:CROSS(((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100),-24);
DRAWTEXT(AAAA,75,'大底');
50;
N:=9;
KN:=3;
DN:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,KN,1),COLOR0099FF;
D:SMA(K,DN,1),COLORYELLOW;
J:3*K-2*D,COLORYELLOW;
IF(J>=REF(J,1),J,DRAWNULL),COLORRED;
IF(J<REF(J,1),J,DRAWNULL),COLORAA8800;
IF(K>=REF(K,1),K,DRAWNULL),COLOR0099FF;
IF(K<REF(K,1),K,DRAWNULL),COLORAA8800;
IF(D>=REF(D,1),D,DRAWNULL),COLORYELLOW;
IF(D<REF(D,1),D,DRAWNULL),COLORAA8800;
DRAWBAND(K,RGB(220,0,220),D,RGB(180,140,140));
DIF1:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA1:=EMA(DIF1,6);
二阳包阴:=CROSS(C<REF(C,1),1) AND C>O AND CROSS(C,REF(O,1));
阳包阴:=CROSS(C,REF(O,1)) AND REF(O>C,1);
小包阳:=EVERY(C>O,2) AND C>REF(C,1) AND O<REF(O,1);
XG:二阳包阴 OR 阳包阴 OR 小包阳;
买进: IF(XG,20,0),LINETHICK2,COLORWHITE;
STICKLINE(J>95,95,J,2,0),COLORGREEN;
STICKLINE(J<5,5,J,2,0),COLORRED;
底:= 5,COLORCYAN, COLOR77AA1A;
小顶: 95,COLORCYAN,COLOR22A6E6;
抄底:IF(J<=0,J,0),COLORRED,LINETHICK2;
风险:IF(J>=100,J,0),COLORGREEN,LINETHICK1;
警惕:IF(D>=80,D,0),COLORYELLOW,LINETHICK2;
顶:100,COLOR22A6E6,LINETHICK1;
VAR1:=3;
VAR2:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
股价准备启动:IF(CROSS(VAR2,VAR1),100,0),COLORRED;
神秘买点:IF((VAR2 <= 3),25,0),COLORFF00FF;
机构建增补仓:IF((VAR2 < 5),45,0),COLOR00FF00;
OBV:=J;
P8:=12;
A1:=REF(OBV,P8)=HHV(OBV,2*P8+1);
B1:=FILTER(A1,P8);
C1:=BACKSET(B1,P8+1);
D1:=FILTER(C1,P8);{高点1}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
DRAWLINE(D1,OBV,S11,OBV,1),COLORCYAN,DOTLINE;
A2:=REF(OBV,P8)=LLV(OBV,2*P8+1);
B2:=FILTER(A2,P8);
C2:=BACKSET(B2,P8+1);
D2:=FILTER(C2,P8);{低点1}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
DRAWLINE(D2,OBV,U11,OBV,1),COLORCYAN,DOTLINE;
Q1:=INTPART(3*8/18);
A12:=REF(OBV,Q1)=HHV(OBV,2*Q1+1);
B12:=FILTER(A12,Q1);
C12:=BACKSET(B12,Q1+1);
D12:=FILTER(C12,Q1);{高点2}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
DRAWLINE(S11,OBV,S112,OBV,1),COLORCYAN,DOTLINE;
Q2:=INTPART(3*8/18);
A22:=REF(OBV,Q2)=LLV(OBV,2*Q2+1);
B22:=FILTER(A22,Q2);
C22:=BACKSET(B22,Q2+1);
D22:=FILTER(C22,Q2);{低点2}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
DRAWLINE(U11,OBV,U112,OBV,1),COLORCYAN,DOTLINE;
DRAWICON(D2,OBV,26);
DRAWICON(D1,OBV,27);
{顶部明确}
VAR177:=REF(CLOSE,1);
VAR277:=((SMA(MAX((CLOSE - VAR177),0),7,1) / SMA(ABS((CLOSE - VAR177)),7,1)) * 100);
VAR377:=CROSS(79,VAR277);
VAR477:=FILTER(VAR377,4);
VAR577:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
VAR677:=SMA(VAR577,5,1);
VAR777:=SMA(VAR677,8,1);
VAR877:=(CROSS(VAR677,VAR777) AND (VAR777 < 5));
VAR977:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND VAR877);
VAR1077:=IF((CLOSE > 1000),VAR877,VAR977);
VAR1177:=VAR1077;
DRAWTEXT(VAR477,98,'☆顶'),COLORMAGENTA;
{宝塔顶底}
VAR22:=LLV(LOW,10);
VAR32:=HHV(HIGH,25);
阶段卖出:= 3.2,COLORCYAN;
清仓卖出:= 3.5;
动力线:= EMA((CLOSE-VAR22)/(VAR32-VAR22)*4,4)*30;
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),2 ,1),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),2 ,1),COLORGREEN;
底部介入:=0.2,COLORGREEN;
重点关注:=0.5, COLORYELLOW;
DRAWICON( FILTER(CROSS(动力线,重点关注),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(清仓卖出,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,底部介入),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(阶段卖出,动力线),20),动力线+0.02,2);
强弱分界线:=1.75,POINTDOT,COLORDDDDDD;
{上证顶部}
SD1:=100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34));
MA1:=SMA(SD1,3,1);
SD2:=100*(INDEXC-LLV(INDEXL,64))/(HHV(INDEXH,64)-LLV(INDEXL,64));
MA2:=SMA(SD2,3,1);
VAR18:=(2*INDEXC+INDEXH+INDEXL+INDEXO)/5;
VAR28:=EMA(EMA(EMA(VAR18,4),4),4);
SJ:=(VAR28-REF(VAR28,1))/REF(VAR28,1)*100;
SD:=MA(SJ,2);
SK:=MA(SJ,1);
卖出:=-(CROSS(90,MA1) OR CROSS(90,MA2) AND CROSS(EMA(CLOSE,3),C)),COLORYELLOW;
{上证底部}
买进8:=CROSS(MA2,19) AND SK>SD AND CROSS(EMA(C,3),EMA(C,8)),COLORRED;
DRAWTEXT(卖出,80,'顶部'),COLORYELLOW;
DRAWTEXT(买进8,30,'底部'),COLORYELLOW;

通达信KDJ+宝塔顶底指标公式

 

相关文章