在线检测未来函数

通达信实用性很强的指标公式

来源:Internet,编辑:股旁网,2014-12-06

{用法:当风云线在强弱线下边是底位。风云线上穿达到30即可买入。风云线在强弱线上方可以说是强势也就是说高位,注意风险!}

VAR3:=1;
BIAS2 := (CLOSE-MA(CLOSE,15))/MA(CLOSE,15)*100;
VAR1:=BIAS2*VAR3;
VAR2:=IF(CLOSE-SMA(CLOSE,75,1)<0,CAPITAL/VOL,0);
VAR4:=WINNER(CLOSE)*100*VAR3;
BIAS3 := (CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
N:=50;
M:=1;
P:=1;
VAR1A:=WINNER(CLOSE)*VAR3;
VAR2A:=VOL/CAPITAL*VAR3;
VAR3A:=MA(VAR1A/VAR2A,1)*VAR3;
C1:=IF(VAR1A>50/100 AND CLOSE>OPEN AND VAR2A<1/100,VAR3A,0);
VAR1B:=COST(5);
VAR2B:=COST(95);
VAR3B:=(1-VAR1B/VAR2B)*100;
VAR4B:=IF(VAR3B>REF(VAR3B,1),VAR3B,0);
C2:=IF(VOL/CAPITAL*100<1,VAR4B,0);
B1:=IF(C1>95,95,C1);
B2:=IF(C2>90,90,C2);
D1:=IF(VAR2>150 AND VAR4<5,CAPITAL/VOL/10,0)*VAR3;
V1:=HHV(H,5);
吃货时机: IF(D1<25,D1,25)* IF(BIAS3<-10,1,0)*IF(H*1.03>=V1,0,1);
风云:VAR4,LINETHICK2;
庄家买卖:IF(VAR4>4,B2,0);
{强弱:30 POINTDOT;}
FX:=100-ABS(VAR1);
风险:FX,LINETHICK2;
MID :=MA(CLOSE,26);
UPPER:= MID + 2*STD(CLOSE,26);
LOWER:= MID - 2*STD(CLOSE,26);
MID2:=EMA(MID,10)*VAR3;
MA1:=MA(LOW,3);
MA2:=MA(HIGH,3);
M1:=COST(3);
M2:=COST(98);
M3:=COST(100);
M4:=COST(99);
M5:=COST(2);
M6:=COST(3);
RSV:=(CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV1,3,1);
D1A:=SMA(K1,3,1);
J1:=3*K1-2*D1A;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=REF(RSI1,1);
MM1:=(CROSS(MA1,M1) OR CROSS(MA1,M5) OR CROSS(MA1,M6)) AND J>19 AND J1<80 AND K>D AND RSI1>RSI3;
MM2:=(CROSS(M2,MA2) OR CROSS(M3,MA2) OR CROSS(M4,MA2)) AND J>70 AND J1>81;
MM3:=IF(MM1,100,50);
MM4:=IF(MM2,0,MM3)*VAR3;
MM:=MM4;
买卖线:MM,LINETHICK2;
{LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
加速方向:RSI2 COLORRED;}
庄控:B1;

通达信实用性很强的指标公式

 

相关文章