在线检测未来函数

通达信主买主卖能量指标公式

来源:Internet,编辑:股旁网,2014-12-09

量:VOL,NODRAW,COLORWHITE;
STICKLINE(量<=HHV(量,144)*0.2,0,量,10,0),COLORGRAY;
STICKLINE(量>=HHV(量,144),0,量,10,0),COLORGREEN;
STICKLINE(量>HHV(量,144)*0.2 AND 量<HHV(量,144) AND C>REF(C,1) AND (量/REF(量,1)<1.5 OR 量/REF(量,1)>3.6),0,量,10,1),COLORRED;
STICKLINE(量>HHV(量,144)*0.2 AND 量<HHV(量,144) AND C<=REF(C,1) AND (量/REF(量,1)<1.5 OR 量/REF(量,1)>3.6),0,量,10,1),COLORCYAN;
STICKLINE(量<=HHV(量,144)*0.2 AND 量/REF(量,1)>=1.5 AND 量/REF(量,1)<=3.6,REF(量,1),量,10,0),COLORYELLOW;
STICKLINE(量>HHV(量,144)*0.2 AND 量<HHV(量,144) AND 量/REF(量,1)>=1.5 AND 量/REF(量,1)<=3.6,0,量,10,0),COLORYELLOW;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),NODRAW,COLORRED;
主卖:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),NODRAW,COLORGREEN;
净流:主买+主卖,NODRAW,COLORCYAN;
STICKLINE(C>REF(C,1),0,主买,8,0),COLORRED;
STICKLINE(C<=REF(C,1),0,主买,8,0),COLORGREEN;
量比:VOL/REF(VOL,1),NODRAW,COLORCYAN;
主买占比:主买/量*100,NODRAW,COLOR336699;
E5:EMA(量,5),COLORCYAN;
E21:EMA(量,21),COLORGREEN;
E144:EMA(量,144),COLORMAGENTA;

通达信主买主卖能量指标公式

 

相关文章