在线检测未来函数

通达信精准买卖提示指标公式

来源:Internet,编辑:股旁网,2014-12-08

VAR1:=(HHV(HIGH,9)-LLV(LOW,9));
VAR2:=(HHV(HIGH,9)-CLOSE);
VAR3:=(CLOSE-LLV(LOW,9));
VAR4:=VAR2/VAR1*100-70 ;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*C+H+L)/4;
VAR7:=SMA((VAR3/VAR1*100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:= IF(VAR9>100,VAR9-100,0);
VARA:=HHV(HIGH,34);
防线B:=EMA((VAR6-VAR8)/(VARA-VAR8)*100,8),COLORWHITE;
B1:=EMA(防线B,5);
{STICKLINE(防线B>0 AND 防线B-B1>=0,79,80,6,0),COLORFF8000;
STICKLINE(防线B>0 AND 防线B-B1<0,79,80,6,1),COLORRED;}
{STICKLINE(防线B>0 AND 防线B-B1>=0,19,20,6,0),COLOR00FF00;}
STICKLINE(防线B>0 AND 防线B-B1>=0,19,20,3,0),COLORYELLOW;
{STICKLINE(防线B>0 AND 防线B-B1<0,49,50,6,1),COLORRED;}
STICKLINE(防线B>0 AND 防线B-B1<0,19,20,3,1),COLORRED;
一进一出:防线B-B1,COLORCYAN;
{STICKLINE(防线B-B1>0,防线B,B1,8,1),COLOR00FF00;}
妙趣横生:-一进一出,COLORRED;
{STICKLINE(防线B-B1<0,防线B,B1,8,1),COLORRED;}
卖出:(REF(一进一出,1)>0 AND 一进一出<=0) OR (一进一出<1 AND 一进一出>=0 AND C<O),COLORRED;
DRAWICON(卖出,36,1);
STICKLINE(卖出,0,28,1,0),COLORRED;
DRAWTEXT(卖出,30,'卖'),COLORMAGENTA;
买入:卖出=0 AND REF(一进一出,1)<0 AND 一进一出>0,COLORRED;
STICKLINE(买入,0,28,2,0),COLORYELLOW;
DRAWICON(买入,40,1);
DRAWTEXT(买入,30,'买'),COLORYELLOW;

通达信精准买卖提示指标公式

 

相关文章