在线检测未来函数

通达信埋伏主升浪主图指标公式

来源:Internet,编辑:股旁网,2014-12-11

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.001,0.050,0,GNBLOCK),COLORCYAN;{概念};
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停}
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通1:=AA*102/100;
通2:=AA*(200-102)/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:(1+7/100)*DD,DOTLINE,COLORGREEN;
下:(1-7/100)*DD,DOTLINE,COLORGREEN;
中:(上+下)/2,DOTLINE,COLORGREEN;
上上:EMA(上,181),DOTLINE,COLORRED;
下下:EMA(下,181),DOTLINE,COLORRED;
中中:EMA(中,181),DOTLINE,COLORRED;
STICKLINE(上>=上上,上,上上,0,0),COLORRED;
DRAWKLINE(H,O,L,C);
{IF((上 <= REF(上,1)),上,DRAWNULL),COLORGREEN,DOTLINE;
IF((上 > REF(上,1)),上,DRAWNULL),COLORRED,DOTLINE;
IF((中 <= REF(中,1)),中,DRAWNULL),COLORGREEN,DOTLINE;
IF((中 > REF(中,1)),中,DRAWNULL),COLORRED,DOTLINE;
IF((下 <= REF(下,1)),下,DRAWNULL),COLORGREEN,DOTLINE;
IF((下 > REF(下,1)),下,DRAWNULL),COLORRED,LINETHICK2;}
顶:=(1+14/100)*DD,LINETHICK2,COLORBLACK;
底:=(1-14/100)*DD,LINETHICK2,COLORBLACK;
触底:=REF(L,1)<底 AND ZT ;
DRAWTEXT(触底,L,'反转'),COLORCYAN;
STICKLINE(触底,C,O,3,1),COLORYELLOW;
STICKLINE(触底,C,O,1,0),COLORRED;
DF:=(C-REF(C,1))/REF(C,1)*100<-5;
DF4:=(C-O)/O*100<-4;
AAAA:=BARSLAST(DF);
乖离涨停1:=H>上 AND ZT AND CROSS(C,上);
DRAWTEXT(乖离涨停1,L,'爆'),COLORYELLOW;
STICKLINE(乖离涨停1,C,O,3,1),COLORYELLOW;
乖离涨停2:=O>上 AND ZT;
STICKLINE(乖离涨停2,C,O,3,1),COLORCYAN;
DRAWTEXT(乖离涨停2,L,'妖股'),COLORCYAN;

通达信埋伏主升浪主图指标公式

 

相关文章