在线检测未来函数

通达信私家波段英豪主图指标公式

来源:Internet,编辑:股旁网,2014-12-11

EMA5:EMA(C,5),COLORFF00FF,LINETHICK1;
EMA10:EMA(C,10),COLOR00FFFF,LINETHICK1;
EMA60:EMA(C,60),COLORFFFFFF,LINETHICK2;
EMA60上:IF(EMA60>=REF(EMA60,1),EMA60,DRAWNULL),COLORRED,LINETHICK2;
EMA60下:IF(EMA60<REF(EMA60,1),EMA60,DRAWNULL),COLOR006400,LINETHICK2;
DRAWBAND(EMA5,RGB(200,10,220),EMA10,RGB(0,200,0));
N:=5;N1:=21;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-3
*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1);
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
MM:=IF(VAR6A>N1,VAR6A-N1,0);
AA:= REF(MM,1)<MM;
BB:= REF(MM,1)>MM;
买入:DRAWICON(CROSS(MM,REF(MM,1)),L-0.2,1);
卖出:DRAWICON(CROSS(REF(MM,1),MM),H+0.2,2);
STICKLINE(AA,C,O,3,0),COLORRED;
STICKLINE(AA,H,L,0.5,0),COLORRED;
STICKLINE(BB,C,O,3,0),COLOR00FF00;
STICKLINE(BB,H,L,0.5,0),COLOR00FF00;
STICKLINE(AA,CLOSE,OPEN,4,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR3300CC;
STICKLINE(AA,CLOSE,OPEN,1.0,0),COLOR9900FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC00FF;
STICKLINE(AA,CLOSE,OPEN,0.2,0),COLOR66FFCC;
STICKLINE(BB,CLOSE,OPEN,4,0),COLOR993300;
STICKLINE(BB,CLOSE,OPEN,3.0,0),COLORCC3300;
STICKLINE(BB,CLOSE,OPEN,2.0,0),COLORFF3300;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLORFF6600;
STICKLINE(BB,CLOSE,OPEN,1.0,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,0.2,0),COLORFFFFFF;
STICKLINE(买入,O,(C-O)/2+O,4,0),COLOR335555;
STICKLINE(买入,O,(C-O)/2+O,2,0),COLOR338888;
STICKLINE(买入,O,(C-O)/2+O,1.5,0),COLOR33AAAA;
STICKLINE(买入,O,(C-O)/2+O,1,0),COLOR33CCCC;
STICKLINE(买入,O,(C-O)/2+O,0,0),COLOR33EEEE;
STICKLINE(卖出,O,(C-O)/2+O,4,0),COLOR550055;
STICKLINE(卖出,O,(C-O)/2+O,2,0),COLOR880088;
STICKLINE(卖出,O,(C-O)/2+O,1.5,0),COLORAA00AA;
STICKLINE(卖出,O,(C-O)/2+O,1,0),COLORCC00CC;
STICKLINE(卖出,O,(C-O)/2+O,0.5,0),COLOREE00EE;
黄昏之星:=((((((REF(CLOSE,2) / REF(OPEN,2)) > 1.03) AND (REF(OPEN,1) > REF(CLOSE,2))) AND ((ABS((REF(OPEN,1) - REF(CLOSE,1))) / REF(CLOSE,1)) < 0.02)) AND ((CLOSE / OPEN) < 0.97)) AND (CLOSE <REF(CLOSE,2)));
射击之星:=(((MIN(OPEN,CLOSE) = LOW) AND ((HIGH - LOW) > (3 * (MAX(OPEN,CLOSE) - LOW)))) AND (CLOSE > MA(CLOSE,5)));
锤头:=(((HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH - MIN(OPEN,CLOSE))))) AND (CLOSE < MA(CLOSE,5)));
吊颈:=(( (HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH - MIN(OPEN,CLOSE))))));
穿头破脚:=((((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN) < 0.96)) AND (CLOSE < REF(OPEN,1))) AND (OPEN > REF(CLOSE,1))) OR (((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) > 1.04)) AND (CLOSE > REF(OPEN,1))) AND (OPEN < REF(CLOSE,1))));
身怀六甲:=(((((ABS((REF(CLOSE,1) - REF(OPEN,1))) / REF(CLOSE,1)) > 0.04) AND ((ABS((CLOSE - OPEN)) / CLOSE) < 0.005)) AND (MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)))) AND (MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1))));
乌云盖顶:=(((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN) < 0.97)) AND (OPEN > REF(CLOSE,1))) AND (CLOSE < REF(CLOSE,1)));
曙光初现:=(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) > 1.03)) AND (OPEN < REF(CLOSE,1))) AND (CLOSE > REF(CLOSE,1)));
倾盆雨:=(((((REF(CLOSE,1) / REF(OPEN,1)) >= 1.03) AND (OPEN < REF(CLOSE,1))) AND (OPEN > REF(OPEN,1))) AND (CLOSE < REF(OPEN,1)));
DRAWTEXT(倾盆雨,H*1.03,'倾盆大雨'),COLORCYAN;DRAWTEXT(黄昏之星,H*1.02,'黄昏之星'),COLORCYAN;
DRAWTEXT(射击之星,H*1.03,'射击之星可能见顶'),COLORCYAN;
DRAWTEXT(锤头,L-L*0.02,'锤头可能见底'),COLORGREEN;
DRAWTEXT(吊颈,H*1.03,'吊颈'),COLORCYAN;DRAWTEXT(穿头破脚,H*1.05,'穿头破脚'),COLORCYAN;
DRAWTEXT(乌云盖顶,H*1.03,'乌云盖顶'),COLORCYAN;
DRAWTEXT(曙光初现,L-L*0.02,'曙光初现(放量)'),COLORGREEN;
DRAWTEXT(身怀六甲,L-L*0.02,'身怀六甲,底升顶落'),COLORGREEN;

通达信私家波段英豪主图指标公式

 

相关文章