在线检测未来函数

通达信资金和选股指标公式

来源:Internet,编辑:股旁网,2014-12-16

AJ:=VOL*CLOSE;
BJ:=SUM(AJ,1)/SUM(VOL,1);
B1J:=EMA(BJ,8);
主力J:=(BJ-B1J)*100/BJ;
DRAWBAND(主力J,RGB(250,180,80),0,RGB(0,180,180));
DRAWBAND(3*(EMA(C,3)-EMA(C,8)-EMA(EMA(C,3)-EMA(C,8),20))*2,RGB(250,0,00),0,RGB(0,80,180));
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,30);
MA4:=MA(CLOSE,60);
XG:COUNT(C>MA(C,5),3)=3{连续5日最低价大于5日均线} AND MA2>MA3 AND MA1>MA4 AND MA4>MA3 AND MA4>=MA2 AND REF(MA2,3)<REF(MA3,3);
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
低进:IF(黄金 AND RSVV<VARB2-2,2,0);
X:=(H-MAX(C,O))/ABS(C-O)>2 AND REF(L,1)/HHV(H,5)<0.96 AND REF(H,4)=REF(HHV(H,4),1) AND O/REF(C,1)>1.01 AND O/REF(C,1)<1.04;
SK:=COUNT(C/REF(C,1)<1.03,3)=3 AND REF(COUNT((C+O)<REF(C+O,1),2)=2,1) AND REF(HHV(H,20),1) =REF(HHV(H,4),1);
X4:=(H-MAX(C,O))/ABS(C-O)>2 AND REF(L,1)/HHV(H,6)<0.95 AND REF(H,5)=REF(HHV(H,5),1) AND O/REF(C,1)>1.01 AND O/REF(C,1)<1.04;
SK4:=COUNT(C/REF(C,1)<1.03,4)=4 AND REF(COUNT((C+O)<REF(C+O,1),3)=3,1) AND REF(HHV(H,20),1) =REF(HHV(H,5),1);
短线狙击:((X AND SK) OR (X4 AND SK4)) ;
MA111:=MA(CLOSE,20);
MA112:=MA(CLOSE,40);
MA113:=MA(CLOSE,60);
A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113;
A12:=C>MAX(MA111,MAX(MA112,MA113));
A13:=V/MA(V,30)>1.2;
A14:=C/REF(C,1)>1.049;
生命:=EXPMA(EXPMA(CLOSE,50),1);
半:=MA(CLOSE,125);
年:=MA(CLOSE,240);
涨幅%:=(C-REF(C,1))/REF(C,1)*100;
换手率%:=HSL;
条件:=C>生命 AND 生命>半 AND 半>年 AND 涨幅%>6.5 AND 换手率%>6;
黑马:=A11 AND A12 AND A13 AND A14 AND 条件;
MA5:=MA(CLOSE,120);
A:=MAX(MAX(MAX(MA1,MA2),MAX(MA3,MA4)),MA5);
B:=MIN(MIN(MIN(MA1,MA2),MIN(MA3,MA4)),MA5);
LL:=BARSLAST(O<=B AND C>=A )=0;
KK: LL AND 黑马;
M2:=EMA(C,2);
M18:=EMA(C,18);
买点:=IF(CROSS(M18,M2),5,0* 10000),COLORFF00FF,LINETHICK2;
明天卖:买点 AND 低进 COLORYELLOW,LINETHICK3;
KTB:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);
DTB:=SMA(KTB,3,1);
JTB:=3*KTB-2*DTB;
DI:="MACD.MACD">0;
准确出击:CROSS(CLOSE,REF(EMA(DMA((((HIGH+LOW)+(CLOSE*2))/4.15),0.9),3),1))AND JTB<55 AND DI;
X1:=(C-REF(C,1))/REF(C,1)*100>=3;
X2:=COUNT( EVERY(C>O,2),BARSLAST( EVERY(C>O,2)=0))=1&& EVERY(C>O,2);
预选:=(X1||X2)*4,COLORGREEN;{//选出放在自选池中关注}
X3:=X1&& EVERY(C>O,2);
X44:=CROSS(REF(C,1),L);
X5:=FILTER(X2||X3||X44,3)&&REF(X1,1);
低位介入:=(FILTER(X3||X5,3)&&REF(预选,1));
每日3%:预选 AND 低位介入;
买入必涨:(((((CLOSE / REF(CLOSE,1)) >= 1.07) AND ((HIGH / CLOSE) < 1.005)) AND ((MA (CLOSE,90) / CLOSE) >1.48)))*1.5;
VAR1D:=(INDEXC-MA(INDEXC,58))/MA(INDEXC,58)<-0.152;
VAR2D:=(C-EMA(C,58))/EMA(C,58)<-0.19;
中短买入:COUNT(VAR2D AND VAR1D,2);
AA8:=LLV(L,34);
XD:=SMA(ABS(L-REF(L,1)),34,1);
CD:=SMA(MAX(L-REF(L,1),0),34,2);
收盘买:=-(EMA(IF(L<=AA8,XD/CD,-3),9));
明天卖2:收盘买<0 AND 收盘买>REF(收盘买,1) AND REF(EVERY(收盘买<REF(收盘买,1),3),1);
CYC13:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYS:=(CLOSE-CYC13)/CYC13*100;
平衡:=0;
RSVX:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSVX,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A1:=CROSS(J,REF(J+0.01,1)) AND J<20;
YX:=C<O;
低点介入:"ZXNH.ZXNH" AND CYS<0 AND A1 AND REF(YX,1);
AA:=REF(MA(C,5),1)<MA(C,5) ;
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
BB:=CROSS(C,MA(C,5)) AND CROSS(C,MA(C,10)) ;
CC:=CROSS(C,MA(C,20)) AND REF(C<O,1) AND REF(C<O,2);
主升浪:(CROSS(FF,MA15) AND AA AND BB AND CC)*3,COLORRED ;
LC:=REF(CLOSE,1);
AAV:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
XGV:=CROSS(-13,AAV);
RSI:=(SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*20);
BBV:=MA(RSI,34);
CCV:=BBV-2.5*STD(RSI,34);
CF:=C>L;
成功率87.3%:(XGV AND CF AND RSI<CCV)*3,COLORGREEN;
A01:=(C-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3));
A11A:=SMA(A01,2,1);
A21:=SMA(A11A,2,1);
A31:=3*A11A-2*A21 ;
A41:=2*A31-0.5;
生命线:=C*(1-(A41-A21)/15),COLORBLUE,LINETHICK2;
A线:=HHV(H,20);
B线:=LLV(L,20);
C线:=(A线+B线)/2;
做多线:=IF(C线,C线,DRAWNULL)COLORFF00FF,LINETHICK2;
进场:(CROSS(生命线,做多线) AND REF(做多线,1)<做多线 AND C>生命线)*5;

通达信资金和选股指标公式

 

相关文章