在线检测未来函数

飞狐MACD合成指标公式

来源:Internet,编辑:股旁网,2014-12-17

获利:WINNER(C)*100,Color800080,LINETHICK,PRECISION2;
套牢:(WINNER(C*1.07)-WINNER(C*0.93))*85,COLORBLUE,LINETHICK,PRECISION2;
获利差:获利-套牢,COLORFFFFFF,LINETHICK,PRECISION2;
DIF:(EMA(CLOSE,12) - EMA(CLOSE,26)),Colorred,LINETHICK,PRECISION2;
DEA:EMA(DIF,9),COLORYELLOW,LINETHICK,PRECISION2;
MACD:=2*(DIF-DEA),COLORFFFFFF,LINETHICK,PRECISION2;
BIAS:EMA(C-REF(C,1),14)*2,Color000080,PRECISION2;
RSV14:=(CLOSE - LLV(LOW,14))/(HHV(HIGH,14) - LLV(LOW,14))-0.5;
K14:EMA(RSV14,3),COLORFFFFFF,LINETHICK,PRECISION2;
D14:EMA(K14,3),COLORGREEN,LINETHICK,PRECISION2;
J14:=3*K14-2*D14;
限制画线时限:=RANGE(BARPOS,SYSPARAM(3)-180,SYSPARAM(3)+1);
WLP:=WINNER(C)-0.5;
SCX:=(WINNER(C*1.07)-WINNER(C*0.93))*0.85-0.5;
ZSCC:=(WINNER(C)-(WINNER(C*1.07)-WINNER(C*0.93))/2*0.85)-0.5;
STICKLINE(限制画线时限 AND ZSCC<-0.5,ZSCC,-0.5,8,0),COLOR1477FF;
FILLRGN(DATATYPE>5 AND 限制画线时限,-0.5,SCX),ColorA00000;
FILLRGN(DATATYPE>5 AND 限制画线时限 AND WLP>SCX,SCX,WLP),Color800080;
FILLRGN(DATATYPE>5 AND 限制画线时限 AND WLP<=SCX,SCX,WLP),Color408000;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,3,0),COLOR000055;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,2,0),COLOR000099;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1,0),COLOR0000BB;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.5,0),COLOR0000DD;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,3,0),COLOR888888;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,2,0),COLORBBBBBB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1,0),COLORDDDDDD;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0.5,0),COLORFFFFFF;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,3,0),COLOR3377AA;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,2,0),COLOR3388BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1,0),COLOR4499CC;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.5,0),COLOR5599DD;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,3,0),COLORFF3300;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,2,0),COLORFF5500;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1,0),COLORFF7700;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.5,0),COLORFF9900;
STICKLINE(限制画线时限,0.4,0.4,3,0),COLORFFFFFF;
STICKLINE(限制画线时限,-0.4,-0.4,3,0),COLORFFFFFF;
PARTLINE(dea<=ref(DEA,1),Dea),COLORff0000,LINETHICK2;
PARTLINE(dea>ref(DEA,1),Dea),COLORYELLOW,LINETHICK2;
PARTLINE(DIF>ref(dif,1),DIF),Colorred,LINETHICK2;
PARTLINE(DIF<=ref(dif,1),DIF),Color008080,LINETHICK2;
K14,COLORFFFFFF;
D14,COLORGREEN;
STICKLINE(限制画线时限 AND J14<-0.5,-0.5,-0.4,8,0),COLORYELLOW;
AA:=COUNT(MA(V,10)<MA(V,30),10)=10;
BB:=CROSS(MA(V,5),MA(V,30));
量突:IF(AA AND BB,-0.3,-0.5),COLORRED,LINETHICK2;
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);
主力出现:IF(CROSS(VAR11,VAR12) AND (VAR11<40),0.2,0),COLOR4455ff,LINETHICK2;
KDJXG:=REF(COUNT(J14<REF(J14,1),5)>=3,1) AND REF(J14,1)<-0.4 AND J14>REF(J14,1);
DRAWICON(限制画线时限 AND FILTER(KDJXG,3),-0.44,8),ALIGN;
DRAWICON(限制画线时限 AND FILTER(KDJXG,3),-0.47,8),ALIGN;
DRAWICON(限制画线时限 AND FILTER(KDJXG,3),-0.5,8),ALIGN;
DRAWICON(CROSS(BIAS,0),0,4),ALIGN;
准备介入点:=ref(cross(0,macd),3) and count(dif>0 and macd<ref(macd,1),4)=4 ;
DRAWICON(准备介入点,macd*1.15,1),ALIGN;

飞狐MACD合成指标公式

 

相关文章