在线检测未来函数

通达信MACD狂生指标公式

来源:Internet,编辑:股旁网,2014-12-18

DIF1:=EMA(CLOSE,36)-EMA(CLOSE,78);
DEA1:=EMA(DIF1,27);
MACD1:=2*(DIF1-DEA1);
MACD2:=EMA(MACD1,3),COLORCYAN;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,0.5,1),COLORLIRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,0.5,1),COLORYELLOW;
STICKLINE(MACD1<MACD2,0,MACD1,0.5,1),COLORLIBLUE;
DIF:=EMA(CLOSE,24)-EMA(CLOSE,52);
DEA:=EMA(DIF,18);
MACD:=(DIF-DEA)*2;
DIF10:EMA(CLOSE,72)-EMA(CLOSE,156),COLORRED;
DEA10:EMA(DIF10,54),COLORGREEN;
DIF0:=EMA(CLOSE,24)-EMA(CLOSE,52),COLORWHITE;
DEA0:=EMA(DIF,18),COLORYELLOW;
底拐:DRAWLINE(DIF>=HHV(DIF,21),DIF,DIF<=LLV(DIF,21),DIF,0),COLORGREEN,CROSSDOT;
顶拐:DRAWLINE(DIF<=LLV(DIF,21),DIF,DIF>=HHV(DIF,21),DIF,0),COLORYELLOW,,CROSSDOT;
DRAWICON(底拐=LLV(DIF,21),底拐*0.97,23);
DRAWICON(顶拐=HHV(DIF,21),顶拐*1.03,14);
DIFX:EMA(CLOSE,12)-EMA(CLOSE,26),COLORWHITE;
DEAX:EMA(DIFX,9),COLORYELLOW;
MACDX:(DIFX-DEAX)*2,COLORSTICK;
LL3:=MA(C,18)LINETHICK2,COLORRED;
LL1:=EMA(C,220)LINETHICK2,COLORRED;
空:=EMA(C,3);
均衡:=EMA(空,3),COLORWHITE;
中轨:=HHV(MA(H,13),13),COLORYELLOW,LINETHICK1;
VAR5:=FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11);
DRAWTEXT(VAR5 AND LL3>REF(LL3,1) AND C>=LL3 AND C>LL1,DIF1*0.9985,'加仓'),COLORYELLOW;
DRAWICON(VAR5,DIF*0.995,15);
DRAWTEXT(VAR5 AND LL3>REF(LL3,1) AND C>=LL3 AND C<LL1,DIF1*0.9985,'反弹'),COLORLIMAGENTA;
BN:=ZIG(3,8);
GN:=REF(ZIG(3,8),1);
ZXCV:CROSS(REF(ZIG(3,8),1),ZIG(3,8))*0.1,COLORGREEN,LINETHICK2;
ZXC1:CROSS(ZIG(3,8),REF(ZIG(3,8),1))*0.1,COLORMAGENTA,LINETHICK2;

通达信MACD狂生指标公式

 

相关文章